Ubuntu Mate Firefox is old, how do I install NoScript?

Ask for help about NoScript, no registration needed to post
needMoarNoScript

Ubuntu Mate Firefox is old, how do I install NoScript?

Post by needMoarNoScript » Wed Jun 26, 2019 11:15 am

I spun up an Ubuntu Mate VM to use a browser that works (been having issues with Firefox and Waterfox), and I'd liek to at least get some minimal extensions installed so I don't get infected.

Privacy badger
HTTPS Everywhere
uBlock Origin
NoScript


Having problems with the noScript part because the firefox is so old.

I am on so many tangents to tangents that I'm almost forgetting what it is that i wanted to do. This is not an experiment, I'm not tinkering, I have stuff to get done and I'd like to get to it instead of get sucked into a rabit hole of linux updates etc etc rant rant

I can't find an old version of noscript that this firefox will install. The v5 on the main site won't install because it's not signed.

Isn't there a list of ALL the old versions somewhere? It's not on Firefox's add on site, that's for sure.
Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:52.0) Gecko/20100101 Firefox/52.0

barbaz
Senior Member
Posts: 9262
Joined: Sat Aug 03, 2013 5:45 pm

Re: Ubuntu Mate Firefox is old, how do I install NoScript?

Post by barbaz » Wed Jun 26, 2019 12:39 pm

needMoarNoScript wrote:
Wed Jun 26, 2019 11:15 am
The v5 on the main site won't install because it's not signed.
about:config > set xpinstall.signatures.required to false

viewtopic.php?f=7&t=25529&start=75

EDIT
Oh wait, you're probably using Firefox 52.0.1 or 52.0.2. You need Firefox 52 ESR.
*Always* check the changelogs BEFORE updating that important software!
-

Post Reply