Toolbar disabled, can't invoke NoScript menu

Ask for help about NoScript, no registration needed to post
ralfbergs
Posts: 4
Joined: Wed Jun 19, 2019 5:45 pm

Toolbar disabled, can't invoke NoScript menu

Post by ralfbergs » Wed Jun 19, 2019 1:42 pm

Hi guys.

I had a case where a page opened a pop-up window, and on that pop-up window the icon toolbar was disabled, so I couldn't click on the NoScript icon to whitelist JavaScript URLs embedded in that page. So I thought I could invoke the NoScript menu from the page's page context menu. Indeed, I found the NoScript menu item, but clicking it had no (apparent) effect.

Here's a screenshot:

https://imgur.com/a/Oj9OIg9
Image

Is this a bug in NoScript? I'm using version 10.6.3, the latest as of today.

Thanks for any help.
Last edited by barbaz on Wed Jun 19, 2019 4:02 pm, edited 1 time in total.
Reason: fix image
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

User avatar
therube
Ambassador
Posts: 7384
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: Toolbar disabled, can't invoke NoScript menu

Post by therube » Wed Jun 19, 2019 3:01 pm

(Image doesn't show. Maybe this will, https://i.imgur.com/ybPmQsM.png.)
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 5.1; rv:52.0) Gecko/20100101 SeaMonkey/2.49.5

User avatar
therube
Ambassador
Posts: 7384
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: Toolbar disabled, can't invoke NoScript menu

Post by therube » Wed Jun 19, 2019 3:01 pm

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 5.1; rv:52.0) Gecko/20100101 SeaMonkey/2.49.5

barbaz
Senior Member
Posts: 9096
Joined: Sat Aug 03, 2013 5:45 pm

Re: Toolbar disabled, can't invoke NoScript menu

Post by barbaz » Wed Jun 19, 2019 4:07 pm

therube wrote:
Wed Jun 19, 2019 3:01 pm
(Image doesn't show.
I fixed it.

@ralfbergs Try experimenting with these about:config settings -

Code: Select all

dom.disable_window_open_feature.personalbar
dom.disable_window_open_feature.titlebar
dom.disable_window_open_feature.toolbar
Does setting one or more of those to true get you a NoScript icon in the popup?
(It's unlikely all of them would be needed. Which one(s) you need depends on how you have your toolbar customised.)
*Always* check the changelogs BEFORE updating that important software!
-

ralfbergs
Posts: 4
Joined: Wed Jun 19, 2019 5:45 pm

Re: Toolbar disabled, can't invoke NoScript menu

Post by ralfbergs » Wed Jun 19, 2019 5:44 pm

Thanks for fixing the image.

I do have the icon in the menu, as you can see from my screenshot.

Unfortunately I can no longer reproduce that popup, so I can't do any testing.

The issue @therube mentioned could be related, but I'm not sure.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

barbaz
Senior Member
Posts: 9096
Joined: Sat Aug 03, 2013 5:45 pm

Re: Toolbar disabled, can't invoke NoScript menu

Post by barbaz » Wed Jun 19, 2019 6:01 pm

I have a local test page that generates that type of popup. If you show a screenshot of where exactly you've put the NoScript toolbar icon in a normal browser window, I could try to check it myself.
*Always* check the changelogs BEFORE updating that important software!
-

ralfbergs
Posts: 4
Joined: Wed Jun 19, 2019 5:45 pm

Re: Toolbar disabled, can't invoke NoScript menu

Post by ralfbergs » Wed Jun 19, 2019 6:33 pm

Many thanks for your efforts.

Here's where I have the icon:

https://imgur.com/a/cYh5K7W

Thanks in advance.
Last edited by barbaz on Wed Jun 19, 2019 6:44 pm, edited 1 time in total.
Reason: remove duplicate image link
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

barbaz
Senior Member
Posts: 9096
Joined: Sat Aug 03, 2013 5:45 pm

Re: Toolbar disabled, can't invoke NoScript menu

Post by barbaz » Wed Jun 19, 2019 6:41 pm

about:config > set dom.disable_window_open_feature.toolbar to true

Should be enough. Now you should see a >> button, click that and you should find the NoScript toolbar icon.
(NoScript's context menu item still didn't work for me.)
*Always* check the changelogs BEFORE updating that important software!
-

ralfbergs
Posts: 4
Joined: Wed Jun 19, 2019 5:45 pm

Re: Toolbar disabled, can't invoke NoScript menu

Post by ralfbergs » Wed Jun 19, 2019 7:28 pm

Did that, thanks. But as I said, can't test it at the moment... I will simply trust that what you said is true... :-)

Many thanks again.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

Post Reply