'privileged page'

Ask for help about NoScript, no registration needed to post
anastrophe
Posts: 3
Joined: Fri May 24, 2019 9:31 pm

'privileged page'

Post by anastrophe » Fri May 24, 2019 9:41 pm

I've searched and read the various topics here, as well as those referenced to mozilla, and i cannot seem to 'crack' this issue.

I receive daily news updates from reuters.com. You can click on a linked story to view it in browser. Sometime in the last few months, either something changed with the reuters links, or something changed in noscript - I dunno which.

But now, when I click on a link, I get a completely blank page, and noscript reports that "This is a privileged page, whose permissions cannot be configured."

Everything is enabled in per-site definitions to allow reuters and content (has been since i first subscribed). The only way I can get the page to display is to disable the noscript extension, which just isn't practical to do (nor desireable).

Here's an example link:

https://newslink.reuters.com/click/1699 ... fB5894a9ea

Is there any way to get these pages working again? My only alternative that I use currently is to copy the url and paste it into a different browser.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

anastrophe
Posts: 3
Joined: Fri May 24, 2019 9:31 pm

Re: 'privileged page'

Post by anastrophe » Fri May 24, 2019 9:43 pm

Interestingly, after posting this, I clicked on the link I included in the post - and the page comes up. But if I copy the link from there and paste it into the browser - same 'privileged page' warning and blank.

I'm baffled here.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

Guest

Re: 'privileged page'

Post by Guest » Fri May 24, 2019 11:22 pm

I have just started having what looks like the same problem or else one VERY similar. My problem only occurs on one site (Amazon.com), but one which is important to me and which I use a lot. If I open a new tab and click on my Amazon bookmark icon on my bookmarks toolbar I just get a blank, white page which says “privileged page”. If I type Amazon.com into the address bar, I get the same result.

If I go to an existing, open tab however, clicking on the bookmark or typing Amazon.com into the address bar simply results in no change to the open tab. The existing tab continues to display the current page (and Noscript retains the settings for the existing page in that case) and doesn’t display “privileged page”. FF doesn't seem to make any attempt to load Amazon.com over the existing page.

The only way I can access Amazon.com in either case if Noscript is active is to go to a Google screen and access Amazon.com through Google or use a different browser. If I disable the Noscript extension, I have no problems accessing Amazon.com through either my bookmark or the address bar and in either a new tab or an existing tab. Noscript is fully configured in site definitions to allow (trust) Amazon.com in all cases. Amazon.com is also the ONLY site (out of a considerable number) which I have found so far which displays this problem.

I am using FF 67, Windows 10 and Noscript 10.6.2 currently and the problem also occurred on FF 66.0.0.5. I tried creating a new profile and thought I had the problem solved. As soon as I added the Noscript extension, the problem re-occurred on the new profile.

I share anastrophe’s frustration and don’t want to run with Noscript disabled. It is also a major annoynance to have to go through Google to access Amazon.com. I simply can’t imagine why the problem is occurring on just the one site (Amazon) and nowhere else. Is this possibly a bug in Noscript or is something else going on? Thanks for any help.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

guest

Re: 'privileged page'

Post by guest » Sat May 25, 2019 1:55 am

I discovered that if I go to Noscript/Options/Advanced and uncheck "sanitize suspicious cross-site requests", I no longer have any problems with the Amazon site (with Noscript active) that I described in the previous post. I don't know if doing that will fix anastrophe's problem but I am going to keep running that way for the time being. It gives me a little less security but it's better than running with Noscript disabled completely.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

anastrophe
Posts: 3
Joined: Fri May 24, 2019 9:31 pm

Re: 'privileged page'

Post by anastrophe » Sat May 25, 2019 2:11 am

That did the trick! Looks like it's not terribly killer if it's disabled based on the faq. Thanks!
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

Post Reply