Question mark *always* on NS icon

Ask for help about NoScript, no registration needed to post
bernie
Posts: 2
Joined: Fri Mar 17, 2017 2:28 am

Question mark *always* on NS icon

Post by bernie » Mon May 20, 2019 1:13 am

I think beginning recently [like a day or so back] NS now seems never to do anything: the status icon just is the S with a question mark superimposed. I can't figure out if it my browser is always running JS or if something else has blocked JS [firefox 66.0.5/64 on win10]. The on AV I'm running is Windows Defender.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

barbaz
Senior Member
Posts: 9044
Joined: Sat Aug 03, 2013 5:45 pm

Re: Question mark *always* on NS icon

Post by barbaz » Mon May 20, 2019 3:38 am

If you click the NS icon, what do you get?

Does this issue occur in a new, clean Firefox profile?
bernie wrote:
Mon May 20, 2019 1:13 am
I can't figure out if it my browser is always running JS or if something else has blocked JS
Go to https://enable-javascript.com/, what does it say about status of Javascript in your browser?
*Always* check the changelogs BEFORE updating that important software!
-

bernie
Posts: 2
Joined: Fri Mar 17, 2017 2:28 am

Re: Question mark *always* on NS icon

Post by bernie » Mon May 20, 2019 10:16 am

Nothing. I click on the S icon and no drop down, no nothing. /b\
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

gak1234

Re: Question mark *always* on NS icon

Post by gak1234 » Mon Jun 03, 2019 11:26 pm

Same problem
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

gak1234

Re: Question mark *always* on NS icon

Post by gak1234 » Mon Jun 03, 2019 11:32 pm

I fixed mine by uninstalling the plugin, EXITING FIREFOX, re-launching, and installing the plugin from the noscript direct download link:
https://secure.informaction.com/downloa ... 10.6.2.xpi

Before I tried the above fix, I uninstalled the plugin and reinstalled it WITHOUT quitting Firefox in between, and it did NOT fix the problem.
Fortunately, my NoScript preferences/settings were NOT lost during these operations - I would have been extremely upset if I had to re-customize hundreds of sites!
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

barbaz
Senior Member
Posts: 9044
Joined: Sat Aug 03, 2013 5:45 pm

Re: Question mark *always* on NS icon

Post by barbaz » Tue Jun 04, 2019 3:13 am

gak1234 wrote:
Mon Jun 03, 2019 11:32 pm
I fixed mine by uninstalling the plugin, EXITING FIREFOX, re-launching, and installing the plugin from the noscript direct download link:
For anyone else who wants to try this fix: *first* export your NoScript settings as a backup: NoScript Options > Export. Although gak1234's NoScript settings remained intact; last I checked, persisting NoScript settings through uninstall/reinstall of NoScript is not guaranteed.
*Always* check the changelogs BEFORE updating that important software!
-

Post Reply