Problematic Rule-Setting Process on Amazon Mechanical Turk

Ask for help about NoScript, no registration needed to post
NginUS
Posts: 3
Joined: Wed Nov 17, 2010 11:23 pm

Problematic Rule-Setting Process on Amazon Mechanical Turk

Post by NginUS » Sat May 04, 2019 7:16 pm

Most every job on Amazon Mechanical Turk uses its own domain, & I have problems obtaining authorization codes because they're often blocked. A whitelist/reload nullifies the code & I'm out a payment, or worse getting a rejection on my account due to the error.

Ideally, I'd like to be able to set NoScript to de-activate on all links launched from 'foo' URL, but I don't see a way to do that. Disabling & Re-enabling the add-on in the Firefox menu is cumbersome at best.

Does anyone have mTurk working consistently with NoScript?

Could use a hand...


TIA
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:66.0) Gecko/20100101 Firefox/66.0

barbaz
Senior Member
Posts: 9176
Joined: Sat Aug 03, 2013 5:45 pm

Re: Problematic Rule-Setting Process on Amazon Mechanical Turk

Post by barbaz » Sat May 04, 2019 11:00 pm

Have you tried selecting "Disable restrictions for this tab" and afterwards visiting the site in that tab?
*Always* check the changelogs BEFORE updating that important software!
-

NginUS
Posts: 3
Joined: Wed Nov 17, 2010 11:23 pm

Re: Problematic Rule-Setting Process on Amazon Mechanical Turk

Post by NginUS » Sat May 04, 2019 11:02 pm

barbaz wrote:
Sat May 04, 2019 11:00 pm
Have you tried selecting "Disable restrictions for this tab" and afterwards visiting the site in that tab?
Yea, but the other 'global' one allows the new tabs that that tab creates to be uninterrupted. Would like to have a 'just this tab' with 'and child tabs'. As is I forget to turn it back on but that's my problem, eventually it'll be a habit I guess.
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:66.0) Gecko/20100101 Firefox/66.0

Post Reply