Unable to install Noscript

Ask for help about NoScript, no registration needed to post
GB George

Unable to install Noscript

Post by GB George » Sat May 04, 2019 4:40 am

Hi It looks like Firefox is blocking installations. "comes up unable to download check your connections"
The same thing happened to my add blocker pro.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0

Cobranut

Re: Unable to install Noscript

Post by Cobranut » Sat May 04, 2019 4:46 am

Starting today I'm having the same issue.
I had it working great, but apparantly Firefox updated and all my addons are disabled, and cannot be reenabled.
Only option is to remove.
I tried to install the new NoScript security suite, but firefox is blocking this, and it seems all other downloads.
What the hell is wrong with Mozilla??? I had a browser that worked fine, and they made it unusable. SMH

Anyone have a work-around?
Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

Non_member

Re: Unable to install Noscript

Post by Non_member » Sat May 04, 2019 5:09 am

In one of my Firefox 66.0.3 f/win x64 profiles NoScript 10.6.1 was moved from "Extensions" folder to "Unsupported" folder, the reason:

"NoScript could not be verified for use in Firefox and has been disabled"

"More Information" links to:
https://support.mozilla.org/en-US/kb/ad ... =inproduct
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

v43

Re: Unable to install Noscript

Post by v43 » Sat May 04, 2019 5:19 am

This is disappointing, I trust that a workaround will be coming soon. Noscript is the sole reason I use firefox.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

Guest

Re: Unable to install Noscript

Post by Guest » Sat May 04, 2019 6:10 am

+1
Mozilla/5.0 (Windows NT 6.1; rv:60.0) Gecko/20100101 Firefox/60.0

smashly

Re: Unable to install Noscript

Post by smashly » Sat May 04, 2019 6:54 am

Same here,
Was working fine and then firefox just excluded it on it's own.
Now it just won't uinstall, same errors as prior posters above.

Odd as my firefox I hadn't updated at all and had the updater actually removed as well..
So it has to be something FF is doing on their end,
Not impressed at all with FF as it has become a nasty browser to use with it's over abundant babysitting methodology/nagging and less and less user control.
Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

Stevo

Re: Unable to install Noscript

Post by Stevo » Sat May 04, 2019 7:06 am

Yes the same with me this morning. Firefox removed noscript and Avast safe browser.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

Xarope

Re: Unable to install Noscript

Post by Xarope » Sat May 04, 2019 7:07 am

Me too, i use FF 66.0.3
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

Stevo

Re: Unable to install Noscript

Post by Stevo » Sat May 04, 2019 7:10 am

Stevo wrote:
Sat May 04, 2019 7:06 am
Yes the same with me this morning. Firefox removed noscript and Avast browser security
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

musonius
Senior Member
Posts: 103
Joined: Sun Jul 08, 2018 5:38 pm

Re: Unable to install Noscript

Post by musonius » Sat May 04, 2019 7:35 am

Giorgio Maone's twitter posting about the problem: https://twitter.com/ma1/status/1124586336055431168

Sorry, my extensions are working fine, I read the obviously wrong information elsewhere and made the mistake to post this without verifying it myself.

Mozilla had a technical problem that caused all extensions to be disabled and none to be installed. The problem has been fixed in the meantime.
Last edited by musonius on Sat May 04, 2019 8:45 am, edited 1 time in total.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

User avatar
Giorgio Maone
Site Admin
Posts: 8700
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: Unable to install Noscript

Post by Giorgio Maone » Sat May 04, 2019 8:30 am

musonius wrote:
Sat May 04, 2019 7:35 am
The problem has been fixed in the meantime.
Is the fix already deployed? I cannot install NoScript yet, neither from AMO or from https://noscript.net/getit

As soon as I woke up this morning and found about it (apparently happened just after I went to sleep :( ) tweeted this.

At this moment the safest browsing option seems TEMPORARILY switching to Chromium and installing https://chrome.google.com/webstore/deta ... cbfeoakpjm (unfortunately not the exactly the same, as it uses the built-in XSS auditor instead of NoScript's XSS filter). Silver lining: more cross-browser beta testers won't hurt.
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:67.0) Gecko/20100101 Firefox/67.0

jag

Re: Unable to install Noscript

Post by jag » Sat May 04, 2019 8:42 am

Same here,
all of my addins went dumped there.
I read that FF is changing policy regarding obfuscated code. Maybe they touched some code zone regarding addin vetting and it went south?
Version : Quantum 66.0.3 64bit, no update pending.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

musonius
Senior Member
Posts: 103
Joined: Sun Jul 08, 2018 5:38 pm

Re: Unable to install Noscript

Post by musonius » Sat May 04, 2019 8:53 am

Giorgio Maone wrote:
Sat May 04, 2019 8:30 am
Is the fix already deployed? I cannot install NoScript yet, neither from AMO or from https://noscript.net/getit
I am very sorry for spreading the obviously wrong message without verifying it myself good enough. :oops:

Since I cannot install NoScript on a new profile, too, I have edited my comments and try to not make that mistake again.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

None

Re: Unable to install Noscript

Post by None » Sat May 04, 2019 9:19 am

Temporary workaround:

Go to the local page of Firefox about:config
and set false for xpinstall.signatures.required
Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0

smashly

Re: Unable to install Noscript

Post by smashly » Sat May 04, 2019 10:11 am

I was one of the suckers that uninstalled noscript and tried updating ff, then discovered the bug is FF and certificate signing.
Which meant I could not re-install NoScript...doh

My resolve so far was to:
1. Exit Firefox andwind the clock back a couple of days
2. Open Firefox and go to about:config and set xpinstall.signatures.required to false.
3. Install noscript.
4. Exit Firefox and restore my date back to the correct date.
Done...

NoScript working as it use to.
Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

Locked