Firefox deactivates NoScript...and calls it Legacy

Ask for help about NoScript, no registration needed to post
AuntyJack.AU

Re: Firefox deactivates NoScript...and calls it Legacy

Post by AuntyJack.AU » Sun May 05, 2019 11:23 am

I removed NoScript before reading here I shouldn't have... and now can't get it back either by direct download or through the add-ons page. Any suggestions (other than "get a better browser")?
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

qwerty

Re: Firefox deactivates NoScript...and calls it Legacy

Post by qwerty » Sun May 05, 2019 12:21 pm

run:
storage.googleapis.com/moz-fx-normandy-prod-addons/extensions/hotfix-update-xpi-intermediate@mozilla.com-1.0.2-signed.xpi
works immediately
Last edited by barbaz on Sun May 05, 2019 2:29 pm, edited 1 time in total.
Reason: kill confusing board-generated link
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

GBgeorge
Posts: 1
Joined: Sun May 05, 2019 12:00 pm

Re: Firefox deactivates NoScript...and calls it Legacy

Post by GBgeorge » Sun May 05, 2019 12:29 pm

Hi everyone, I think Firefox not in the hurry to fix this issue. most likely they don't want us to block their unwonted popups, and advertisement.
Before this I never had popups and advertising from any social media website,not even in U-torrent. Now I get popups from everywhere.
Well this quick fix worked for me, without changing any of my settings.I changed my time setting on my PC to 30th of April this year and everything installed perfectly. I'll keep this only until some fix by Firefox comes into place. If it does just change the time back.
Regards
GB
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0

Guest

Re: Firefox deactivates NoScript...and calls it Legacy

Post by Guest » Sun May 05, 2019 1:44 pm

I have the same issue. Firefox deactivated ALL of my Security (Ublock, Noscript ). But thats not the Point. Since this Update yesterday Firefox also refuses to install them new ... and now comes the point : After deinstalling FF-67 and rollback to FF-64 ! The Devs seems to going completely mad !
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

ChromeSux

Re: Firefox deactivates NoScript...and calls it Legacy

Post by ChromeSux » Sun May 05, 2019 3:05 pm

Purely speculative: Could be a coordinated effort to get some tracking scripts to run as there might be an operation running. If there are any security researchers out there they should set up some honey pots and see what flies start to buzz in.

As a workaround I am closing down my Firefox until this gets fixed and switching over to SeaMonkey browser using the legacy NoScript https://noscript.net/getit (scroll down for download.)
Mozilla/5.0 (Windows NT 6.1; rv:60.0) Gecko/20100101 Firefox/60.0

barbaz
Senior Member
Posts: 9230
Joined: Sat Aug 03, 2013 5:45 pm

Re: Firefox deactivates NoScript...and calls it Legacy

Post by barbaz » Sun May 05, 2019 3:20 pm

GBgeorge wrote:
Sun May 05, 2019 12:29 pm
I think Firefox not in the hurry to fix this issue. most likely they don't want us to block their unwonted popups, and advertisement.
ChromeSux wrote:
Sun May 05, 2019 3:05 pm
Purely speculative: Could be a coordinated effort to get some tracking scripts to run as there might be an operation running. If there are any security researchers out there they should set up some honey pots and see what flies start to buzz in.
Conspiracy theories and speculation regarding motives are not constructive. Please keep this thread limited to known facts and workarounds regarding this Firefox issue. Thanks.
*Always* check the changelogs BEFORE updating that important software!
-

Zeugma

Re: Firefox deactivates NoScript...and calls it Legacy

Post by Zeugma » Sun May 05, 2019 3:36 pm

barbaz wrote:
Sun May 05, 2019 3:20 pm
Conspiracy theories and speculation regarding motives are not constructive. Please keep this thread limited to known facts and workarounds regarding this Firefox issue. Thanks.
Known facts: "A few hours ago a security certificate that Mozilla used to sign Firefox add-ons expired. What this means is that every add-on signed by that certificate, which seems to be nearly all of them, will now be automatically disabled by Firefox as security measure.

In simpler terms, Firefox doesn't trust any add-ons right now."
:geek: just wait.
Update: https://www.reddit.com/r/firefox/commen ... ons_being/
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

grau
Posts: 1
Joined: Sun May 05, 2019 3:36 pm

Re: Firefox deactivates NoScript...and calls it Legacy

Post by grau » Sun May 05, 2019 3:39 pm

qwerty wrote:
Sun May 05, 2019 12:21 pm
run:
storage.googleapis.com/moz-fx-normandy-prod-addons/extensions/hotfix-update-xpi-intermediate@mozilla.com-1.0.2-signed.xpi
works immediately
This works! Seriously, thanks so much. The previous methods weren't working for me, but I just copied that line and a prompt for an update showed up.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

Snoggle

Re: Firefox deactivates NoScript...and calls it Legacy

Post by Snoggle » Sun May 05, 2019 5:04 pm

Hi guys I doubt that the real fix can be found without changing the browser architecture and decentralization of app verification.
I did ALL the steps described here and after 24 hours everything is still gone...
So, I depend on this and got no time for bs.
Downloaded Waterfox and opened extension xpi files with it and installed them *******bingo********
keep screenshot of your passwords and a copy of your Firefox profile folder together with your XPI files for later (hopefully)
NoScript works on waterfox and so do the others... ;-)
At least I have now a fully functional backup browser while the dimwits try and do their homework.
unhide your folders (windows) go to user, yourname, appdata,roaming,mozilla,firefox,your.profile,extensions
to get to xpi - keep a copy of your profile and uninstall Firefox and delete all traces
Later we will re-install FF and see...
All the best
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

Snoggle

Re: Firefox deactivates NoScript...and calls it Legacy

Post by Snoggle » Sun May 05, 2019 5:14 pm

Forgot to say -- keep a copy of your bookmarks by exporting them to html and for easy import into waterfox
all the best and stay safe!
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

Batman2000

Re: Firefox deactivates NoScript...and calls it Legacy

Post by Batman2000 » Sun May 05, 2019 5:43 pm

Hi

You can disable the signature check in FF to allow the add-on again.
But only do this if you trust the add-on.

in about:config
Set xpinstall.signatures.required to false

More info about the setting: https://wiki.mozilla.org/Addons/Extension_Signing
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

Rankor
Posts: 1
Joined: Sun May 05, 2019 6:22 pm

Re: Firefox deactivates NoScript...and calls it Legacy

Post by Rankor » Sun May 05, 2019 6:23 pm

THX alot m8!!!
Giorgio Maone wrote:
Sat May 04, 2019 8:54 pm
If you're experiencing this right now on Firefox, do this for the hotfix to immediately apply (it happened to me minutes ago on my main profile):
  1. Open about:config
  2. Turn app.shield.optoutstudies.enabled to true (if false)
  3. Turn app.normandy.run_interval_seconds to 1
As soon as you can see all your add-ons coming back (it should happen right away), reset both preferences.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

Guest

Re: Firefox deactivates NoScript...and calls it Legacy

Post by Guest » Sun May 05, 2019 8:08 pm

I've tried fix suggested here with no results.
This issue is also affecting page loads that require a manual changes such as "temp trusted". These pages will not load.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

musonius
Senior Member
Posts: 107
Joined: Sun Jul 08, 2018 5:38 pm

Re: Firefox deactivates NoScript...and calls it Legacy

Post by musonius » Sun May 05, 2019 9:07 pm

The new version 66.0.4 has arrived and here are the release notes.
Repaired certificate chain to re-enable web extensions that had been disabled
The problem should be fixed now.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

Alf

Re: Firefox deactivates NoScript...and calls it Legacy

Post by Alf » Mon May 06, 2019 2:58 am

What options do I have if I want to use an unsigned add-on (advanced users)?

The Developer Edition version and the Nightly version of Firefox allow you to override the settings that require you to sign the add-ons if you change the preference xpinstall.signatures.required to false in the Firefox configuration editor (about: config page). To ignore the requirement to sign language packs, you have to set the preference extensions.langpacks.signatures.required as false. There are also special versions not belonging to Firefox that allow you to override that configuration. You can check out this article from MozillaWiki for more information.

https://support.mozilla.org/es/kb/firma ... en-firefox

moderator edit: English version of that link is https://support.mozilla.org/en-US/kb/ad ... nced-users
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:66.0) Gecko/20100101 Firefox/66.0

Post Reply