Firefox deactivates NoScript...and calls it Legacy

Ask for help about NoScript, no registration needed to post
BillM
Posts: 4
Joined: Wed Jun 04, 2014 5:32 pm

Re: Firefox deactivates NoScript...and calls it Legacy

Post by BillM » Sat May 04, 2019 7:38 pm

"It took 2 restarts"... of Firefox, or your computer??
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

User avatar
Giorgio Maone
Site Admin
Posts: 8715
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: Firefox deactivates NoScript...and calls it Legacy

Post by Giorgio Maone » Sat May 04, 2019 8:54 pm

If you're experiencing this right now on Firefox, do this for the hotfix to immediately apply (it happened to me minutes ago on my main profile):
  1. Open about:config
  2. Turn app.shield.optoutstudies.enabled to true (if false)
  3. Turn app.normandy.run_interval_seconds to 1
As soon as you can see all your add-ons coming back (it should happen right away), reset both preferences.
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:67.0) Gecko/20100101 Firefox/67.0

davidpbrown
Posts: 9
Joined: Wed Jan 21, 2015 12:58 pm

Re: Firefox deactivates NoScript...and calls it Legacy

Post by davidpbrown » Sat May 04, 2019 9:00 pm

Can't resist a simple thank you post!.. NoScript is essential these days and this was a surprise just now.
Great to see a simple fix so promptly. :D
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:66.0) Gecko/20100101 Firefox/66.0

User avatar
therube
Ambassador
Posts: 7431
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: Firefox deactivates NoScript...and calls it Legacy

Post by therube » Sat May 04, 2019 9:22 pm

For FF 56, & even though a "fix" came through from Mozilla (surprisingly), it does not "fix" anything.
NoScript will not work without applying the "hack".

It is the same as it was before, 5.1.8.7rc4 is not signed.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0 SeaMonkey/2.49.5

GuestK

Re: Firefox deactivates NoScript...and calls it Legacy

Post by GuestK » Sat May 04, 2019 9:37 pm

Already did that (just changed seconds to 1, studies was set to true already) but still waiting for plugins to come back =S. Already restarted Firefox like 4 times and restarted pc once
Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/73.0.3683.103 Safari/537.36

User avatar
Giorgio Maone
Site Admin
Posts: 8715
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: Firefox deactivates NoScript...and calls it Legacy

Post by Giorgio Maone » Sat May 04, 2019 10:08 pm

GuestK wrote:
Sat May 04, 2019 9:37 pm
Already did that (just changed seconds to 1, studies was set to true already) but still waiting for plugins to come back =S. Already restarted Firefox like 4 times and restarted pc once
If the hotfix is already shown in about:studies but still no extensions, either you removed them while trying to fix this (and you need to reinstall them) or that's an instance of this bug.
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:67.0) Gecko/20100101 Firefox/67.0

Dudelin

NoScript deactivated

Post by Dudelin » Sat May 04, 2019 11:51 pm

Starting in Firefox version 57, only extensions built using WebExtensions APIs will work. Its seems that this was being worked on sometime ago, but confusing to look at forum. Is this being updated to work now, or do I need to find something else??? I've always trusted NoScript and although frustrating to use at times, felt it was well worth the effort! Simply, is it being revised and how long need I wait???
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

Dudelin

Re: Firefox deactivates NoScript...and calls it Legacy

Post by Dudelin » Sun May 05, 2019 12:17 am

Just wrote re deactivation a few minutes ago. Then noticed the fix w/about:config. The first line was correct. The 2nd I changed to "1". Clicked OK. The change happened quickly. <G> Went back and changed the 1 to original number and still working ! Great. Haven't restarted FireFox as yet; hoping the fix will stay fixed.... Tks much, Admin!
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

Skeezix
Senior Member
Posts: 54
Joined: Fri Jan 21, 2011 1:23 am

Re: Firefox deactivates NoScript...and calls it Legacy

Post by Skeezix » Sun May 05, 2019 1:23 am

Well, like a dumb-a$$ :( , I didn't write down the original value. I think it was 12xxx but am not sure, so I just entered "12000". Could somebody please tell me what the original value is?
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

-MelVin-

Re: Firefox deactivates NoScript...and calls it Legacy

Post by -MelVin- » Sun May 05, 2019 2:03 am

Skeezix wrote:
Sun May 05, 2019 1:23 am
Well, like a dumb-a$$ :( , I didn't write down the original value. I think it was 12xxx but am not sure, so I just entered "12000". Could somebody please tell me what the original value is?
21600
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

pricklypeople

Re: Firefox deactivates NoScript...and calls it Legacy

Post by pricklypeople » Sun May 05, 2019 3:33 am

Thank you for the instructions on how to set studies on and especially the reminder to turn it of again, worked like a charm, on my slow connection it took only a few minutes. Firefox simply suggests turning it on an waiting a few hours/days!? And is not telling people that they could turn it back off, you're a life saver again, happy to have your wonderful add on back on again!
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

Miranda99

Re: Firefox deactivates NoScript...and calls it Legacy

Post by Miranda99 » Sun May 05, 2019 7:53 am

Glad to find this discussion, but I believe it should be clearly linked from the noscript.net home page.
A lot of people are pretty lost right now.
Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

davidpbrown
Posts: 9
Joined: Wed Jan 21, 2015 12:58 pm

Re: Firefox deactivates NoScript...and calls it Legacy

Post by davidpbrown » Sun May 05, 2019 10:05 am

Giorgio Maone wrote:
Sat May 04, 2019 8:54 pm
If you're experiencing this right now on Firefox, do this for the hotfix to immediately apply (it happened to me minutes ago on my main profile):
  1. Open about:config
  2. Turn app.shield.optoutstudies.enabled to true (if false)
  3. Turn app.normandy.run_interval_seconds to 1
As soon as you can see all your add-ons coming back (it should happen right away), reset both preferences.
While this works well on PC..
I see this now on mobile and wonder neither option is available in about:config ..
is there an alternate solution then for mobile Firefox on Android?
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:66.0) Gecko/20100101 Firefox/66.0

User avatar
Giorgio Maone
Site Admin
Posts: 8715
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: Firefox deactivates NoScript...and calls it Legacy

Post by Giorgio Maone » Sun May 05, 2019 10:08 am

-MelVin- wrote:
Sun May 05, 2019 2:03 am
Skeezix wrote:
Sun May 05, 2019 1:23 am
Well, like a dumb-a$$ :( , I didn't write down the original value. I think it was 12xxx but am not sure, so I just entered "12000". Could somebody please tell me what the original value is?
21600
Or, as with any about:config preference, you can just use the "Reset" command (context menu item) to restore its original value.

Speaking of about:config, on Firefox for Android there's no hotfix, but at least on the Beta which I'm using you can turn off signature verification just like you do in the Tor Browser (xpinstall.signatures.required=false).
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:67.0) Gecko/20100101 Firefox/67.0

davidpbrown
Posts: 9
Joined: Wed Jan 21, 2015 12:58 pm

Re: Firefox deactivates NoScript...and calls it Legacy

Post by davidpbrown » Sun May 05, 2019 10:16 am

Giorgio Maone wrote:
Sun May 05, 2019 10:08 am
Speaking of about:config, on Firefox for Android there's no hotfix, but at least on the Beta which I'm using you can turn off signature verification just like you do in the Tor Browser (xpinstall.signatures.required=false).
and thanks again that worked well for Android.

I wonder still why and how this happened.. and why Firefox doesn't recognise NoScript is a large critical part of what makes Firefox a better user experience. 8-)
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:66.0) Gecko/20100101 Firefox/66.0

Post Reply