Firefox deactivates NoScript...and calls it Legacy

Ask for help about NoScript, no registration needed to post
Xarope

Re: Firefox deactivates NoScript...and calls it Legacy

Post by Xarope » Sat May 04, 2019 7:33 am

Hallo Olivia,
problem liegt wohl an einem ausgelauendem Zertifikat.
Mozilla, kennt das problem wohl und arbeitet dran.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

Xarope

Re: Firefox deactivates NoScript...and calls it Legacy

Post by Xarope » Sat May 04, 2019 7:34 am

Hat nixs mit NoScript zu tun, andere Add-Ons sind auch betroffen.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

musonius
Senior Member
Posts: 98
Joined: Sun Jul 08, 2018 5:38 pm

Re: Firefox deactivates NoScript...and calls it Legacy

Post by musonius » Sat May 04, 2019 7:41 am

Giorgio Maone's twitter posting about the problem: https://twitter.com/ma1/status/1124586336055431168

Sorry, my extensions are working fine, I read the obviously wrong information elsewhere and made the mistake to post this without verifying it myself.

Mozilla had a technical problem that caused all extensions to be disabled and none to be installed. The problem has been fixed in the meantime.
Last edited by musonius on Sat May 04, 2019 8:45 am, edited 1 time in total.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

NITRO

Re: Firefox deactivates NoScript...and calls it Legacy

Post by NITRO » Sat May 04, 2019 8:14 am

A little Hotfix for those who don't want use FF whithout NoScript.

Use "about:debugging" and load AddOn temporary.
The *.xpi files for your extentions are under "C:\Users\<USERNAME>\AppData\Roaming\Mozilla\Firefox\Profiles\<PROFILE-NAME>\extensions".
The one for NoScript is by me a unknown combination of characters and numbers, you can try it and remove it, if it is not NoScript.

Ein kleiner Hotfix für alle die FF nicht ohne NoScript nutzen wollen.

Gebt "about:debugging" in die Adressleiste ein, dort könnte ihr AddOns temporär laden.
Die entsprechenden *.xpi Dateien für eure Erweiterungen findet man unter "C:\Users\<USERNAME>\AppData\Roaming\Mozilla\Firefox\Profiles\<PROFILE-NAME>\extensions".
Die für NoScript ist bei mir eine (gefühlt zufällige) kombination aus Buchstaben und Zahlen, man kann sie einfach ausprobieren und wieder entfernen, falls es sich nicht um NoScript handelt.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

User avatar
Giorgio Maone
Site Admin
Posts: 8697
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: Firefox deactivates NoScript...and calls it Legacy

Post by Giorgio Maone » Sat May 04, 2019 8:39 am

Latest update
A Firefox release has been pushed — version 66.0.4 on Desktop and Android, and version 60.6.2 for ESR. This release repairs the certificate chain to re-enable web extensions, themes, search engines, and language packs that had been disabled (Bug 1549061).

Check the Tor Blog for more updates about the Tor Browser.

History

Mozilla accidentally broke add-ons signing, see https://twitter.com/ma1/status/1124586336055431168
Some hours ago they said they were testing a fix, but it doesn't seem to be deployed yet.

At this moment the safest browsing option (other than using the Tor Browser with this work-around) seems TEMPORARILY switching to Chromium and installing https://chrome.google.com/webstore/deta ... cbfeoakpjm
Not exactly the same, but as a silver lining, more cross-browser beta testers won't hurt.

[UPDATES 1 & 2]
Mozilla is now deploying the hotfix.
If you're the typical NoScript user, you probably have Firefox Preferences>Privacy & Security>Allow Firefox to install and run studies disabled, but it's currently (temporarily) required for the hotfix to work.

If you're a Tor Browser user, you cannot enable Studies (for obvious reasons), but you can still opt-out extensions signing (until this is properly and generally fixed)
  1. Open about:config
  2. Toggle the value of xpinstall.signatures.required so it becomes false.
  3. Restart the browser.
The above trick (xpinstall.signatures.required=false in about:config) works also on Firefox for Android, which has no hotfix, although I could test it on the Beta only (which is what I'm using on my device, and which therefore never got its extensions disabled).

If you're on Firefox, do the following for the hotfix to immediately apply (it happened to me minutes ago on my main profile):
  1. Open about:config
  2. Turn app.shield.optoutstudies.enabled to true (if false)
  3. Turn app.normandy.run_interval_seconds to 1
As soon as you can see all your add-ons coming back (it should happen right away), reset both preferences.
Otherwise, if the hotfix is already shown in about:studies but still no extensions, either you removed them while trying to fix this (and you need to reinstall them) or that's an instance of this bug.
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:67.0) Gecko/20100101 Firefox/67.0

Jockel333
Posts: 1
Joined: Sat May 04, 2019 8:46 am

Re: Firefox deactivates NoScript...and calls it Legacy

Post by Jockel333 » Sat May 04, 2019 8:49 am

olivia wrote:
Sat May 04, 2019 4:37 am
Hallo,

spricht hier jemand deutsch???
Habe auch das Problem, und verstehe nicht viel englisch. Jedenfalls keine Facherklärungen, was eventuell aktiviert oder deaktiviert werden muss, um "no script" neu installieren zu können.

Schon mal danke ...

LG
An intermediate certificate expired causing the problem.

Also es ist ein Zertifikatproblem, da können wir nicht viel machen außer vielleicht eine Sonderedition zu installieren die es uns erlaubt, add-ons ohne Zertifikat zu installieren. Wo dieses mittlere Zertifikat liegt: ka. Aber es wird wohl bald einen fix geben, morgen sollte wieder alles laufen.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

Guest

Re: Firefox deactivates NoScript...and calls it Legacy

Post by Guest » Sat May 04, 2019 10:53 am

markwoll wrote:
Sat May 04, 2019 1:37 am
see here for bugzilla thread:
https://bugzilla.mozilla.org/show_bug.cgi?id=1548973

An intermediate certificate expired causing the problem.
Thanks, good to know,
Regards
Mozilla/5.0 (Windows NT 10.0; rv:66.0) Gecko/20100101 Firefox/66.0

User avatar
Giorgio Maone
Site Admin
Posts: 8697
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: Firefox deactivates NoScript...and calls it Legacy

Post by Giorgio Maone » Sat May 04, 2019 12:23 pm

They've started deploying the hotfix.
Notice that if you're the typical NoScript user, you probably have Firefox Preferences>Privacy & Security>Allow Firefox to install and run studies disabled, but it's currently (temporarily) required for the hotfix to work.

If you're a Tor Browser user, you cannot enable Studies (for obvious reasons), but you can still (until this is properly and generally fixed)
  1. Open about:config
  2. Toggle the value of xpinstall.signatures.required so it becomes false.
  3. Restart the browser.
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:67.0) Gecko/20100101 Firefox/67.0

whipnet
Posts: 1
Joined: Sat May 04, 2019 1:16 pm

Re: Firefox deactivates NoScript...and calls it Legacy

Post by whipnet » Sat May 04, 2019 1:42 pm

I run the ESR version of FF. I doubt I'll get the update/fix.
Ugh... I run that version to AVOID crap like this happening in the first place!

*
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0

rthappe

Re: Firefox deactivates NoScript...and calls it Legacy

Post by rthappe » Sat May 04, 2019 1:54 pm

Für Olivia zur schnellen Abhilfe (übergangsweise) gemäß der kurzen Anleitung von Giorgio Maone weiter unten:
about:config in der Adressleiste eintragen, um die Firefox Einstellungen zu öffnen; dort den Parameter xpinstall.signatures.required umschalten (Doppelklick) auf false, damit Firefox auch unsignierte Erweiterungen akzeptiert.
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:66.0) Gecko/20100101 Firefox/66.0

barbaz
Senior Member
Posts: 9140
Joined: Sat Aug 03, 2013 5:45 pm

Re: Firefox deactivates NoScript...and calls it Legacy

Post by barbaz » Sat May 04, 2019 3:08 pm

Guest wrote:
Sat May 04, 2019 10:34 am
https://discourse.mozilla.org/t/certifi ... tall/39047
*Always* check the changelogs BEFORE updating that important software!
-

Mad_Man_Moon
Posts: 19
Joined: Fri Oct 27, 2017 12:02 pm

Re: Firefox deactivates NoScript...and calls it Legacy

Post by Mad_Man_Moon » Sat May 04, 2019 5:04 pm

Cheers, guys, you're (as always) awesome on all of this.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

User avatar
therube
Ambassador
Posts: 7406
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: Firefox deactivates NoScript...and calls it Legacy

Post by therube » Sat May 04, 2019 6:14 pm

If anyone is running a pre-Quantum, version of Firefox [that requires signing] (so like FF 52 or 56) you will also be affected.
As there will be no fix for "Firefox", you will need to set the xpinstall.signatures.required Pref to 'false'.
(That should automatically re-enable your missing extensions. xpinstall.signatures.required will need to remain, false.)
Seems that is not correct.
Thinking I did not have 52 open long enough to be affected.
Well, it might be correct - for the ESR version (so 52 ESR) - though not the 52 "non-ESR".
(I have 52 ESR & also happened to have "a" 52 laying about.)
52-ESR will respect the xpinstall.signatures.required Pref.
52 non-ESR will not.
56 may require the "hack"... let me see...
Yes, it needs the "hack". (I've forgotten about all the crap Mozilla makes you go through to accomplish what should be easy.)
See here, viewtopic.php?f=7&t=25529&p=100091#p100091.


(In any case) the scourge has arrived & it is real :lol:.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0 SeaMonkey/2.49.5

Moocow3

Re: Firefox deactivates NoScript...and calls it Legacy

Post by Moocow3 » Sat May 04, 2019 6:51 pm

I enabled the Allow Firefox to install and run studies & got the NS icon back, but it currently has a "?" in the middle & isn't working. ABP is working, WOT is back but is grayed out.
Mozilla/5.0 (Windows NT 5.1; rv:52.0) Gecko/20100101 Firefox/52.0

Moocow3

Re: Firefox deactivates NoScript...and calls it Legacy

Post by Moocow3 » Sat May 04, 2019 6:54 pm

It took 2 restarts. I'm back, thanks! The 52 solution also works.
Mozilla/5.0 (Windows NT 5.1; rv:52.0) Gecko/20100101 Firefox/52.0

Post Reply