No warning in toolbar despite blocked script breaking page

Ask for help about NoScript, no registration needed to post
nsrobert42
Posts: 2
Joined: Tue Mar 26, 2019 6:08 pm

No warning in toolbar despite blocked script breaking page

Post by nsrobert42 » Tue Mar 26, 2019 6:37 pm

Hi,

When I visit https://aws.amazon.com/ec2/pricing/on-demand/ the page loads incorrectly. Specifically, the pricing tab shows "Sorry, an error was encountered while retrieving pricing data. (Try Again)". The NoScript icon in the toolbar shows a blue S with no red circle and slash. However, when I click on it the NS icon, I find ...a2z.com is Default (blocked). Clicking "trusted" for a2z.com causes the page to reload correctly.

I would expect that if a site is blocked by the default rule that there would be a circle and slash with at least a number 1.

Other bits:
- Firefox 66.0.1, although this behavior was present in 65.0.1 also.
- Mac OS 10.14.3.
- this behavior is present even with all other add-ons disabled and FF restarted.
- I have no general preset customizations.
- "Display blocked items count badge" is checked and works on other sites.

This behavior seems similar to that noted here viewtopic.php?f=7&t=25468#p99764

Thanks,
Robert
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:66.0) Gecko/20100101 Firefox/66.0

barbaz
Senior Member
Posts: 9180
Joined: Sat Aug 03, 2013 5:45 pm

Re: No warning in toolbar despite blocked script breaking page

Post by barbaz » Tue Mar 26, 2019 7:59 pm

I can only reproduce this if I remove "fetch" from the Default preset. Are you sure you didn't customise them?

Anyway, I agree that if something is blocked by NoScript permissions, the NS icon should reflect this.
*Always* check the changelogs BEFORE updating that important software!
-

nsrobert42
Posts: 2
Joined: Tue Mar 26, 2019 6:08 pm

Re: No warning in toolbar despite blocked script breaking page

Post by nsrobert42 » Wed Mar 27, 2019 9:57 pm

Oh! You are correct that fetch is unchecked. I did not intentionally modify it. Maybe I unchecked it by accident.

My customizations tabs are:

Default
(unchecked) script
(unchecked) object
(checked) media
(checked) frame
(checked) font
(checked) webgl
(unchecked) fetch
(checked) other


Trusted
All are checked, but script is greyed out.

Untrusted
All are unchecked

Is the default value for fetch in Default checked?

Thanks
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:66.0) Gecko/20100101 Firefox/66.0

barbaz
Senior Member
Posts: 9180
Joined: Sat Aug 03, 2013 5:45 pm

Re: No warning in toolbar despite blocked script breaking page

Post by barbaz » Wed Mar 27, 2019 10:05 pm

nsrobert42 wrote:
Wed Mar 27, 2019 9:57 pm
Is the default value for fetch in Default checked?

Thanks
Yes. Default of Default is to have only "frame", "fetch", and "other" checked, everything else un-checked.
*Always* check the changelogs BEFORE updating that important software!
-

witrak()
Posts: 6
Joined: Thu Mar 22, 2018 11:14 pm

Re: No warning in toolbar despite blocked script breaking page

Post by witrak() » Thu Apr 25, 2019 5:31 pm

barbaz wrote:
Wed Mar 27, 2019 10:05 pm
Yes. Default of Default is to have only "frame", "fetch", and "other" checked, everything else un-checked.
I have fetch unchecked too. I'm almost sure I haven't modified it. Can it be an "old default" - changed at some moment in the NoScript past to the current value?

Another question is that there's no way to know what is the default. If there's no way to reset to default (as it is reasonable to assume that default settings are safe), then the only way to recover from inadvertently changed state is to plow thru InformAction Forums in search for some answer, like the one I'm commenting now :-(
"Reset" button in Options page is definitely not good for it, despite its name (which should be "Delete all personal settings" rather).
I would be happy with Reset button performing just options reset.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

Post Reply