Page 1 of 1

NS 5.1.9 crashing PM when starting Gmail

Posted: Mon Feb 18, 2019 9:30 pm
by lakrsrool
If I have NS 5.1. enabled and I attempt to load the Gmail page then Pale Moon crashes.

If I have NS 5.1.9 disabled and I attempt to load the Gmail page then Pale Moon does not crash.

Based on this result -- it appears in my case NS 5.1.9 causes Pale Moon the crash when using Gmail.

For now I have disabled NS since v5.1.9 (classic) appears to be the most recent version compatible with Pale Moon.

Re: NS 5.1.9 crashing PM when starting Gmail

Posted: Tue Feb 19, 2019 12:03 am
by therube
the Gmail page
URL?
Pale Moon
Version?

Re: NS 5.1.9 crashing PM when starting Gmail

Posted: Tue Feb 19, 2019 12:12 am
by therube
Image

(Now I used my hacked version of NoScript, but... I'd expect no different with the "official" release.)

Re: NS 5.1.9 crashing PM when starting Gmail

Posted: Tue Feb 19, 2019 12:14 am
by lakrsrool
Gmail login URL (that works w/out NS): https://mail.google.com/mail/

Most current Pale Moon (always): v28.3.1

I tried setting NS to "Allow Scripts Globally" and get the same results (does this suggest that it's not a script problem?)

I've added "mail.google" to NS white list and already had "google.com" in white list.

I would certainly think that other NS users would have ran into this problem based on how ubiquitous Gmail happens to be (I don't normally use Gmail at all myself but was testing Gmail for an app for someone when I ran across the problem).

Re: NS 5.1.9 crashing PM when starting Gmail

Posted: Tue Feb 19, 2019 12:18 am
by therube
Test in a new, clean Profile with only NoScript installed.

Re: NS 5.1.9 crashing PM when starting Gmail

Posted: Tue Feb 19, 2019 12:18 am
by lakrsrool
therube wrote:
Tue Feb 19, 2019 12:12 am
... (Now I used my hacked version of NoScript, but... I'd expect no different with the "official" release.)
Since it works for you, I'll test NS w/out other blocker type extensions to rule out extension conflicts. What I've done until now is test with and without NS and w/out NS works as opposed to w/ NS that consistently crashes the browser.

Note: I got an Oops (SPAM) error (like I get so often on this forum) -- so I removed your image link and hopefully it posts.

Re: NS 5.1.9 crashing PM when starting Gmail

Posted: Tue Feb 19, 2019 1:30 am
by lakrsrool
What I found is that if I'm using Disconnect (add-on) then NS will crash PM -- even if I disable Disconnect.

What I have to do is disable Disconnect AND disable NS and then re-enable only NS -- otherwise NS if enabled while Disconnect is enabled will continue to crash the browser even if I've disabled NS --- it is not until NS is disabled while Disconnect is disabled and then NS in enabled again that the crash problem does not appear to be an issue with NS enabled.

Apparently a conflict exists between the two extensions.

Hopefully leaving Disconnect disabled from now on will resolve the issue and allow NS to run w/out a problem. :?

Re: NS 5.1.9 crashing PM when starting Gmail

Posted: Mon Feb 25, 2019 9:08 pm
by 4td8s
get rid of the Disconnect addon as it is no longer being updated for almost two years:

https://addons.mozilla.org/en-US/firefo ... t/reviews/

one review suggests replacing "disconnect addon" with either uBlock origin or privacy badger

Re: NS 5.1.9 crashing PM when starting Gmail

Posted: Tue Apr 02, 2019 8:14 pm
by lakrsrool
I did get rid of Disconnect and had no issues (~7-10 days or so) for some time (using uBlock Origin [uBo] from then on) -- but ultimately I started getting persistent browser crashes again when attempting to use Gmail (crash occurs loading the Gmail interface page) in the PM (v28.4.1) browser (Note: the 7-10 time frame free of issues is probably because I rarely use the Gmail interface on the web). I then started allowing scripts globally in NS using only alternative security aspects of NS (i.e. Anti-XSS protection, HTTPS enforcement, Clickjacking protection and ABE etc) which worked for a while but at some point the crashes continued until I disabled the NS extension altogether.

Since I've disabled NS (v5.1.9) after using NS for many years I have not had any more Gmail crash problems in the PM browser (so far about 3 weeks w/ no crash problems since disabling NS).

I'll keep NS disabled going forward and only report back if the browser crash problem returns as a result of using the Gmail interface on the Web.

In the meantime I'll be using the "Advanced User" functions of uBO (instead of NS).....

Re: NS 5.1.9 crashing PM when starting Gmail

Posted: Wed Jul 17, 2019 1:07 am
by 4td8s
hi lakrsrool - it has been a little over 3 months since I last responded since I was very busy

I'm no longer using NS on Palemoon as I have removed NS completely and replaced it with uMatrix.
PM always display an addon warning with NS but not with uMatrix