NS 5.1.9 crashing PM when starting Gmail

Ask for help about NoScript, no registration needed to post
User avatar
lakrsrool
Senior Member
Posts: 195
Joined: Wed Nov 12, 2014 4:20 pm

NS 5.1.9 crashing PM when starting Gmail

Post by lakrsrool » Mon Feb 18, 2019 9:30 pm

If I have NS 5.1. enabled and I attempt to load the Gmail page then Pale Moon crashes.

If I have NS 5.1.9 disabled and I attempt to load the Gmail page then Pale Moon does not crash.

Based on this result -- it appears in my case NS 5.1.9 causes Pale Moon the crash when using Gmail.

For now I have disabled NS since v5.1.9 (classic) appears to be the most recent version compatible with Pale Moon.
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:60.9) Gecko/20100101 Goanna/4.1 Firefox/60.9 PaleMoon/28.3.1

User avatar
therube
Ambassador
Posts: 7468
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: NS 5.1.9 crashing PM when starting Gmail

Post by therube » Tue Feb 19, 2019 12:03 am

the Gmail page
URL?
Pale Moon
Version?
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0 SeaMonkey/2.53 Lightning/5.8

User avatar
therube
Ambassador
Posts: 7468
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: NS 5.1.9 crashing PM when starting Gmail

Post by therube » Tue Feb 19, 2019 12:12 am

Image

(Now I used my hacked version of NoScript, but... I'd expect no different with the "official" release.)
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0 SeaMonkey/2.53 Lightning/5.8

User avatar
lakrsrool
Senior Member
Posts: 195
Joined: Wed Nov 12, 2014 4:20 pm

Re: NS 5.1.9 crashing PM when starting Gmail

Post by lakrsrool » Tue Feb 19, 2019 12:14 am

Gmail login URL (that works w/out NS): https://mail.google.com/mail/

Most current Pale Moon (always): v28.3.1

I tried setting NS to "Allow Scripts Globally" and get the same results (does this suggest that it's not a script problem?)

I've added "mail.google" to NS white list and already had "google.com" in white list.

I would certainly think that other NS users would have ran into this problem based on how ubiquitous Gmail happens to be (I don't normally use Gmail at all myself but was testing Gmail for an app for someone when I ran across the problem).
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:60.9) Gecko/20100101 Goanna/4.1 Firefox/60.9 PaleMoon/28.3.1

User avatar
therube
Ambassador
Posts: 7468
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: NS 5.1.9 crashing PM when starting Gmail

Post by therube » Tue Feb 19, 2019 12:18 am

Test in a new, clean Profile with only NoScript installed.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0 SeaMonkey/2.53 Lightning/5.8

User avatar
lakrsrool
Senior Member
Posts: 195
Joined: Wed Nov 12, 2014 4:20 pm

Re: NS 5.1.9 crashing PM when starting Gmail

Post by lakrsrool » Tue Feb 19, 2019 12:18 am

therube wrote:
Tue Feb 19, 2019 12:12 am
... (Now I used my hacked version of NoScript, but... I'd expect no different with the "official" release.)
Since it works for you, I'll test NS w/out other blocker type extensions to rule out extension conflicts. What I've done until now is test with and without NS and w/out NS works as opposed to w/ NS that consistently crashes the browser.

Note: I got an Oops (SPAM) error (like I get so often on this forum) -- so I removed your image link and hopefully it posts.
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:60.9) Gecko/20100101 Goanna/4.1 Firefox/60.9 PaleMoon/28.3.1

User avatar
lakrsrool
Senior Member
Posts: 195
Joined: Wed Nov 12, 2014 4:20 pm

Re: NS 5.1.9 crashing PM when starting Gmail

Post by lakrsrool » Tue Feb 19, 2019 1:30 am

What I found is that if I'm using Disconnect (add-on) then NS will crash PM -- even if I disable Disconnect.

What I have to do is disable Disconnect AND disable NS and then re-enable only NS -- otherwise NS if enabled while Disconnect is enabled will continue to crash the browser even if I've disabled NS --- it is not until NS is disabled while Disconnect is disabled and then NS in enabled again that the crash problem does not appear to be an issue with NS enabled.

Apparently a conflict exists between the two extensions.

Hopefully leaving Disconnect disabled from now on will resolve the issue and allow NS to run w/out a problem. :?
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:60.9) Gecko/20100101 Goanna/4.1 Firefox/60.9 PaleMoon/28.3.1

4td8s
Junior Member
Posts: 22
Joined: Thu Jun 03, 2010 10:40 pm

Re: NS 5.1.9 crashing PM when starting Gmail

Post by 4td8s » Mon Feb 25, 2019 9:08 pm

get rid of the Disconnect addon as it is no longer being updated for almost two years:

https://addons.mozilla.org/en-US/firefo ... t/reviews/

one review suggests replacing "disconnect addon" with either uBlock origin or privacy badger
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0

User avatar
lakrsrool
Senior Member
Posts: 195
Joined: Wed Nov 12, 2014 4:20 pm

Re: NS 5.1.9 crashing PM when starting Gmail

Post by lakrsrool » Tue Apr 02, 2019 8:14 pm

I did get rid of Disconnect and had no issues (~7-10 days or so) for some time (using uBlock Origin [uBo] from then on) -- but ultimately I started getting persistent browser crashes again when attempting to use Gmail (crash occurs loading the Gmail interface page) in the PM (v28.4.1) browser (Note: the 7-10 time frame free of issues is probably because I rarely use the Gmail interface on the web). I then started allowing scripts globally in NS using only alternative security aspects of NS (i.e. Anti-XSS protection, HTTPS enforcement, Clickjacking protection and ABE etc) which worked for a while but at some point the crashes continued until I disabled the NS extension altogether.

Since I've disabled NS (v5.1.9) after using NS for many years I have not had any more Gmail crash problems in the PM browser (so far about 3 weeks w/ no crash problems since disabling NS).

I'll keep NS disabled going forward and only report back if the browser crash problem returns as a result of using the Gmail interface on the Web.

In the meantime I'll be using the "Advanced User" functions of uBO (instead of NS).....
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:60.9) Gecko/20100101 Goanna/4.1 Firefox/60.9 PaleMoon/28.4.1

4td8s
Junior Member
Posts: 22
Joined: Thu Jun 03, 2010 10:40 pm

Re: NS 5.1.9 crashing PM when starting Gmail

Post by 4td8s » Wed Jul 17, 2019 1:07 am

hi lakrsrool - it has been a little over 3 months since I last responded since I was very busy

I'm no longer using NS on Palemoon as I have removed NS completely and replaced it with uMatrix.
PM always display an addon warning with NS but not with uMatrix
Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/76.0.3809.46 Safari/537.36

Post Reply