At&t news videos won't play with Noscript enabled

Ask for help about NoScript, no registration needed to post
Alice_Redhat
Posts: 7
Joined: Mon May 29, 2017 2:51 pm

At&t news videos won't play with Noscript enabled

Post by Alice_Redhat » Sat Dec 08, 2018 6:04 pm

I was a hold out but I finally upgraded my Firefox v56 to the latest Quantum version and also updated Noscript. Now any news videos from the att.net home page will not play unless I completely disable Noscript, which I shouldn't have to do. I'm not super technical but can follow directions and can usually figure things out on my own. Is there some "page or element info" I can post to get some help so I can get them to play without disabling?

ps. I have been using Noscript for years and I must say after using the new version now for a few weeks I like it better, it's more user friendly and you actually see that there's a whole lot of stuff (and come crap) going on with web pages.

Thanks,
Alice
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

User avatar
therube
Ambassador
Posts: 7363
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: At&t news videos won't play with Noscript enabled

Post by therube » Sat Dec 08, 2018 6:43 pm

URLs?
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0 SeaMonkey/2.49.5

barbaz
Senior Member
Posts: 9032
Joined: Sat Aug 03, 2013 5:45 pm

Re: At&t news videos won't play with Noscript enabled

Post by barbaz » Sat Dec 08, 2018 7:21 pm

Also, what version of NoScript are you using?
*Always* check the changelogs BEFORE updating that important software!
-

Alice_Redhat
Posts: 7
Joined: Mon May 29, 2017 2:51 pm

Re: At&t news videos won't play with Noscript enabled

Post by Alice_Redhat » Sat Dec 08, 2018 8:02 pm

I am using v. 10.2.0 of Noscript.

Assuming you want the url that is in the Firefox url box? Here's a couple of examples of some as of today:

https://start.att.net/player/article/wo ... ry/finance

https://start.att.net/player/article/us ... egory/news

They all start with https://start.att.net/player. However that domain is not in the list of Noscript, only att.net which I have as trusted.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

User avatar
therube
Ambassador
Posts: 7363
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: At&t news videos won't play with Noscript enabled

Post by therube » Sat Dec 08, 2018 9:40 pm

Works here.

In addition to att.net, there is:

att.com, at least 1 cloudfront.net, syn-*.com, synacor.com, technoratimedia.com, & jwp.cdn

that if allowed, allows playback.

If they are all needed, or only some subset, not sure.
But with those, you should get playback.


(Depending on settings, & by default), allowing "att.net" would also include allowing start.att.net (& stop.att.net).
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0 SeaMonkey/2.49.5

barbaz
Senior Member
Posts: 9032
Joined: Sat Aug 03, 2013 5:45 pm

Re: At&t news videos won't play with Noscript enabled

Post by barbaz » Sat Dec 08, 2018 11:00 pm

Your second link works for me with NoScript latest development build 10.2.1rc2 and only these sites set to (Temp.) Trusted:

Code: Select all

…att.net
…jwpcdn.com
…syn-cdn.com
…synacor.com
They don't all show up at the start. You have to (Temp.) Trust some of them and reload, and repeat a few times, before they all show up.
*Always* check the changelogs BEFORE updating that important software!
-

Alice_Redhat
Posts: 7
Joined: Mon May 29, 2017 2:51 pm

Re: At&t news videos won't play with Noscript enabled

Post by Alice_Redhat » Sat Dec 08, 2018 11:17 pm

I thought that setting all to temporarily trusted would do the trick? I see all the domains in the NS list that you both mentioned except jwpcdn. Maybe that is the problem. I'll keep playing or maybe download the development build.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

Alice_Redhat
Posts: 7
Joined: Mon May 29, 2017 2:51 pm

Re: At&t news videos won't play with Noscript enabled

Post by Alice_Redhat » Sat Dec 08, 2018 11:21 pm

I just went into NS settings and jwpcdn.com is in there marked as trusted. I have refreshed the pages many times after doing a temp trust. Still no go.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

Alice_Redhat
Posts: 7
Joined: Mon May 29, 2017 2:51 pm

Re: At&t news videos won't play with Noscript enabled

Post by Alice_Redhat » Thu Dec 13, 2018 10:01 pm

I installed the development build but jwpcdn.com still did not show up in the NS list for either of those pages. Any other suggestions? If not I'll just continue to disable NS if I really want to watch one of the AT&T news videos.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

User avatar
therube
Ambassador
Posts: 7363
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: At&t news videos won't play with Noscript enabled

Post by therube » Fri Dec 14, 2018 12:07 am

jwpcdn is the "player".
One way or another you've got to get that to display, got to get that allowed.

Now it could be that it's existence depends on something else being allowed - which you have blocked, or even blocked outside of NoScript.

If I Allow Globally, AT&T plays.

If I Disable Restrictions For This Tab, the video plays.

If I Temporarily Allow All This Page, the video does not play - until I do that again a 2nd, & then a 3rd time (at which point enough has been allowed [maybe even too much] to allow playback).
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0 SeaMonkey/2.49.5

Quest

Re: At&t news videos won't play with Noscript enabled

Post by Quest » Fri Dec 14, 2018 6:52 pm

Alice_Redhat wrote:I thought that setting all to temporarily trusted would do the trick? I see all the domains in the NS list that you both mentioned except jwpcdn.
"Disable restrictions from this tab" gives still more options.
And BTW do you have "List full addresses in the permissions popup" allowed in Settings/Appearance?
Mozilla/5.0 (Windows NT 6.1; rv:64.0) Gecko/20100101 Firefox/64.0

Alice_Redhat
Posts: 7
Joined: Mon May 29, 2017 2:51 pm

Re: At&t news videos won't play with Noscript enabled

Post by Alice_Redhat » Thu Dec 20, 2018 12:19 am

Thank you "therube' and "quest" for your suggestions. I tried all of them and still no video and never saw jwpcdn so I could allow it.

FYI, I just tried to watch a video on cbsnews and all I get is a black rectangle where the video s/b playing after setting all to temp trusted and refreshing several times. It actually played the ad (that plays before the video) before I did anything with NS but now even the ad won't play. I remember seeing another post about trouble with cbs videos.

I do like the new version 10, I think it's more user friendly but it does seem to have some issues. How are you supposed to 'trust' what you can't even see in the list? But I'll keep using it regardless of a fairly minor flaw. I'm sure it will get fixed in the future.

At this point, I have much better things to do with my time and don't really care to spend more time fooling around with it. It's much quicker and easier just to disable NS to watch an occasional video from a source I think I can trust for a minute or two and then re-enable NS when I'm done (and believe me I won't forget).

Thanks for your help anyway.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

barbaz
Senior Member
Posts: 9032
Joined: Sat Aug 03, 2013 5:45 pm

Re: At&t news videos won't play with Noscript enabled

Post by barbaz » Thu Dec 20, 2018 2:54 am

Alice_Redhat wrote:At this point, I have much better things to do with my time and don't really care to spend more time fooling around with it. It's much quicker and easier just to disable NS to watch an occasional video from a source I think I can trust for a minute or two and then re-enable NS when I'm done (and believe me I won't forget).
ok. Your computer, your choice.

If you do decide to get back to sorting this out, or if anyone else has the same problem and wants to take troubleshooting further, the next step would be to look at how the TRUSTED preset is configured (NoScript Options > General)
*Always* check the changelogs BEFORE updating that important software!
-

Post Reply