Uninstall leaves settings in place?

Ask for help about NoScript, no registration needed to post
Techie

Uninstall leaves settings in place?

Post by Techie » Sat Dec 08, 2018 2:13 pm

I had installed NoScript. Tried to use it on a website. Now the website won't load. NoScript is too confusing for me, so I decided to uninstall. The trouble is that after removing the add-on from Firefox the website still no long works. How do I get my settings back to what they were before installing NoScript?
I have Firefox Quantum 63.03 64 bit.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

barbaz
Senior Member
Posts: 8872
Joined: Sat Aug 03, 2013 5:45 pm

Re: Uninstall leaves settings in place?

Post by barbaz » Sat Dec 08, 2018 2:28 pm

I think uninstalling NoScript 10 does reset all its settings.

Maybe try reloading this webpage with Ctrl-Shift-R (to bypass any caching)?
*Always* check the changelogs BEFORE updating that important software!
-

Techie

Re: Uninstall leaves settings in place?

Post by Techie » Sat Dec 08, 2018 2:49 pm

I have reloaded the page and even restarted the Firefox browser.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

Techie

Re: Uninstall leaves settings in place?

Post by Techie » Sat Dec 08, 2018 3:50 pm

If I reinstall the NoScript add-in, then the website start working again. If I disable the NoScript add-in the website stops working.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

barbaz
Senior Member
Posts: 8872
Joined: Sat Aug 03, 2013 5:45 pm

Re: Uninstall leaves settings in place?

Post by barbaz » Sat Dec 08, 2018 4:17 pm

Link to this website?
Does it require login to see the page with the issue?
*Always* check the changelogs BEFORE updating that important software!
-

Techie

Re: Uninstall leaves settings in place?

Post by Techie » Sat Dec 08, 2018 5:06 pm

The website works fine when browsing from a Firefox private window or from any other browser where NoScript has never been installed.
https://www.capitalone.com
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

User avatar
therube
Ambassador
Posts: 7271
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: Uninstall leaves settings in place?

Post by therube » Sat Dec 08, 2018 6:56 pm

If you remove NoScript, NoScript is not the issue.

AFAIK, NoScript does not affect "FF" settings.
NoScript may have its own settings that affect FF, having NoScript installed may make changes that affect FF, but it does not change (probably cannot even do it if it wanted to) FF settings.


Anyhow, cap.1, works fine on my end.
Allow capitalone.com, & log in as expected.


Perhaps some other content blocking you may have going on; 3rd party cookies or similar?


As a test, create a new, clean Profile.
Install NoScript.
Visit cap.1 & log in.
That works.
Remove NoScript.
Visit cap.1 & log in.
That works too, no?
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0 SeaMonkey/2.49.5

Techie

Re: Uninstall leaves settings in place?

Post by Techie » Sat Dec 08, 2018 9:35 pm

The site was loading ok BEFORE installing NoScript and I change some of its settings for Cap1. I could not get the website to load properly again even after trying to put the settings back to what I thought they were beforehand. As soon as I reinstall NoScript the site load correct again - without my changing any of the NoScript settings. It seems to me that this points to a NoScript, not to FF problem. It seems NoScript made some setting change that persists even after it is uninstalled.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

barbaz
Senior Member
Posts: 8872
Joined: Sat Aug 03, 2013 5:45 pm

Re: Uninstall leaves settings in place?

Post by barbaz » Sat Dec 08, 2018 9:51 pm

To be clear, did you try this in a new, clean Firefox profile as suggested? -
therube wrote:As a test, create a new, clean Profile.
Install NoScript.
Visit cap.1 & log in.
That works.
Remove NoScript.
Visit cap.1 & log in.
That works too, no?
*Always* check the changelogs BEFORE updating that important software!
-

Techie

Re: Uninstall leaves settings in place?

Post by Techie » Tue Dec 11, 2018 12:23 pm

Problem resolved after clearing site and cookie data. Seems NoScript was leaving crumbs.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

User avatar
therube
Ambassador
Posts: 7271
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: Uninstall leaves settings in place?

Post by therube » Tue Dec 11, 2018 12:52 pm

What would NoScript have to do with site & cookies settings?

Other then it may have been blocking the particular domains where (other) cookies were coming from (that is if some of theme were different from "capitalone.com", like ensighten.com, newrelic.com, ...)
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0 SeaMonkey/2.49.5

Post Reply