[Fixed] error message when downloading html-attachments

Ask for help about NoScript, no registration needed to post
richard68
Posts: 4
Joined: Tue Jul 17, 2018 12:01 am

[Fixed] error message when downloading html-attachments

Post by richard68 » Tue Jul 17, 2018 12:47 am

Since the update to version 10.1.8.7 I can no longer download html-attachments from my e-mail account.

The error message is:
C:\Users\XXX\AppData\Local\Temp\JUZBCwYK.html.part could not be saved because the source file could not be read.

If I disable NoScript the download works without problems.

My system information:
Windows 8.1 with current system updates July 2018
Firefox Quantum 61.0.1
FlashPlayer 30.0.0.134
The NoScript-setting for the provider side of my e-mail account is set to "trusted".

Any help is welcome ;-)

Greetings, Richard
Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0

User avatar
therube
Ambassador
Posts: 7682
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: error message when downloading html-attachments

Post by therube » Tue Jul 17, 2018 1:54 am

Who is your mail provider?

Anything of note mentioned in Browser Console?
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0 SeaMonkey/2.53 Lightning/5.8

newjunkcity

Re: error message when downloading html-attachments

Post by newjunkcity » Tue Jul 17, 2018 7:47 am

Hi,

I found this thread after some Googling; I've got the same error message.
HTTP downloads not working from one of my work sites. Disable restrictions globally in NoScript, and the problem goes away.

FireFox 61.0.1 64-bit
Windows 10 Pro

The site is our own, and based on the GLPI Project. If it might be helpful, the files are served via links to this page:
https://github.com/glpi-project/glpi/bl ... t.send.php
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0

User avatar
Giorgio Maone
Site Admin
Posts: 8957
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: error message when downloading html-attachments

Post by Giorgio Maone » Tue Jul 17, 2018 10:16 am

Please check latest development build:
v 10.1.8.8rc1
=============================================================
x Prevent script injection from messing with
content-disposition=attachment responses.

If it doesn't fix this problem, which I could not reproduce yet (I'm almost shooting in the dark) please provide me with some more details and even better a reproducible test case, thanks!
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0

newjunkcity

Re: error message when downloading html-attachments

Post by newjunkcity » Tue Jul 17, 2018 3:27 pm

Hi Giorgio,

I've just tested the dev build v10.1.8.8rc1, and everything works. To make sure, I've restored the current release from AMO, and the downloads have ceased to function properly.
So all in all, confirmation that the fix seems to target the issue!

Many thanks.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0

richard68
Posts: 4
Joined: Tue Jul 17, 2018 12:01 am

Re: error message when downloading html-attachments

Post by richard68 » Tue Jul 17, 2018 5:06 pm

therube wrote:Who is your mail provider?

Anything of note mentioned in Browser Console?
Mail provider: t-online.de

Notifications in the Browser Console:

Code: Select all

[NoScript] Cannot collect noscript activity data <unavailable> Could not establish connection. Receiving end does not exist. collectSeen@moz-extension://a32916d8-5c11-419c-a96d-c0fe12d0e6dc/bg/main.js:263:38log.js:12:62
https://pix.telekom.de/697740521790539/wt?p=441,email.t-online.de.privatkunden.inbox.mailreadview,1,1366x768,24,1,1531844080774,2,1366x611,0&tz=2&ct=content.inbox-mailreadview-attachment-downloadattachment&la=de&cg1=.undefined.undefined&pu=https%3A%2F%2Femail.t-online.de%2Fem&eor=1
[HTTP/1.1 200 OK 115ms]
https://email.t-online.de/em/bin/service.mailbox/delivermessagepart?folder=INBOX.Trash&uId=112161413710985210&mimePartId=2&&acceptRanges=&noSecureDelivery=0&exifOrientation=&disposition=attachment
[HTTP/1.1 302 Found 192ms]
https://dlvr.t-online.de/dlvr?p[dtkn]=brfjC6n_ApdZ9zUzs1yF6l0mFaGZPphh
[HTTP/1.1 200 OK 407ms]
Error: Invalid tab ID: 5
But dev build v10.1.8.8rc1 fixed the problem !
Last edited by barbaz on Tue Jul 17, 2018 5:09 pm, edited 1 time in total.
Reason: wrap console messages in code tags
Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0

richard68
Posts: 4
Joined: Tue Jul 17, 2018 12:01 am

Re: error message when downloading html-attachments

Post by richard68 » Tue Jul 17, 2018 5:08 pm

newjunkcity wrote:Hi,

...Disable restrictions globally in NoScript, and the problem goes away
Restrictions in NoScript for
pix.telekom.de
email.t-online.com
dlvr.t-online.de
t-online.de
disabled = error persists.

But dev build v10.1.8.8rc1 fixed the problem !
Many thanks for your help !
Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0

richard68
Posts: 4
Joined: Tue Jul 17, 2018 12:01 am

Re: error message when downloading html-attachments

Post by richard68 » Tue Jul 17, 2018 5:09 pm

Giorgio Maone wrote:Please check latest development build:
v 10.1.8.8rc1
=============================================================
x Prevent script injection from messing with
content-disposition=attachment responses.

If it doesn't fix this problem, which I could not reproduce yet (I'm almost shooting in the dark) please provide me with some more details and even better a reproducible test case, thanks!
Hi Giorgio,

Thanks for the quick solution !
Problem SOLVED by version 10.1.8.8.
Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0

rpr
Posts: 7
Joined: Thu Jan 30, 2014 11:26 am

Re: [Fixed] error message when downloading html-attachments

Post by rpr » Thu Jul 19, 2018 9:23 pm

I also have this problem with NoScript 10.1.8.8 while trying to download some PDF files.

Here is an example: http://www.anpost.ie/NR/rdonlyres/53AC8 ... Q32018.pdf

As soon as I disable NoScript the download works normally.

System info: Firefox 61.0.1, Ubuntu 16.04 64-bit.

-- rpr.
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0

User avatar
Giorgio Maone
Site Admin
Posts: 8957
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: [Fixed] error message when downloading html-attachments

Post by Giorgio Maone » Thu Jul 19, 2018 9:31 pm

rpr wrote:I also have this problem with NoScript 10.1.8.8 while trying to download some PDF files.

Here is an example: http://www.anpost.ie/NR/rdonlyres/53AC8 ... Q32018.pdf
If I follow this link everything works as expected: in Firefox's default configuration, it gets opened within the browser. Otherwise, if I changed the default action to "download" or "always ask", I manage to have it downloaded on my system.
Maybe you could give us the link to the page where you start the download from, and also try on a clean profile with just NoScript installed.
Good luck and let me know.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0

rpr
Posts: 7
Joined: Thu Jan 30, 2014 11:26 am

Re: [Fixed] error message when downloading html-attachments

Post by rpr » Fri Jul 20, 2018 7:43 am

I started the download from http://www.anpost.ie/AnPost/IrishStamps ... rs+Corner/ and the PDF link is the last thing on the right side (The Collector).

In my Firefox preferences I have: General > Applications > PDF: Always ask

The issue also exists in a clean Firefox profile with NoScript 10.1.8.8.

I can workaround the issue by right-click > Save Link As in which case the download is successful.

-- rpr.
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0

skriptimaahinen
Senior Member
Posts: 213
Joined: Wed Jan 10, 2018 7:37 am

Post by skriptimaahinen » Fri Jul 20, 2018 11:06 am

Can confirm. Need to have pdf content type action set to "ask" and scripts allowed for anpost.ie to reproduce. Definitely something in the RequestUtil. Again...
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0

User avatar
Giorgio Maone
Site Admin
Posts: 8957
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: [Fixed] error message when downloading html-attachments

Post by Giorgio Maone » Fri Jul 20, 2018 10:05 pm

Please check latest development build, thanks.
v 10.1.8.9rc2
=============================================================
x Fixed externally handled resources opened in popups broken
by dynamic script injection (thanks rpr and paulmcg for
reporting)

x [Tor Browser, Linux] Replaced unicode glyphs not being
rendered on some browsers / platforms
x Prevent multiple canScript content messages during the same
page load
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0

rpr
Posts: 7
Joined: Thu Jan 30, 2014 11:26 am

Re: [Fixed] error message when downloading html-attachments

Post by rpr » Sat Jul 21, 2018 2:18 pm

Hi Giorgio,
version 10.1.8.9rc2 fixed the issue.
Thanks,
-- rpr.
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0

Post Reply