Bloomberg video not playing

Ask for help about NoScript, no registration needed to post
gasull
Posts: 3
Joined: Sat Aug 16, 2014 10:37 pm

Bloomberg video not playing

Post by gasull » Sat Jun 09, 2018 2:47 am

Bloomberg video won't play, even if allowing all scripts. I need to disable the addon in order to play the video.

https://www.bloomberg.com/news/videos/2 ... -car-video
Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0

skriptimaahinen
Senior Member
Posts: 213
Joined: Wed Jan 10, 2018 7:37 am

Re: Bloomberg video not playing

Post by skriptimaahinen » Sat Jun 09, 2018 5:36 am

I got the video working after enabling these sites and permissions.

Code: Select all

bloomberg.com           script, fetch
akamaihd.net            fetch
bwbx.io                 script
gotraffic.net           script
imasdk.googleapis.com   script, frame
lldns.net               fetch
That's for FF60/NS10, but since you appear to use FF52, maybe there's something in this (https://forums.informaction.com/viewtopic.php?t=24761) thread that might help you if the settings above are not enough?
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0

User avatar
therube
Ambassador
Posts: 7682
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: Bloomberg video not playing

Post by therube » Sat Jun 09, 2018 9:54 am

That was a bit of a pain.
uBlock was blocking something.
After that, Allow Global got it working.

Somewhat whittled down:

+bbthat.com
+2mdn.net
+nice264.com
+youboranqs01.com
+imasdk.googleapis.com
+bloomberg.tv
+gotraffic.net
+bwbx.io
+google.com
+crwdcntrl.net
+blob:
+bloomberg.com

That's a lot isn't it.
And that's quite different (from 10).
Could be that not everything there is needed, but its too much of a pain to try to get it any shorter.
(google.com is needed, it seems.)
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0 SeaMonkey/2.49.4

barbaz
Senior Member
Posts: 9691
Joined: Sat Aug 03, 2013 5:45 pm

Re: Bloomberg video not playing

Post by barbaz » Sun Jun 10, 2018 5:32 pm

skriptimaahinen wrote: since you appear to use FF52, maybe there's something in this (https://forums.informaction.com/viewtopic.php?t=24761) thread that might help you if the settings above are not enough?
Yep, it's the same issue as that thread. This is a NoScript bug, and Giorgio already has the fix. Not sure why it hasn't been released yet. I'll contact him again.
*Always* check the changelogs BEFORE updating that important software!
-

User avatar
Giorgio Maone
Site Admin
Posts: 8957
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: Bloomberg video not playing

Post by Giorgio Maone » Sun Jun 10, 2018 10:19 pm

Please check latest development build 5.1.8.6rc1. If it looks good, tomorrow I'm gonna release 5.1.8.6 stable. Thank you.

v 5.1.8.6rc1
=============================================================
x [Surrogate] Fixed 2mdn surrogate compatibility issues
(thanks barbaz)
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0

barbaz
Senior Member
Posts: 9691
Joined: Sat Aug 03, 2013 5:45 pm

Re: Bloomberg video not playing

Post by barbaz » Mon Jun 11, 2018 3:19 am

Fixed here. Thanks Giorgio!

@gasull, please confirm?
*Always* check the changelogs BEFORE updating that important software!
-

barbaz
Senior Member
Posts: 9691
Joined: Sat Aug 03, 2013 5:45 pm

Re: Bloomberg video not playing

Post by barbaz » Mon Sep 10, 2018 3:57 pm

There was an error in the fix included in 5.1.8.6. Please re-check with latest development build 5.1.8.7rc4 (or 5.1.8.7 release).
*Always* check the changelogs BEFORE updating that important software!
-

Post Reply