[RESOLVED] Whitelisting one site is ineffective

Ask for help about NoScript, no registration needed to post

[RESOLVED] Whitelisting one site is ineffective

Postby Odin99 » Wed May 16, 2018 6:16 pm

My ISP's Webmail [at mail.dslextreme.com] has been whitelisted for years in NoScript with no problem whatever. Recently however, as an experiment, I instructed NS to block scripts at this site. The loss of functionality caused me almost immediately to reverse that instruction. Nevertheless now whenever I return to that site an error message appears saying I must enable Javascript to access it. When I click the "try again" button, the page reloads and comes up, but for no apparent reason I have to do this nearly every time I return to the page. I've confirmed that dslextreme.com appears in my whitelist. My ISP tells me it's a problem with my installation of NoScript. What can I do? (Detailed guidance would be appreciated.)
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0
Odin99
Junior Member
 
Posts: 29
Joined: Fri Jun 26, 2015 1:22 am

Re: Whitelisting one site is ineffective

Postby therube » Wed May 16, 2018 6:31 pm

Open the site in a Private Window & see if the issue persists.
If it does, then as a test, create a new clean Profile, add NoScript, & test in there.

I would think it has something to do with cookies or similar.

Also make sure you don't have any other "blockers"; like uBlock (ad blocker or similar), affecting things.


Also check the URL of the page you are using (or are ending up at).
Some pages send you to something like: www.site.com/login&no_javascript (a "no javascript" message page, & when you enable JavaScript & refresh, it does not refresh properly leaving you at the same page, presenting you with the same message - even though you do have JS enabled.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 5.1; rv:52.0) Gecko/20100101 SeaMonkey/2.49.3
User avatar
therube
Ambassador
 
Posts: 6913
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: Whitelisting one site is ineffective

Postby Odin99 » Thu May 17, 2018 12:24 am

As the URL is https://mail.dslextreme.com/public/noscript.jsp, it's pretty clear your final paragraph applies. Please tell me what I can do to solve the issue (aside from abandoning NoScript).
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0
Odin99
Junior Member
 
Posts: 29
Joined: Fri Jun 26, 2015 1:22 am

Re: Whitelisting one site is ineffective

Postby barbaz » Thu May 17, 2018 12:47 am

Change your bookmark?
*Always* check the changelogs BEFORE updating that important software!
Board search is currently partially broken: viewtopic.php?f=14&t=21752
Workaround: use your favorite search engine, add site:forums.informaction.com to your query
-
barbaz
Senior Member
 
Posts: 8393
Joined: Sat Aug 03, 2013 5:45 pm

Re: Whitelisting one site is ineffective

Postby Odin99 » Fri May 18, 2018 1:22 am

Thanks, therube and barbaz. After reading barbaz's post, I checked and found that my bookmark had been changed to the NoScript version that I provided above; so I changed it back, and now the issue seems resolved. :D
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0
Odin99
Junior Member
 
Posts: 29
Joined: Fri Jun 26, 2015 1:22 am

Re: Whitelisting one site is ineffective

Postby barbaz » Fri May 18, 2018 3:00 am

You're welcome and thanks for reporting back. Image
*Always* check the changelogs BEFORE updating that important software!
Board search is currently partially broken: viewtopic.php?f=14&t=21752
Workaround: use your favorite search engine, add site:forums.informaction.com to your query
-
barbaz
Senior Member
 
Posts: 8393
Joined: Sat Aug 03, 2013 5:45 pm


Return to NoScript Support

Who is online

Users browsing this forum: No registered users and 2 guests

cron