Noscript blocking nothing and allowing all scripts

Ask for help about NoScript, no registration needed to post
jbee

Noscript blocking nothing and allowing all scripts

Post by jbee » Thu Jan 04, 2018 8:43 am

Noscript Version 10.1.6.2
Firefox 57
Windows 10

It simply doesn't block anything by default. All scripts are allowed on all domains without me whitelisting them or clicking allow/temp allow.

If I specifically set a domain to untrusted then that domain's scripts are properly blocked as expected, but I want all scripts disabled by default and I see no option in noscript 10 for that.

I think it's a bug.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

Pansa
Senior Member
Posts: 318
Joined: Fri Nov 24, 2017 10:30 pm

Re: Noscript blocking nothing and allowing all scripts

Post by Pansa » Thu Jan 04, 2018 1:40 pm

The preset settings can be accessed from the options screen.
For the default settings you have to set an already trusted domain back to default,
click on default again
Set or remove the checkmarks you want
and then change the domain back to what you had it set to.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

User avatar
Giorgio Maone
Site Admin
Posts: 8934
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: Noscript blocking nothing and allowing all scripts

Post by Giorgio Maone » Fri Jan 05, 2018 12:23 am

Please check latest development build:
v 10.1.6.3rc2
=============================================================
x Moved preset customization into its own (more discoverable)
global Options section, rather than embedded in assignment

x Domain matching now threats unknown no-dot domains (not in
the public suffixes list) as TLDs everywhere
x Improved validation of manual entries
x Needed capabilities highlighted also on short-hand domain
matched entries inside the CUSTOM preset
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

Post Reply