NoScript keeps losing settings v10.1.5.9

Ask for help about NoScript, no registration needed to post
Scavenger
Posts: 2
Joined: Sun Dec 17, 2017 12:20 pm

NoScript keeps losing settings v10.1.5.9

Post by Scavenger » Sun Dec 17, 2017 12:26 pm

- version 10.1.5.9
settings made on a domain are lost upon closing and starting a new browser session
older settings are retained but only settings made after updating to 10.1.5.9 are affected and lost
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

8-bit
Senior Member
Posts: 97
Joined: Thu Mar 16, 2017 7:43 pm

Re: NoScript keeps losing settings v10.1.5.9

Post by 8-bit » Sun Dec 17, 2017 12:37 pm

Can you provide an example ?

If you are trying to allow a site as trusted permanently, you need to click the clock on the tab a second time - it will retract and become a permanent allow, which will stay across sessions. If you provide a more detailed example, it will be easier to diagnose exactly what is going on.
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:57.0) Gecko/20100101 Firefox/57.0

Scavenger
Posts: 2
Joined: Sun Dec 17, 2017 12:20 pm

Re: NoScript keeps losing settings v10.1.5.9

Post by Scavenger » Mon Dec 18, 2017 3:18 pm

https://forums.informaction.com

- I click trusted ... and the clock
- click the noscript settings page and it's listed temporarily

But in anycase this way of temporarily trust is a bit tricky, perhaps you could add a button just for temporarily trusting a single domain.
Reading through the forum posts a lot of user are struggling with this way of making choices, it's a bit too unclear if a domain has been made trusted permanently.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

8-bit
Senior Member
Posts: 97
Joined: Thu Mar 16, 2017 7:43 pm

Re: NoScript keeps losing settings v10.1.5.9

Post by 8-bit » Mon Dec 18, 2017 3:41 pm

Scavenger wrote:https://forums.informaction.com

- I click trusted ... and the clock
- click the noscript settings page and it's listed temporarily.
I'm running 10.1.5.9rc2 now (same as 10.1.5.9), and the behaviour of the clock is now reversed from my previous post. Clicking on trusted ONCE leaves the clock retracted (small) which is permanent. This seems to be the default behaviour now. You only need to click the trusted icon once and don't take any action on the clock to keep it as permanent.
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:57.0) Gecko/20100101 Firefox/57.0

barbaz
Senior Member
Posts: 9720
Joined: Sat Aug 03, 2013 5:45 pm

Re: NoScript keeps losing settings v10.1.5.9

Post by barbaz » Mon Dec 18, 2017 4:33 pm

8-bit wrote:I'm running 10.1.5.9rc2 now (same as 10.1.5.9), and the behaviour of the clock is now reversed from my previous post. Clicking on trusted ONCE leaves the clock retracted (small) which is permanent. This seems to be the default behaviour now. You only need to click the trusted icon once and don't take any action on the clock to keep it as permanent.
Cannot confirm. One click on Trusted is still temp allow for me. Image
*Always* check the changelogs BEFORE updating that important software!
-

bo elam
Senior Member
Posts: 208
Joined: Sat Oct 14, 2017 2:25 am

Re: NoScript keeps losing settings v10.1.5.9

Post by bo elam » Mon Dec 18, 2017 4:51 pm

barbaz wrote:Cannot confirm. One click on Trusted is still temp allow for me. Image
Same here. Nothing has changed for me regarding clock with version 10.1.5.9rc2.

Bo
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:57.0) Gecko/20100101 Firefox/57.0

8-bit
Senior Member
Posts: 97
Joined: Thu Mar 16, 2017 7:43 pm

Re: NoScript keeps losing settings v10.1.5.9

Post by 8-bit » Mon Dec 18, 2017 5:07 pm

barbaz wrote:Cannot confirm. One click on Trusted is still temp allow for me. Image
You are correct.

The way I attempted to test it again was faulty. I already had it set to Trusted, then clicked on Default, and when I clicked back on Trusted again it held it's Trusted state. NEVER REFRESHED IN BETWEEN. Sorry for any confusion this may have caused. :?
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:57.0) Gecko/20100101 Firefox/57.0

Post Reply