Gigantic interface.

Ask for help about NoScript, no registration needed to post
8-bit
Senior Member
Posts: 97
Joined: Thu Mar 16, 2017 7:43 pm

Gigantic interface.

Post by 8-bit » Sat Dec 16, 2017 2:04 am

Is the new gigantisized interface how it is intended to be? I am running 10.5.8rc2, and when I click on the NS icon in the tool bar, the window is now HUGE! :shock:
Just curious...

8-bit!
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:57.0) Gecko/20100101 Firefox/57.0

barbaz
Senior Member
Posts: 9280
Joined: Sat Aug 03, 2013 5:45 pm

Re: Gigantic interface.

Post by barbaz » Sat Dec 16, 2017 2:43 am

Doesn't look that much bigger on my end with 10.1.5.8rc3. If 10.1.5.8rc3 is also gigantic for you, can you please post a screenshot?
*Always* check the changelogs BEFORE updating that important software!
-

NSUser100101

Re: Gigantic interface.

Post by NSUser100101 » Sat Dec 16, 2017 3:21 am

Looks like this on 10.1.5.8 for me:

Image
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

barbaz
Senior Member
Posts: 9280
Joined: Sat Aug 03, 2013 5:45 pm

Re: Gigantic interface.

Post by barbaz » Sat Dec 16, 2017 3:54 am

Gak.

What is your screen resolution?
Do you have HiDPI screen or similar?
*Always* check the changelogs BEFORE updating that important software!
-

8-bit
Senior Member
Posts: 97
Joined: Thu Mar 16, 2017 7:43 pm

Re: Gigantic interface.

Post by 8-bit » Sat Dec 16, 2017 4:02 am

barbaz wrote:Gak.

What is your screen resolution?
Do you have HiDPI screen or similar?
That's exactly what I am seeing as well. MacBook Pro 15" 2880 x 1800 (High DPI - approx 220)

Edit: Adding screen shot - actual size. rc3

Image
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:57.0) Gecko/20100101 Firefox/57.0

aliburda
Posts: 2
Joined: Sat Dec 16, 2017 11:57 am

[DEFECT] Noscript 10.1.5.8 UI element are exageratly large.

Post by aliburda » Sat Dec 16, 2017 12:20 pm

Noscript 10.1.5.8
Firefox 57.0.2 and Firefox Developer edition 58.b11
Windows 10 version 1709

The UI for Noscript is too large, blown out of proportion, as if zoomed to an extreme degree.
Since this happened suddenly and wasn't the case with previous versions of Noscript 10 on Firefox 57, I suspect this arose as the extension was updated to its now current version (10.1.5.8).
At first I thought I messed up with the zoom feature in the browser by mistake but after double checking, I can confirm the browser zoom is set to 100%.

For information as it may be relevant, my computer has an High DPI display; native resolution is 3200x1800 with a 200% scaling factor applied.

I will try to upload screenshots later if it helps clarify the issue.

Thanks.

EDIT: Screenshots

Image

Image
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

NSUser100101

Re: Gigantic interface.

Post by NSUser100101 » Sat Dec 16, 2017 12:52 pm

Yep, I just tried it on a 1920x1200 desktop screen without DPI scaling, and it looks normal, but my laptop has a 4k screen with increased DPI, and it is enormous per my screenshot above.
Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

RetiredGuy
Posts: 2
Joined: Sat Dec 16, 2017 2:22 pm

NoScript text suddenly huge

Post by RetiredGuy » Sat Dec 16, 2017 2:31 pm

When clicking on the NoScript icon in the toolbar, it presents a dialog box with huge text. Only a few words fit into the dialog box.
I uninstalled NoScript and reinstalled it, but the same thing happens.
Firefox 57.0.2 (64-bit) NoScript 10.1.5.8
I can use [ctrl][-] to temporarily shrink the text in the main options window, but it is only temporary and doesn't fix the pop-up dialog box.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

barbaz
Senior Member
Posts: 9280
Joined: Sat Aug 03, 2013 5:45 pm

Re: Gigantic interface.

Post by barbaz » Sat Dec 16, 2017 3:50 pm

Threads merged.
*Always* check the changelogs BEFORE updating that important software!
-

barbaz
Senior Member
Posts: 9280
Joined: Sat Aug 03, 2013 5:45 pm

Re: NoScript text suddenly huge

Post by barbaz » Sat Dec 16, 2017 3:51 pm

RetiredGuy wrote:When clicking on the NoScript icon in the toolbar, it presents a dialog box with huge text. Only a few words fit into the dialog box.
I uninstalled NoScript and reinstalled it, but the same thing happens.
Firefox 57.0.2 (64-bit) NoScript 10.1.5.8
I can use [ctrl][-] to temporarily shrink the text in the main options window, but it is only temporary and doesn't fix the pop-up dialog box.
Is this same issue as https://forums.informaction.com/viewtop ... =7&t=24208 ?
Last edited by barbaz on Sat Dec 16, 2017 7:24 pm, edited 1 time in total.
*Always* check the changelogs BEFORE updating that important software!
-

Azijn
Junior Member
Posts: 22
Joined: Sat Nov 25, 2017 2:01 pm

[bug] Oversize text in 10.1.5.8 for MacOS

Post by Azijn » Sat Dec 16, 2017 4:04 pm

The text is comically oversized when I push the NoScript icon.

My suspicion is that it's because I've got a Retina Screen and something goes wrong with text scaling.
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:57.0) Gecko/20100101 Firefox/57.0

barbaz
Senior Member
Posts: 9280
Joined: Sat Aug 03, 2013 5:45 pm

Re: Gigantic interface.

Post by barbaz » Sat Dec 16, 2017 4:05 pm

Threads merged.
*Always* check the changelogs BEFORE updating that important software!
-

Guest

Re: Gigantic interface.

Post by Guest » Sat Dec 16, 2017 6:04 pm

5K Mac Retina screen here - the NoScript UI is crazy big since the latest update.
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:57.0) Gecko/20100101 Firefox/57.0

RetiredGuy
Posts: 2
Joined: Sat Dec 16, 2017 2:22 pm

Re: NoScript text suddenly huge

Post by RetiredGuy » Sat Dec 16, 2017 6:31 pm

Yes, it is the same as the referenced topic.

[ok. Can't paste image :( ]
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

cyberpunkrocker
Posts: 1
Joined: Sat Dec 16, 2017 6:26 pm

Re: Gigantic interface.

Post by cyberpunkrocker » Sat Dec 16, 2017 6:33 pm

Same issue here, on a more or less normal Windows 10 laptop (1366x768). After update to 10.1.5.8, noscript fonts suddenly became HUGE (>twice the size of rest of the system fonts).

The 10.x.x.x has always used somewhat bad looking UI fonts. Why cannot it use the default fonts set by the user?
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

Post Reply