Not getting huge lag anymore since I stopped using NS

Ask for help about NoScript, no registration needed to post
Galvin
Posts: 15
Joined: Sat Jul 02, 2016 9:29 pm

Not getting huge lag anymore since I stopped using NS

Post by Galvin » Thu Dec 07, 2017 11:03 pm

Using firefox 57. Since I stopped using it. Firefox no longer has huge lag on certain sites after 10+ hours or use.

The one site it had the most lag from was www.coinigy.com. This is crypto charting site. I would have two tabs open on this site. And just simply clicking on one of the tabs firefox would lag or sometimes freeze for a split second.

Other sites not so much, but there always would be some lag. And this was with different versions of NS of 10.x

I thought addons never cause lag cause of the new changes in firefox 57?
Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

User avatar
Thrawn
Senior Member
Posts: 3106
Joined: Mon Jan 16, 2012 3:46 am
Location: Australia
Contact:

Re: Not getting huge lag anymore since I stopped using NS

Post by Thrawn » Thu Dec 07, 2017 11:08 pm

Galvin wrote:I thought addons never cause lag cause of the new changes in firefox 57?
:D I'm not sure who assured you of that?

Performance problems from NoScript are most often the XSS filter, which has certainly undergone significant change with NS 10 and is a work in progress. Please use Firefox 52 ESR with classic NoScript if you need stability.
======
Thrawn
------------
Religion is not the opium of the masses. Daily life is the opium of the masses.

True religion, which dares to acknowledge death and challenge the way we live, is an attempt to wake up.
Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/62.0.3202.94 Chrome/62.0.3202.94 Safari/537.36

bo elam
Senior Member
Posts: 194
Joined: Sat Oct 14, 2017 2:25 am

Re: Not getting huge lag anymore since I stopped using NS

Post by bo elam » Thu Dec 07, 2017 11:20 pm

Galvin, you could also try the latest beta. I installed 10.1.5.6rc2 last night, sites that I felt kind of took a lot, freezed, etc, are loading better with this version, including the one you linked. That site opened smoothly, changing tabs feel normal. There was another beta released after the one I installed, you could try that one also.
https://addons.mozilla.org/en-US/firefo ... 0.1.5.6rc3

Bo
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:57.0) Gecko/20100101 Firefox/57.0

Galvin
Posts: 15
Joined: Sat Jul 02, 2016 9:29 pm

Re: Not getting huge lag anymore since I stopped using NS

Post by Galvin » Fri Dec 08, 2017 5:49 pm

It won't lag right away, not till FF runs for 10 hours or so. Firefox also bleeds memory, firefox goes from like 2GB, to 6GB after 24 hours. So that could add to the lag not sure.
Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

Galvin
Posts: 15
Joined: Sat Jul 02, 2016 9:29 pm

Re: Not getting huge lag anymore since I stopped using NS

Post by Galvin » Sat Dec 09, 2017 7:34 pm

The new version fixed the lag issues after running for a long time. Thanks
Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

lancelot

Re: Not getting huge lag anymore since I stopped using NS

Post by lancelot » Sun Dec 10, 2017 3:54 pm

Same here. Not sure which change/fix it was, but after 10.1.5.6 tabs with video do not start lagging anymore for me.
Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

Post Reply