NoScript 10 and publishwith.me

Ask for help about NoScript, no registration needed to post
Peter 123
Junior Member
Posts: 28
Joined: Fri Nov 24, 2017 3:27 am

NoScript 10 and publishwith.me

Post by Peter 123 » Sun Dec 03, 2017 1:34 pm

"publishwith.me" is a site where you can create online a document (called "pad") in order to collaborate on this document together with others:
https://publishwith.me/

That's the starting page:

Image



When clicking on "Create new pad" a page like this will appear (in case that you allow the script for publishwith.me):

Image

Usually, when clicking on the blue bar on top of the pad (the bar with the words "PublishWith.me") you should be transferred back to the starting page. This worked without problems with NoScript 5.

With NoScript 10 something strange happens after clicking on the blue bar:
- The opened page (the pad) remains, but its contents (the text) disappears from the editor.
- Only after refreshing the page (the one with the pad) (either via NoScript either via Firefox) the starting page will appear as desired.

It must have to do with NoScript because when deactivating it, all works fine.

Edited:
Images in smaller size.
Last edited by Peter 123 on Mon Dec 04, 2017 3:04 am, edited 1 time in total.
Mozilla/5.0 (Windows NT 6.1; rv:57.0) Gecko/20100101 Firefox/57.0

User avatar
Thrawn
Senior Member
Posts: 3106
Joined: Mon Jan 16, 2012 3:46 am
Location: Australia
Contact:

Re: NoScript 10 and publishwith.me

Post by Thrawn » Sun Dec 03, 2017 10:40 pm

Which sites have you allowed vs blocked?
======
Thrawn
------------
Religion is not the opium of the masses. Daily life is the opium of the masses.

True religion, which dares to acknowledge death and challenge the way we live, is an attempt to wake up.
Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/62.0.3202.94 Chrome/62.0.3202.94 Safari/537.36

Peter 123
Junior Member
Posts: 28
Joined: Fri Nov 24, 2017 3:27 am

Re: NoScript 10 and publishwith.me

Post by Peter 123 » Mon Dec 04, 2017 2:59 am

I have allowed publishwith.me and explicitely blocked no site (google.analytics is on default):

Image
Mozilla/5.0 (Windows NT 6.1; rv:57.0) Gecko/20100101 Firefox/57.0

barbaz
Senior Member
Posts: 9283
Joined: Sat Aug 03, 2013 5:45 pm

Re: NoScript 10 and publishwith.me

Post by barbaz » Mon Dec 04, 2017 3:06 am

So does allowing google-analytics.com get it working?
*Always* check the changelogs BEFORE updating that important software!
-

Peter 123
Junior Member
Posts: 28
Joined: Fri Nov 24, 2017 3:27 am

Re: NoScript 10 and publishwith.me

Post by Peter 123 » Mon Dec 04, 2017 3:16 am

No. :( By allowing google.analytics first happened the same as when clicking on the blue bar on top: The contents/text of the pad disappeared. (After refreshing the page the contents were here again.)

Later (e.g. when creating a new pad) the situation is the same as described above: click on the blue bar ---> contents disappear ---> refreshing of the page ---> (only now) the redirection to the starting page works.

PS:
Peter 123 wrote: With NoScript 10 something strange happens after clicking on the blue bar:
- The opened page (the pad) remains, but its contents (the text) disappears from the editor.
- Only after refreshing the page (the one with the pad) (either via NoScript either via Firefox) the starting page will appear as desired.
I just tested it with the first version of NoScript 10 (10.1.1): The problem already exists there. (After deactivating NoScript, all works again as it should.)
Mozilla/5.0 (Windows NT 6.1; rv:57.0) Gecko/20100101 Firefox/57.0

Post Reply