Noscript trashes firefox 57 ????

Ask for help about NoScript, no registration needed to post
no-user

Noscript trashes firefox 57 ????

Post by no-user » Sat Dec 02, 2017 3:30 pm

12/02/17 --Ubuntu linux 16.04, firefox 57, latest noScript. Don't understand what triggers this but display for current tab displays all black with occasional blinking rectangle somewhere on screen, switching to some other tab causes that one to do the same. Top menu bar buttons (File, Edit, etc) start to disappear, entries on tab line disappear. Have to completely kill firefox and remove noscript.

Help! ?? !!

Dave
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0

User avatar
therube
Ambassador
Posts: 7681
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: Noscript trashes firefox 57 ????

Post by therube » Sat Dec 02, 2017 8:41 pm

57, though you're currently on 52?

How much RAM is FF using at these times?
If you disable NoScript, the same tabs will display correctly?
If you disable Hardware Acceleration in FF, is there any change?
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0 SeaMonkey/2.49.2

no-user

Re: Noscript trashes firefox 57 ????

Post by no-user » Sat Dec 02, 2017 11:27 pm

I backed away from 57, since I want NoScript active.
I didn't observe RAM directly. But the machine has 8GB, uses 3 GB without FF running. It didn't go to swap, so it was using less than 5 GB.
Once Firefox began showing damage, it was so damaged that I couldn't get to the addons page to remove Noscript. I killed FF, restarted, and immediately removed Noscript. FF then behaved normally.

One indication of trouble - mousing to or away from a tab (not clicking new tab) causes maybe a half-second of rapid flashing of the address/search bar.

I ran FF 57, installed Noscript and (somehow) provoked the damage. CPU and memory usage not exceptional. Disabled hardware acceleration, killed and restarted FF. Still rapid address/search bar flashing sometimes. Started new tab xx, properly displaying data. Switched to another tab, back to tab xx, now shows all blank, even with a reload. Mousing over a tab causes the top 3 lines (File/Edit/etc, tabs, search) to go mostly black, random. Sometimes page goes from black to displaying data, but the data is from another tab.
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0

pizzadude
Posts: 1
Joined: Sun Dec 03, 2017 12:10 am

Re: Noscript trashes firefox 57 ????

Post by pizzadude » Sun Dec 03, 2017 12:17 am

I have the same issue. I use Ubuntu MATE 17.10 on a Thinkpad T510i with intel ironlake graphics. The regular noscript popup performs fine, but as soon as I open the options page noscript and firefox start blinking and tabs start "freaking out". This has been an issue since the original Noscript 10 release. I think it's due to the amount of animations when you have a long list of allowed/denied sites in the options page, so maybe if Giorgio disabled animations on the options page it would be fine. But that's just my theory.
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0

User avatar
Giorgio Maone
Site Admin
Posts: 8972
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: Noscript trashes firefox 57 ????

Post by Giorgio Maone » Sun Dec 03, 2017 1:49 am

Removed most animations from 10.1.5.3rc1, please check it, thank you!
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

another guest

Re: Noscript trashes firefox 57 ????

Post by another guest » Sun Dec 03, 2017 2:13 am

Hello late night coding hero! Unfortunately it still hangs my 57.01 in Kubuntu 16.04 shortly after i open the settings page. When i am fast enough to close it the browser still works but stops loading most pages.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

User avatar
Just_Golem
Junior Member
Posts: 25
Joined: Tue Nov 28, 2017 11:04 am

Re: Noscript trashes firefox 57 ????

Post by Just_Golem » Sun Dec 03, 2017 2:16 am

Giorgio Maone wrote:Removed most animations from 10.1.5.3rc1, please check it, thank you!
Installed 10.1.5.3. Seems faster though some hesitations still visible in Debug Text box. When accessing or scrolling, text switches between Visible/Invisible many times before becoming Stable Visible

Then, as soon as I check Debug Box, all other open Tabs in FF then display Non-Working NoScript Preference tab
Screenshot https://twitter.com/Just_Golem/status/9 ... 9762252800
(edit) image above also shows wrong Icon being displayed on Twitter. It should be Partial Script Blocking with a 2 (doubleclick and tellapart) not "All Is Blocked" as we see here (end edit)

Image shows I am on Twitter but NS Prefs are shown, but it's just an Image of prefs, nothing can be done. I need to open a new instance of Twitter in another tab, then close original. Same goes for Forum tab

Also, when I click Debug, randomly NS Preference page displays on Black background instead of it's normal White
Mozilla/5.0 (X11; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0

no-user

Re: Noscript trashes firefox 57 ????

Post by no-user » Sun Dec 03, 2017 2:50 am

Installed new version rc1, brought up options page. Scrolling up and down is somewhat sluggish , and a new scroll position doesn't always show a full display - there are blank areas, mainly the left 5 columns. The rapid flashing is still there.

Killed FF and restarted. Didn't bring up options page. Could not provoke misbehavior.
Brought options page, scrolled up and down. Blank spots in display, as above, misbehavior started, as above.
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0

no-user

Re: Noscript trashes firefox 57 ????

Post by no-user » Thu Dec 07, 2017 2:40 pm

Installed noscript 10.1.5.5, same misbehavior. Many bursts of these error messages on originating terminal:

[Parent 20030, Main Thread] WARNING: file /build/firefox-bfYN6l/firefox-57.0.1+build2/ipc/chromium/src/base/shared_memory_posix.cc, line 216

and these

[GFX1-]: Failed 2 buffer db=0 dw=0 for 0, 0, 399, 20
[GFX1-]: Failed 2 buffer db=0 dw=0 for 0, 30, 1144, 75
[GFX1-]: Failed 2 buffer db=0 dw=0 for 0, 0, 399, 20
[GFX1-]: Failed 2 buffer db=0 dw=0 for 1131, 0, 13, 809
[GFX1-]: Failed 2 buffer db=0 dw=0 for 0, -1, 13, 258
[GFX1-]: Failed 2 buffer db=0 dw=0 for 0, 0, 1131, 2435
[GFX1-]: Failed 2 buffer db=0 dw=0 for 1131, 0, 13, 809
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0

User avatar
Giorgio Maone
Site Admin
Posts: 8972
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: Noscript trashes firefox 57 ????

Post by Giorgio Maone » Thu Dec 07, 2017 4:29 pm

Could you please check ldb 10.1.5.6rc2? Thanks.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

Tomatix
Senior Member
Posts: 60
Joined: Tue Dec 05, 2017 3:05 pm

Re: Noscript trashes firefox 57 ????

Post by Tomatix » Thu Dec 07, 2017 4:57 pm

Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0

another guest

Re: Noscript trashes firefox 57 ????

Post by another guest » Thu Dec 07, 2017 6:58 pm

Giorgio Maone wrote:Could you please check ldb 10.1.5.6rc2? Thanks.
Unfortunately it still hangs and kills most tabs once the settings page was opened.
Mozilla/5.0 (Windows NT 6.1; rv:52.0) Gecko/20100101 Firefox/52.0

no-user

Re: Noscript trashes firefox 57 ????

Post by no-user » Sun Dec 10, 2017 5:03 am

Just tried 10.1.5.7rc1, behavior same as before - incomplete site list on options page when scrolling, fast blinking and black areas when switching to other tabs.
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0

Post Reply