NoScript and Google search interface

Ask for help about NoScript, no registration needed to post
Peter 123
Junior Member
Posts: 28
Joined: Fri Nov 24, 2017 3:27 am

NoScript and Google search interface

Post by Peter 123 » Fri Dec 01, 2017 3:00 am

It seems that the latest version of NoScript (= 10.1.4) is responsible for the following problem because it appeared just now (a few minutes ago) for the first time (obviously immediately after NoScript 10.1.4 was installed):

Until version 10.1.4 NoScript helped me to keep the old-fashioned interface of Google search (the one with the black bar on top of the search page and with the column left of the search results where I could specify country, language, time etc. of my search. Since NoScript 10.1.4 this interface is gone and replaced by the new one. (If necessary I will provide pictures to show the difference.)

In my settings of NoScript I did not change anything for the Google page: the setting for www.google.de (respectively www.google.at) was (and is) set on "Default". And whatever I try to modify in NoScript, I cannot bring back the old interface of Google search. :(

So any kind of help would be highly appreciated.

Thanks in advance.
Mozilla/5.0 (Windows NT 6.1; rv:57.0) Gecko/20100101 Firefox/57.0

Pansa
Senior Member
Posts: 318
Joined: Fri Nov 24, 2017 10:30 pm

Re: NoScript and Google search interface

Post by Pansa » Fri Dec 01, 2017 3:13 am

Can't confirm.
Google.de set to default in NS 10.1.4 has still no-JS version.

Check the checkmarks in the default preset and confirm in the debug log?

To get the wanted site, all marks should be unset, and debug log should have
"DEFAULT": {
"capabilities": [],
"temp": false
},
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

barbaz
Senior Member
Posts: 9230
Joined: Sat Aug 03, 2013 5:45 pm

Re: NoScript and Google search interface

Post by barbaz » Fri Dec 01, 2017 3:14 am

Can't reproduce on google.at, google.de, or google.fr. When I do a search, it redirects to the black bar interface.

NoScript 10.1.4, Firefox 57.0.1, new profile
all google domains set to "Default" before testing
*Always* check the changelogs BEFORE updating that important software!
-

Peter 123
Junior Member
Posts: 28
Joined: Fri Nov 24, 2017 3:27 am

Re: NoScript and Google search interface

Post by Peter 123 » Fri Dec 01, 2017 3:28 am

Thank you, Pansa and barbaz, for your quick replies.

I just wanted to add the following PS to my first posting:

I reverted now to an older version of NoScript (I think it was 10.1.3c1) and the old (black bar) interface of Google was here again. After a short while NoScript updated automatically again to version 10.1.4 - and this time the old interface indeed remained. :D

So (at the moment) all is fine again. But your tests and responses are nevertheless very important for me as they assure that the old interface of Google is in fact retained (using the setting "Default").

So many thanks to you again. :D
Last edited by Peter 123 on Fri Dec 01, 2017 3:30 am, edited 1 time in total.
Mozilla/5.0 (Windows NT 6.1; rv:57.0) Gecko/20100101 Firefox/57.0

barbaz
Senior Member
Posts: 9230
Joined: Sat Aug 03, 2013 5:45 pm

Re: NoScript and Google search interface

Post by barbaz » Fri Dec 01, 2017 3:29 am

You're welcome. Image
*Always* check the changelogs BEFORE updating that important software!
-

Post Reply