NoScript redirects Twitter on FF to mobile site

Ask for help about NoScript, no registration needed to post
HappyInTheWest
Posts: 8
Joined: Wed Nov 29, 2017 9:49 pm

NoScript redirects Twitter on FF to mobile site

Post by HappyInTheWest » Thu Nov 30, 2017 8:18 pm

Hello - thanks for being here to answer questions. I have nowhere near the technical vocabulary and expertise you all do, so please speak slowly and use small words!

I'm on a 2014 Mac Air updated to High Sierra and FF Quantum.

This morning Twitter on Firefox started redirecting to the mobile site. In about:config I restored all the "useragent" lines to default, and restarted. No change.

Firefox in safe mode didn't have the problem.

So I disabled my add-ons one at a time, and it turned out NoScript is the villain. I reproduced the result twice.

What's my next step? I want to re-enable NS as soon as possible.
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:57.0) Gecko/20100101 Firefox/57.0

Pansa
Senior Member
Posts: 318
Joined: Fri Nov 24, 2017 10:30 pm

Re: NoScript redirects Twitter on FF to mobile site

Post by Pansa » Thu Nov 30, 2017 9:57 pm

HappyInTheWest wrote:Hello - thanks for being here to answer questions. I have nowhere near the technical vocabulary and expertise you all do, so please speak slowly and use small words!

I'm on a 2014 Mac Air updated to High Sierra and FF Quantum.

This morning Twitter on Firefox started redirecting to the mobile site. In about:config I restored all the "useragent" lines to default, and restarted. No change.

Firefox in safe mode didn't have the problem.

So I disabled my add-ons one at a time, and it turned out NoScript is the villain. I reproduced the result twice.

What's my next step? I want to re-enable NS as soon as possible.
That was standard behaviour of NS before Quantum, too.
If you don't allow the specific scripts, Twitter thinks that blocking the scripts means that you are on a mobile platform that doesn't have scripts, and redirects you.

So reactivate NS, check if you are running the current version (10.1.3)
then check if your settings for "default, untrusted and trusted" are correct

And then make a rule for "https://twitter.com/" (that's enough to stop the redirect for me)
you still need to allow other scripts (like twtimage for content).
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

HappyInTheWest
Posts: 8
Joined: Wed Nov 29, 2017 9:49 pm

Re: NoScript redirects Twitter on FF to mobile site

Post by HappyInTheWest » Thu Nov 30, 2017 10:06 pm

Pansa, thank you! Once again you've stepped up to help me out.

I followed you right up until this:
And then make a rule for "https://twitter.com/"
I know how to make rules (filters) in email programs. I haven't made one in NS. Is this analogous, with an if/then structure? How do I word the rule?
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:57.0) Gecko/20100101 Firefox/57.0

Pansa
Senior Member
Posts: 318
Joined: Fri Nov 24, 2017 10:30 pm

Re: NoScript redirects Twitter on FF to mobile site

Post by Pansa » Thu Nov 30, 2017 10:12 pm

you just open the options of NS, there is an input line near the top.
just add the domain and press the arrow.
Then press the "trusted" button for that entry.

You might want to read
https://forums.informaction.com/viewtop ... =7&t=23974
to get an idea of what NS is all about, and how to work with it.
Last edited by Pansa on Thu Nov 30, 2017 10:15 pm, edited 1 time in total.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

HappyInTheWest
Posts: 8
Joined: Wed Nov 29, 2017 9:49 pm

Re: NoScript redirects Twitter on FF to mobile site

Post by HappyInTheWest » Thu Nov 30, 2017 10:14 pm

Excellent. I'll take all these steps tonight. Much obliged!
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:57.0) Gecko/20100101 Firefox/57.0

Pansa
Senior Member
Posts: 318
Joined: Fri Nov 24, 2017 10:30 pm

Re: NoScript redirects Twitter on FF to mobile site

Post by Pansa » Thu Nov 30, 2017 10:16 pm

I pasted the wrong link, sorry. I edited my mistake.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

HappyInTheWest
Posts: 8
Joined: Wed Nov 29, 2017 9:49 pm

Re: NoScript redirects Twitter on FF to mobile site

Post by HappyInTheWest » Thu Nov 30, 2017 10:19 pm

Noted! No prob, hadn't even clicked yet.
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:57.0) Gecko/20100101 Firefox/57.0

HappyInTheWest
Posts: 8
Joined: Wed Nov 29, 2017 9:49 pm

Re: NoScript redirects Twitter on FF to mobile site

Post by HappyInTheWest » Mon Dec 18, 2017 7:37 pm

It took me this long to prioritize fixing this! Pansa, I appreciate the link.

I did everything again I did on the first go-round and several times after: allowing all scripts that are integral and necessary for Twitter, then reloading the page. This time, it worked. Maybe a bug was fixed between then and now?

I hate mysteries that have no answer, but hey, I'll take it! And thank you again for your help.
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:57.0) Gecko/20100101 Firefox/57.0

Pansa
Senior Member
Posts: 318
Joined: Fri Nov 24, 2017 10:30 pm

Re: NoScript redirects Twitter on FF to mobile site

Post by Pansa » Mon Dec 18, 2017 9:47 pm

HappyInTheWest wrote:It took me this long to prioritize fixing this! Pansa, I appreciate the link.

I did everything again I did on the first go-round and several times after: allowing all scripts that are integral and necessary for Twitter, then reloading the page. This time, it worked. Maybe a bug was fixed between then and now?

I hate mysteries that have no answer, but hey, I'll take it! And thank you again for your help.
You probably made a ...twitter.com rule now (that is new since the initial exchange)
which you can set from the mobile site, and applies to both mobile and non-mobile version, since it applies to everything below twitter.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

glengineered

Re: NoScript redirects Twitter on FF to mobile site

Post by glengineered » Wed Jan 10, 2018 10:38 pm

I've just spent 20 minutes trying to deal with this problem.

I've been temporarily allowing ...twitter.com and ...twimg.com, but it still redirected.

It wasn't until I went into options and also temporarily allowed https://twitter.com that it stopped.

Smells like a bug to me?
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0

Pansa
Senior Member
Posts: 318
Joined: Fri Nov 24, 2017 10:30 pm

Re: NoScript redirects Twitter on FF to mobile site

Post by Pansa » Thu Jan 11, 2018 3:22 am

glengineered wrote:I've just spent 20 minutes trying to deal with this problem.

I've been temporarily allowing ...twitter.com and ...twimg.com, but it still redirected.

It wasn't until I went into options and also temporarily allowed https://twitter.com that it stopped.

Smells like a bug to me?
Can't confirm.
Setting the temp trust for ...twitter and ... twimg.com, and then manually hitting back (to actually reload the base domain instead of just reloading the mobile page) has worked for me since basically forever now.

when you said "in the options" did you manually type it in the input field? Because ...twitter.com includes https://twitter.com.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

User avatar
Giorgio Maone
Site Admin
Posts: 8768
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: NoScript redirects Twitter on FF to mobile site

Post by Giorgio Maone » Thu Jan 11, 2018 11:42 am

To put it simple: Twitter redirects scriptless browsers (including Firefox w/ NoScript) to the mobile version, which is in its own separate domain.
If you set twitter.com and twimg.com to TRUSTED and reload, you're just reloading the mobile version ("m.twitter.com"). In order to get the desktop version, you either need to go back (like Pansa said), or input "twitter.com" manually, or use a bookmark.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

jbjb

Re: NoScript redirects Twitter on FF to mobile site

Post by jbjb » Wed Feb 05, 2020 7:03 pm

Argg it seems that since a few days twitter now forces to their mobile site if twitter and twimg are set "untrusted" in latest firefox.
Mozilla/5.0 (Windows NT 10.0; rv:72.0) Gecko/20100101 Firefox/72.0

skriptimaahinen
Senior Member
Posts: 171
Joined: Wed Jan 10, 2018 7:37 am

Re: NoScript redirects Twitter on FF to mobile site

Post by skriptimaahinen » Wed Feb 05, 2020 10:02 pm

It would appear changing useragent helps here too (like with google search).

Unfortunately the old way to change useragent on FireFox does not work anymore (viewtopic.php?f=7&t=25573&sid=1fbfa7253 ... 45#p101612).

Quoting myself:
First of all, since FF71, site specific settings (general.useragent.override.somesite.com) do not work anymore. The pref has been removed.

Also note that general.useragent.override (global useragent change) has no effect if privacy.resistFingerprinting is enabled.

The official way to change useragent from now on is to use webextension. Sorry, do not have any recommendations to give but for quick testing I like to use FireFox's Responsive Design Mode. It has built-in useragent switcher.
Mozilla/5.0 (Windows NT 10.0; rv:68.0) Gecko/20100101 Firefox/68.0

Guest

Re: NoScript redirects Twitter on FF to mobile site

Post by Guest » Fri Feb 07, 2020 5:28 pm

Thank you for pointing the extension way, i used GoodTwitterby Zusor and everything is back to normal, way nicer and hundreds of bookmarks now usable again. fingers crossed til the next twittergola :-)
Mozilla/5.0 (Windows NT 10.0; rv:72.0) Gecko/20100101 Firefox/72.0

Post Reply