NoScript and sticky videos

Ask for help about NoScript, no registration needed to post
HappyInTheWest
Posts: 8
Joined: Wed Nov 29, 2017 9:49 pm

NoScript and sticky videos

Post by HappyInTheWest » Wed Nov 29, 2017 9:29 pm

First of all: thank you thank you thank you for NoScript! I so appreciate all your hard work. I've contributed what I can monetarily, and hope many others are doing the same.

Since the upgrade to Quantum and reinstalling the new NS, pop-up "sticky" videos are following me down the page on multiple news sites. Not ads, but news video features.

On some pages I can close them with one click; on one site, I can't close it at all.

Is it NoScript that was saving me from those before the upgrade? Will it block them again sometime soon?

Thanks!
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:57.0) Gecko/20100101 Firefox/57.0

Pansa
Senior Member
Posts: 318
Joined: Fri Nov 24, 2017 10:30 pm

Re: NoScript and sticky videos

Post by Pansa » Wed Nov 29, 2017 9:35 pm

1. Which version of noscript specifically?
2. what do your presets (default, untrusted and trusted) look like.
3. Confirm that the check marks set there are also like that in the debug log in the options.

If the videos are active, it basically means for some reason or other you have allowed the scripts that do that.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

HappyInTheWest
Posts: 8
Joined: Wed Nov 29, 2017 9:49 pm

Re: NoScript and sticky videos

Post by HappyInTheWest » Wed Nov 29, 2017 10:02 pm

Pansa, I just went to some of the pages where I've been having the problem and can't reproduce them. I'm on a different laptop, where I just downloaded NS this morning.

I have the problem on my primary laptop, where I downloaded it as soon as the new version was announced. So it appears to be isolated to one computer. I'll reload NS when I'm back on that one, and report back.

Thanks very much for the fast input!
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:57.0) Gecko/20100101 Firefox/57.0

HappyInTheWest
Posts: 8
Joined: Wed Nov 29, 2017 9:49 pm

Re: NoScript and sticky videos

Post by HappyInTheWest » Mon Dec 11, 2017 9:37 pm

Update: I've had a second problem with NS: it's forcing my Twitter feed into the mobile view on my laptop. I disabled all other add-ons, and NS is the culprit.

So unfortunately, I'm back to running Firefox without NS protections, and whether it will block sticky videos is moot. I'm looking for something to block those in the meantime.

I'll upgrade NS as prompted, and with any luck I can turn it back on, view Twitter normally, see if NS blocks those damned videos, then report back again.

Thanks.
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:57.0) Gecko/20100101 Firefox/57.0

User avatar
Giorgio Maone
Site Admin
Posts: 9065
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: NoScript and sticky videos

Post by Giorgio Maone » Mon Dec 11, 2017 9:49 pm

HappyInTheWest wrote:Update: I've had a second problem with NS: it's forcing my Twitter feed into the mobile view on my laptop. I disabled all other add-ons, and NS is the culprit.
You mean you open twitter.com and it redirects to m.twitter.com?
It doesn't happen to me. Is twitter.com marked as TRUSTED?
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

jb

Re: NoScript and sticky videos

Post by jb » Fri Dec 15, 2017 5:56 pm

j have the same problem with twitter : it goes from https://twitter.com/pseudo to https://mobile.twitter.com/pseudo

and all the twitter/twimg are set to untristed(default)
Mozilla/5.0 (Windows NT 10.0; rv:57.0) Gecko/20100101 Firefox/57.0

Pansa
Senior Member
Posts: 318
Joined: Fri Nov 24, 2017 10:30 pm

Re: NoScript and sticky videos

Post by Pansa » Fri Dec 15, 2017 6:36 pm

If you make a ...twitter rule instead of one for https://m.twitter.com it works after you manually press the "back" button in the browser.

The thing is the first time you click the link it redirects you to the mobile version, and it stays there unless you go back.
No script should also allow you to add "https://twitter.com" specifically in the options menu, but it doesn't let me press the + button in 10.1.5.7 for some reason.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

Post Reply