[FIXED] NoScript 10.1.3 (not RC) un-maximizes FF57

Ask for help about NoScript, no registration needed to post
Pansa
Senior Member
Posts: 318
Joined: Fri Nov 24, 2017 10:30 pm

[FIXED] Re: NoScript 10.1.3 (not RC) un-maximizes FF57

Post by Pansa » Fri Dec 01, 2017 3:59 am

Just_Golem wrote: No Longer works in Private Mode as in a few versions back. :-( :-(
Can't confirm
opening page in private mode adheres to preset rules.
Overlay opens functionally.
Changing rule applies to page.

Are you sure capabilities of your rule-set is in order?
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

User avatar
Just_Golem
Junior Member
Posts: 25
Joined: Tue Nov 28, 2017 11:04 am

Re: NoScript 10.1.3 (not RC) un-maximizes FF57

Post by Just_Golem » Fri Dec 01, 2017 4:13 am

Pansa wrote:
Just_Golem wrote: No Longer works in Private Mode as in a few versions back. :-( :-(
Can't confirm
opening page in private mode adheres to preset rules.
Overlay opens functionally.
Changing rule applies to page.

Are you sure capabilities of your rule-set is in order?

Well, visited Site in private mode, to look at Videos ;-) ;-) , click on Icon and ask Temporary Allow, Icon say OK than it says 19 Objects are still Blocked, click again on Icon and it ONLY show Main Site Listed as Trusted and no other sites are displayed and since Videos come from elsewhere, videos and OK button do not work. So, does not work in Private Mode???? :-) :-)
Mozilla/5.0 (X11; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0

Pansa
Senior Member
Posts: 318
Joined: Fri Nov 24, 2017 10:30 pm

Re: NoScript 10.1.3 (not RC) un-maximizes FF57

Post by Pansa » Fri Dec 01, 2017 4:22 am

Just_Golem wrote:
Pansa wrote:
Just_Golem wrote: No Longer works in Private Mode as in a few versions back. :-( :-(
Can't confirm
opening page in private mode adheres to preset rules.
Overlay opens functionally.
Changing rule applies to page.

Are you sure capabilities of your rule-set is in order?

Well, visited Site in private mode, to look at Videos ;-) ;-) , click on Icon and ask Temporary Allow, Icon say OK than it says 19 Objects are still Blocked, click again on Icon and it ONLY show Main Site Listed as Trusted and no other sites are displayed and since Videos come from elsewhere, videos and OK button do not work. So, does not work in Private Mode???? :-) :-)
Are you sure capabilities of your rule-set is in order?.......
check if trusted actually allows all scripts. (and confirm in the debug log under "capabilities" of each rule-preset).

alternatively:
https://forums.informaction.com/viewtop ... =7&t=23986
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

barbaz
Senior Member
Posts: 9266
Joined: Sat Aug 03, 2013 5:45 pm

Re: NoScript 10.1.3 (not RC) un-maximizes FF57

Post by barbaz » Fri Dec 01, 2017 4:43 am

Just_Golem wrote:
Pansa wrote:
Just_Golem wrote: No Longer works in Private Mode as in a few versions back. :-( :-(
Can't confirm
opening page in private mode adheres to preset rules.
Overlay opens functionally.
Changing rule applies to page.

Are you sure capabilities of your rule-set is in order?

Well, visited Site in private mode, to look at Videos ;-) ;-) , click on Icon and ask Temporary Allow, Icon say OK than it says 19 Objects are still Blocked, click again on Icon and it ONLY show Main Site Listed as Trusted and no other sites are displayed and since Videos come from elsewhere, videos and OK button do not work. So, does not work in Private Mode???? :-) :-)
Just_Golem started a new thread about this problem - https://forums.informaction.com/viewtop ... =7&t=23987
That was the correct thing to do. Please continue that discussion there.
*Always* check the changelogs BEFORE updating that important software!
-

nxindy89
Posts: 1
Joined: Fri Dec 01, 2017 5:08 pm

Re: NoScript 10.1.3 (not RC) un-maximizes FF57

Post by nxindy89 » Fri Dec 01, 2017 5:22 pm

Looks like I'm just confirming the "un-maximize FF window bug" WX64, FF 57 NS 10.1.3. Thanks for the good work. I pray for the strength to overcome my arthritis and somehow struggle through this obnoxious development, and go up and click the maximize icon when needed. :)
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

lbecque
Posts: 2
Joined: Wed Nov 22, 2017 6:54 am

Re: 10.1.3 small bug, restore/maximize window sizing problem

Post by lbecque » Fri Dec 01, 2017 8:38 pm

10.1.5 all the below is fixed. Thanks for the quick response Giorgio!
lbecque wrote:Giorgio, nice job on the latest UI improvements! It is starting to come along and make sense, be more intuitive now. Certainly huge improvement in the number of clicks. I think I already like the new interface better than the old one prior to Quantum.

Anyway, I noticed a very small bug in the latest release today concerning windowing and their sizes. Here is how to reproduce:
Open a browser window maximized to full screen.
Click on the NoScript "S" icon. Result:
1) The NoScript pulldown UI appears as it should.
2) What also happens (and it shouldn't) is that the browser window is resized. The icon on the upper right of the window between the 'minimize' and 'close' buttons changes from 'restore' to 'maximize'

If you click on the "S" icon again to close the NoScript pulldown UI nothing happens to the browser window sizing and it is not restored to maximum.

If you repeat the above procedure but first click 'restore' then manually resize the window to approx. 2/3 the screen in both horizontal and vertical (but make sure the entire smaller window fits on the screen) then click 'maximize' before clicking the "S" NoScript icon the pulldown UI fails to appear completely, the screen size changes to close to maximum on both the horizontal and vertical and part of the screen is shifted to the right off the screen where it is not view-able and so is the bottom of the window off the screen.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

User avatar
hakimoto
Posts: 5
Joined: Thu Nov 30, 2017 10:46 am

Re: NoScript 10.1.3 (not RC) un-maximizes FF57

Post by hakimoto » Wed Dec 06, 2017 10:08 am

Fixed for me in 10.1.5.x.
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0

Post Reply