Empty NoScript Menu

Ask for help about NoScript, no registration needed to post
cruzzer

Empty NoScript Menu

Post by cruzzer » Tue Nov 28, 2017 10:05 am

Bug:
1. Left-Click No-Scipt Icon
2. Menu is empty (although icon shows scripts, was not empty with 10.1.1, 10.1.2)
3. Click away
4. Empty NoScript Window pops up.

Fix attempts:
-Restart Firefox
-Disabled/Enabled NoScript

Info:
- MacOS 10.12
- Firefox 57.0 64 Bit
- No other extensions active
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:57.0) Gecko/20100101 Firefox/57.0

tigerjack
Posts: 8
Joined: Tue Nov 28, 2017 10:59 am

Re: Empty NoScript Menu

Post by tigerjack » Tue Nov 28, 2017 11:03 am

Same behaviour here.
Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/62.0.3202.94 Safari/537.36

AndrewTheWookiee
Posts: 1
Joined: Tue Nov 28, 2017 5:59 pm

Re: Empty NoScript Menu

Post by AndrewTheWookiee » Tue Nov 28, 2017 6:01 pm

Same thing is happening for me.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

cruzzer

Re: Empty NoScript Menu

Post by cruzzer » Wed Nov 29, 2017 7:47 am

I can confirm that this issue persists with 10.1.3c3.
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:57.0) Gecko/20100101 Firefox/57.0

cruzzer

Re: Empty NoScript Menu

Post by cruzzer » Wed Nov 29, 2017 8:31 am

I was fearing to reset firefox, but It turned out not to be as bad as expected.

Workaround:
1. enable/use mozilla sync
2. open about:config
3. click: refresh firefox
4. sync/activate sync to retrieve settings

Firefox will delete all settings and re-import things like logins on startup. The sync will then restore elements chosen for sync, e.g. bookmarks. This worked for me, your mileage may vary.
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:57.0) Gecko/20100101 Firefox/57.0

8-bit
Senior Member
Posts: 97
Joined: Thu Mar 16, 2017 7:43 pm

Re: Empty NoScript Menu

Post by 8-bit » Wed Nov 29, 2017 8:41 am

Not seeing this bahaviour here... Although several of you can repro. Has anyone attampted a full uninstall/re-install of NS with the latest version?
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:57.0) Gecko/20100101 Firefox/57.0

cruzzer

Re: Empty NoScript Menu

Post by cruzzer » Wed Nov 29, 2017 10:06 am

I don't know what you mean with a "full" uninstall and re-install, but if you mean "remove" under about:adddons/Extensions, then yes. I installed the latest version 10.1.3c3 and the problem persisted. Then I removed it, restarted Firefox and re-installed NoScript. This appeared to not resolve it for me.

I then proceeded to resetting Firfox which then fixed my issue. Resetting a browser is more of a workaround, but then again Giorgio was under great pressure to release NS 10 rather sooner than later. So these kind of issue are to be expected and fine with me.
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:57.0) Gecko/20100101 Firefox/57.0

Clangers

Re: Empty NoScript Menu

Post by Clangers » Wed Nov 29, 2017 11:49 am

I have also had this issue. I removed noscript and then used the 'Refresh Firefox' option on the download page on Mozzila's website before reinstalling noscript. This seems to have fixed the problem for me.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

tigerjack
Posts: 8
Joined: Tue Nov 28, 2017 10:59 am

Re: Empty NoScript Menu

Post by tigerjack » Wed Nov 29, 2017 12:32 pm

Same here, the workaround using the `Refresh Firefox` button + resync seems to have worked.
Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/62.0.3202.94 Safari/537.36

tigerjack
Posts: 8
Joined: Tue Nov 28, 2017 10:59 am

Re: Empty NoScript Menu

Post by tigerjack » Wed Nov 29, 2017 1:58 pm

tigerjack wrote:Same here, the workaround using the `Refresh Firefox` button + resync seems to have worked.
...well, until I rebooted the laptop.
Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/62.0.3202.94 Safari/537.36

Post Reply