"Disable" in Add-ons Manager really disables NoScript

Ask for help about NoScript, no registration needed to post
User avatar
gracious1
Junior Member
Posts: 20
Joined: Sat Sep 16, 2017 7:33 pm

"Disable" in Add-ons Manager really disables NoScript

Post by gracious1 » Mon Oct 23, 2017 11:50 am

Here's what happened in SeaMonkey 2.48 on Ubuntu 14.04 :

1. I upgraded to NoScript 5.1.2, and re-enabled it (it had been disabled).
2. I decided to disable NS, and clicked "Disable" in the Add-ons Manager, but to my surprise I didn't get the dialog box asking me to keep the anti-clickjacking and other protections going and just disable script-blocking.
3. I restarted SeaMonkey. Button still appeared in the Status Bar.
4. In Add-ons Manager, I clicked "Disable" again, and this time I did see the dialog asking me whether I wanted to retain anti-clickjacking protection, etc. and just disable script-blocking.
5. I agreed to just disabling script-blocking.
6. I restarted SeaMonkey
7. The icon/button in the status bar disappeared. Additionally, the icon in the Add-ons Manager disappeared, like so:
Image
(click on thumbnail for larger view)

At this point, I could not adjust any preferences for NS in the Add-ons Manager (clicking the Preferences button was useless), but I was able to disable NS completely.

EDIT: Shortly after I wrote this, I got notification that 5.1.3 has been released. I'll re-post after I test.
Mozilla/5.0 (X11; Linux x86_64; rv:45.9) Gecko/20100101 Goanna/3.2 Firefox/45.9 PaleMoon/27.4.2

User avatar
gracious1
Junior Member
Posts: 20
Joined: Sat Sep 16, 2017 7:33 pm

Re: SeaMonkey 2.48 - NoScript UI bizarreness

Post by gracious1 » Mon Oct 23, 2017 12:07 pm

Okay, I repeated the steps, as follows:

1. NoScript was already disabled.
2. Upgrade NoScript to 5.1.3
3. Clicked "Enable" in Add-ons Manager.
4. Statusbar button appeared, and indicated that I still had script-blocking deactivated. ("Global blocking advised").
5. Re-started browser.
6. Statusbar button still there! I checked Add-ons Manager, and the icon is still there too.

So I guess whatever was wrong was fixed in this new release? :?: :mrgreen:

EDIT: I spoke too soon!

7. Using statusbar button, I re-activated global script blocking
8. In Add-ons Manager, I clicked "Disable"
9. Warning dialog popped up; I selected to keep the other protections but disable script-blocking. The icon immediately disappeared from the Add-ons Manager.
10. I rebooted the browser.
11. The NoScript icon reappeared, but NoScript was completely disabled, not just script-blocking. And the statusbar icon was gone, too, of course.
Mozilla/5.0 (X11; Linux x86_64; rv:45.9) Gecko/20100101 Goanna/3.2 Firefox/45.9 PaleMoon/27.4.2

User avatar
therube
Ambassador
Posts: 7426
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: SeaMonkey 2.48 - NoScript UI issues

Post by therube » Mon Oct 23, 2017 2:58 pm

10. I rebooted the browser.
11. The NoScript icon reappeared, but NoScript was completely disabled, not just script-blocking. And the statusbar icon was gone, too, of course.
Confirmed, well sort of.

Though I've got to assume that NoScript is actually running (in a Globally Allow mode, though no way to interact with it, i.e., icon).


> (in a Globally Allow mode, though no way to interact with it, i.e., icon)

Is that expected?

And as noted, the Icon, in Addons Manager, is missing.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 5.1; rv:52.0) Gecko/20100101 SeaMonkey/2.49.1

User avatar
therube
Ambassador
Posts: 7426
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: SeaMonkey 2.48 - NoScript UI issues

Post by therube » Mon Oct 23, 2017 3:09 pm

Confirmed, well sort of.

Though I've got to assume that NoScript is actually running (in a Globally Allow mode, though no way to interact with it, i.e., icon).
Nope, just Confirmed, confirmed - forget the "sort of" part.

NoScript is not running at all.

NoScript (...3232) no longer shows up in extensions.ini.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 5.1; rv:52.0) Gecko/20100101 SeaMonkey/2.49.1

User avatar
Giorgio Maone
Site Admin
Posts: 8701
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: "Disable" in Add-ons Manager really disables NoScript

Post by Giorgio Maone » Mon Oct 23, 2017 3:23 pm

I edited the original post's title to reflect my understanding of this report, please correct me if I'm wrong.
So the problem is that no matter what the "usual" safety prompt tells you about not entirely disabling NoScript, if you use the [Disable] button the Add-on Manager just does its job.
It's surely a regression due to the different disablement mechanics in restartless extensions, and admittedly something I overlooked.
In the meanwhile I suppose you can just use "Forbid scripts globally" if it is what you want to do, and [Disable] if you want NoScript to be completely disabled, with the advantage that you can re-enable it right away now that it's restartless.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0

User avatar
therube
Ambassador
Posts: 7426
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: "Disable" in Add-ons Manager really disables NoScript

Post by therube » Mon Oct 23, 2017 3:42 pm

with the advantage that you can re-enable it right away now that it's restartless
Actually, you can't.
Clicking (Addons Manager) Enable is a non-starter because even though NoScript shows in Addons Manager, it is not really there. (And clicking on Enable, or maybe even any "NoScript" entry there, may (did in my case) lock up that window/tab [I was able to completely close the browser, Ctrl+Q [in SeaMonkey], without having to close it.)

NoScript (...3232) does remain in /extensions/, so it is physically there.
But to "re-enable" NoScript, you'll have to actually install it again (either by download/install, or simply drag from /extensions/ directory into a browser window). (Or suppose you could hack extensions.ini to reflect correctly before opening [SeaMonkey]. Did not check to see if the same occurs in FF?]
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 5.1; rv:52.0) Gecko/20100101 SeaMonkey/2.49.1

User avatar
gracious1
Junior Member
Posts: 20
Joined: Sat Sep 16, 2017 7:33 pm

Re: "Disable" in Add-ons Manager really disables NoScript

Post by gracious1 » Tue Oct 24, 2017 5:52 pm

Giorgio Maone wrote:I edited the original post's title to reflect my understanding of this report, please correct me if I'm wrong.
So the problem is that no matter what the "usual" safety prompt tells you about not entirely disabling NoScript, if you use the [Disable] button the Add-on Manager just does its job.
Well, I titled it the way I did, because the problem appeared to be a UI issue, until I went further with my testings. But your title better encapsulates what the matter is! :ugeek:
Giorgio Maone wrote:It's surely a regression due to the different disablement mechanics in restartless extensions, and admittedly something I overlooked.
In the meanwhile I suppose you can just use "Forbid scripts globally" if it is what you want to do, and [Disable] if you want NoScript to be completely disabled, with the advantage that you can re-enable it right away now that it's restartless.
I can say as an end-user that I never had any problems with NoScript whilst it was a XUL/overlay kind of extension that required a restart. I certainly don't mind having to restart to get an extension to work properly.

Also, it is still the case that. to get the release notes (e.g. https://noscript.net/?ver=5.1.3) you still have to restart the browser anyway. There is kind of a disconnect when you install NoScript, and then maybe you do some other things,, and then you quit your browser. And then the next day you start it again, and, oh look, there are the Release Notes for that extension I installed yesterday!
Mozilla/5.0 (X11; Linux x86_64; rv:45.9) Gecko/20100101 Goanna/3.2 Firefox/45.9 PaleMoon/27.4.2

User avatar
gracious1
Junior Member
Posts: 20
Joined: Sat Sep 16, 2017 7:33 pm

Re: "Disable" in Add-ons Manager really disables NoScript

Post by gracious1 » Tue Oct 24, 2017 7:05 pm

A similar problem appears in Pale Moon 27.5.1 (64-bit) in Ubuntu 14.04, with some minor differences.

Steps to reproduce:
  1. Start with a new profile.
  2. Install NoScript 5.1.3.
  3. Restart Pale Moon.
  4. Open Add-ons Manager and click Disable button for NoScript.
  5. When warning dialog appears, choose to disable global-blocking but keep other protections
    In Add-ons Manager, it appears that NoScript is disabled, and that it will be re-enabled on restart.
    Image
  6. Click "Restart now".
  7. After browser restart, re-open Add-ons Manager. NoScript appears enabled, but the icon is gone.
    Image


Also I want to point out another thing: caption says "Extra protection for your Firefox"; should say "Extra protection for your Pale Moon". :mrgreen:
(BTW, for anyone reading who is not aware, the blue dot is normal. It means that the application was targetted for Pale Moon in the install.rdf. Firefox-targetted applications get an orange dot.)
Mozilla/5.0 (X11; Linux x86_64; rv:45.9) Gecko/20100101 Goanna/3.2 Firefox/45.9 PaleMoon/27.4.2

barbaz
Senior Member
Posts: 9176
Joined: Sat Aug 03, 2013 5:45 pm

Re: "Disable" in Add-ons Manager really disables NoScript

Post by barbaz » Tue Oct 24, 2017 8:29 pm

gracious1 wrote:A similar problem appears in Pale Moon 27.5.1 (64-bit) in Ubuntu 14.04, with some minor differences.

Steps to reproduce:
[...]
Confirmed, in both Pale Moon and SeaMonkey.
gracious1 wrote:Also I want to point out another thing: caption says "Extra protection for your Firefox"; should say "Extra protection for your Pale Moon". :mrgreen:
Nope. That text is static, it has no way to detect the browser type, and NoScript is mainly used by Firefox users. Best to leave it saying Firefox.
*Always* check the changelogs BEFORE updating that important software!
-

User avatar
Giorgio Maone
Site Admin
Posts: 8701
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: "Disable" in Add-ons Manager really disables NoScript

Post by Giorgio Maone » Tue Oct 24, 2017 11:24 pm

Took quite a drastic route in latest development build 5.1.4rc1, but I really need to focus on pure WebExtension now.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0

Post Reply