PM 27 - NoScript status bar icon disappears with 5.1.3rc2

Ask for help about NoScript, no registration needed to post
User avatar
gracious1
Junior Member
Posts: 20
Joined: Sat Sep 16, 2017 7:33 pm

PM 27 - NoScript status bar icon disappears with 5.1.3rc2

Post by gracious1 » Fri Oct 20, 2017 1:50 pm

When I upgraded to 5.1.1, I had no problems. I had heard there were issues with Pale Moon & 5.1.2, so I refrained from upgrading until I saw the release notes stating that the URL bar issue was fixed in the developmental builds. So I upgraded to 5.1.3rc2, and I experienced the disappearing icon in the status bar. I restarted the browser (no need to go to Safe Mode first), and this corrected the problem.

This occurred with Pale Moon 27.4.2 x86_84 on Ubuntu 14.04 LTS. I made this a separate thread from the other thread since that is about NS 5.1.2 in Firefox 56, and you seemed to imply that it was fixed in the developmental builds (it hasn't, at least not for Pale Moon.) My apologies if you think this should have gone in that thread.

BTW, I installed 5.1.3rc2 in Pale Moon 27.6.0a1 for the first time, and the icon appeared as it should. But this was not an upgrade but rather a new install.
Mozilla/5.0 (X11; Linux x86_64; rv:45.9) Gecko/20100101 Goanna/3.2 Firefox/45.9 PaleMoon/27.4.2

barbaz
Senior Member
Posts: 9180
Joined: Sat Aug 03, 2013 5:45 pm

Re: PM 27 - NoScript status bar icon disappears with 5.1.3rc

Post by barbaz » Fri Oct 20, 2017 5:09 pm

gracious1 wrote: I made this a separate thread from the other thread since that is about NS 5.1.2 in Firefox 56, and you seemed to imply that it was fixed in the developmental builds (it hasn't, at least not for Pale Moon.) My apologies if you think this should have gone in that thread.
That issue is not dealt with in dev builds yet. But since this concerns Pale Moon and not Firefox, the separate thread is fine for now. We'll merge the threads if Giorgio decides that's appropriate.

Does the workaround from the other thread work in Pale Moon too? -
UPDATE WITH A FIX
  1. Firefox menu > Help (?) > Restart with Add-ons disabled
  2. Click the [Continue in Safe Mode] button
  3. Restart the browser again normally: NoScript UI should be back now :)
  4. Please report here the list of your add-ons as shown in about:support no need for this anymore, we've got enough data, thank you all!
Thanks and sorry for the inconvenience, we're trying to figure out what exactly is happening and how to make sure it doesn't happen again.
Furthermore, if you feel extra adventurous and helpful, please install 5.1.3rc1 from https://noscript.net/getit#devel, to provide us with some indication on what to expect on next update.
-- Giorgio
*Always* check the changelogs BEFORE updating that important software!
-

User avatar
gracious1
Junior Member
Posts: 20
Joined: Sat Sep 16, 2017 7:33 pm

Re: PM 27 - NoScript status bar icon disappears with 5.1.3rc

Post by gracious1 » Sun Oct 22, 2017 6:23 am

barbaz wrote:Does the workaround from the other thread work in Pale Moon too?
Well, as I thought I had stated (or at least implied) in my original post, it wasn't necessary for me to take the trouble to restart in Safe Mode and then restart normally. I simply did File -> Restart (which is a built-in feature of PM as of v. 27.5). The simple restart restored the UI without the intervening step of going into Safe Mode.

So as far I can see, this is not any sort of extension conflict. :|
Mozilla/5.0 (X11; Linux x86_64; rv:52.9) Gecko/20100101 Goanna/3.4 Firefox/52.9 PaleMoon/27.6.0a1

barbaz
Senior Member
Posts: 9180
Joined: Sat Aug 03, 2013 5:45 pm

Re: PM 27 - NoScript status bar icon disappears with 5.1.3rc

Post by barbaz » Sun Oct 22, 2017 11:56 pm

Sorry, I missed that part of your post.

Does it disappear again when you upgrade to 5.1.3rc3?
If so, when this issue occurs, do you see anything related in the Browser Console? (Ctrl-Shift-J)
(if you don't know what's related, turn off CSS warnings and post everything else you see)
*Always* check the changelogs BEFORE updating that important software!
-

User avatar
gracious1
Junior Member
Posts: 20
Joined: Sat Sep 16, 2017 7:33 pm

Re: PM 27 - NoScript status bar icon disappears with 5.1.3rc

Post by gracious1 » Mon Oct 23, 2017 12:35 pm

After I read your post, I found that 5.1.3 had been released, so I have not tried 5.1.3rc3 .

So I upgraded to 5.1.3. This time a different UI oddity occurred. On one window, I got a two NoScript buttons, as illustrated below.

{Actually, I can't show you. Every time I try to post an image or any kind of URL, I get an anti-spam warning.!}

The one on the right, which has a red outline and a down arrow, pops up a context menu when you right-click it. The one the left, which is all-white, pops up the menu on hover.

Two other windows were open, and they only showed the one button, the all-white button.

EDIT: Actually, it's worse than that. So frustrated. :evil: I've just suffered some bizarre UI issues, including the disappearance of buttons from modal dialogs. I had to completely disable NoScript and then use Clean Install to remove all the prefs to get my profile work again. :cry:


Image

Image
Last edited by therube on Mon Oct 23, 2017 2:48 pm, edited 1 time in total.
Reason: screenshots entered into post
Mozilla/5.0 (X11; Linux x86_64; rv:45.9) Gecko/20100101 Goanna/3.2 Firefox/45.9 PaleMoon/27.4.2

User avatar
Giorgio Maone
Site Admin
Posts: 8701
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: PM 27 - NoScript status bar icon disappears with 5.1.3rc

Post by Giorgio Maone » Mon Oct 23, 2017 2:48 pm

gracious1 wrote: EDIT: Actually, it's worse than that. So frustrated. :evil: I've just suffered some bizarre UI issues, including the disappearance of buttons from modal dialogs. I had to completely disable NoScript and then use Clean Install to remove all the prefs to get my profile work again. :cry:
You mean affecting just NoScript's UI or other stuff as well?
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0

User avatar
gracious1
Junior Member
Posts: 20
Joined: Sat Sep 16, 2017 7:33 pm

Re: PM 27 - NoScript status bar icon disappears with 5.1.3rc

Post by gracious1 » Tue Oct 24, 2017 5:23 pm

Giorgio Maone wrote:
gracious1 wrote: EDIT: Actually, it's worse than that. So frustrated. :evil: I've just suffered some bizarre UI issues, including the disappearance of buttons from modal dialogs. I had to completely disable NoScript and then use Clean Install to remove all the prefs to get my profile work again. :cry:
You mean affecting just NoScript's UI or other stuff as well?
Other stuff. For example, when I did Restart , the modal dialog that asks "Are you sure you want to restart" had its buttons missing. The text of the buttons was there, but there was no button drawn.
Mozilla/5.0 (X11; Linux x86_64; rv:45.9) Gecko/20100101 Goanna/3.2 Firefox/45.9 PaleMoon/27.4.2

Post Reply