[FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

Ask for help about NoScript, no registration needed to post
Darklord

Re: [Fix] Fx 56 - NoScript icon disappeared on 5.1.2 update

Post by Darklord » Sat Oct 14, 2017 11:48 am

Hi,

this is the first time I saw problems with NoScript and not a very big one, I assume.

Today I also recognized the symbol missing (FF56, Win10, 64 bit). Also, I was noticed by NoScript that the currently installed version is outdated and I installed the addon with the new version 5.1.2 again.
The symbol re-appeared and no further issues so far. I hope the addon will work after the new FF update to ver 57.

Keep up your great work with this great and really important addon.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0

f00dl3
Posts: 2
Joined: Sat Oct 14, 2017 11:43 am

Firefox 56 showstopper

Post by f00dl3 » Sat Oct 14, 2017 11:49 am

In Firefox 56 there is a big issue where i have NoScript installed, it shows installed in extensions, it actively works, but does not show on status bar - which makes it pretty much a problem because I am unable to enable scripts for a site it's blocking. I tried going into the Toolbar but there is no Add Ons toolbar and/or no option in the View->Toolbars->Customize for any add-ons what so ever.

I have found that by re-installing NoScript every time I restart Firefox I can get the toolbar back. I imagine this is part of the move to "more secure extensions," but at the same time, it's really a show stopper.
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0

not-applicable

Re: FX 55 - no script icon disappeared on 5.1.2 update

Post by not-applicable » Sat Oct 14, 2017 11:54 am

I've had this bug too, I found I could fix it by disabling Noscript from within the addons menu, restarting firefox, re-enabling noscript and restarting again.

I wonder if the "safe browsing version 4" add-on (mozilla made this appear as a "study" in firefox on my system, I'm not sure what these studes are about but I've heard bad rumours about one being done with something called cliqz) might have caused this issue?
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:56.0) Gecko/20100101 Firefox/56.0

mary7
Posts: 10
Joined: Sat Aug 19, 2017 11:05 am

Re: [Fix] Fx 56 - NoScript icon disappeared on 5.1.2 update

Post by mary7 » Sat Oct 14, 2017 11:57 am

finally returned all ok
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0

Guest

Re: [Fix] Fx 56 - NoScript icon disappeared on 5.1.2 update

Post by Guest » Sat Oct 14, 2017 12:25 pm

Fix described in the first post worked for me.
Addon list as requested:
Extensions
Name Version Enabled ID
Adblock Plus 2.9.1 true {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
NoScript 5.1.2 true {73a6fe31-595d-460b-a920-fcc0f8843232}
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:56.0) Gecko/20100101 Firefox/56.0

randomouser

Re: Fx 56 - NoScript icon disappeared on 5.1.2 update

Post by randomouser » Sat Oct 14, 2017 12:30 pm

Giorgio Maone wrote:All you, also those who fixed it by restarting in safe mode, could you please post the list of your extensions (from about:support)?
Even if we've got a few report, I'm still unable to reproduce this issue and I'd really like to pinpoint it, no matter if a work-around seems to exist. Thanks!

Here's the list:

Add-ons Manager - Version Number 1.05.2017
Clean Links 2.7.1-signed.1-signed
Click to Play per-element 0.3.4
CloudHole 1.04.2004
DevEdition theme enabler 1.0.1
Disable Plugin & Mimetype Enumeration 1.1.5.1-signed
Distill Web Monitor 1.06.2024
DownThemAll! 3.0.8
Enhanced Steam 9.05.2017
Enhancer for YouTube™ 2.0.40
Ghostery 7.3.3.7
Google search link fix 1.06.2005
h264ify 1.0.6
HTTPS Everywhere 2017.10.4
Master Password+ 1.28.2
NewsFox 1.0.9.4.1
NoScript 5.01.2002
OmniSidebar 1.06.2015
Plain Text Linker 1.02.2006
Privacy Settings 0.2.6
Reddit Enhancement Suite 5.08.2006
Simple Locale Switcher 1.0.2
Stylish 2.0.7
Tampermonkey 4.05.5553
Text Link 5.0.2016031501
uBlock Origin 1.14.14
uMatrix 1.01.2000
Update Scanner 3.03.2002
Video Blocker 5.02.2006
Video DownloadHelper 6.03.2001
Volatile Storage 0.5.1-signed.1-signed
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0

Guest

Re: [Fix] Fx 56 - NoScript icon disappeared on 5.1.2 update

Post by Guest » Sat Oct 14, 2017 12:38 pm

FF 56.0

Blank Your Monitor + Easy Reading 1.9.13.1-signed.1-signed true
NoScript 5.1.2 true
Safe Browsing Version 4 (temporary add-on) 1.0.0 true sbv4-gradual-rollout@mozilla.com
Ubuntu Modifications 3.4 false
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0

LarsXYZ

Re: Fx 56 - NoScript icon disappeared on 5.1.2 update

Post by LarsXYZ » Sat Oct 14, 2017 12:39 pm

Verteron wrote:Just experienced this myself and found out it was because the latest FF update had not applied like usual.
That's probably why the safe mode trick worked,because it triggered the FF update.
So,not a bug with NS ;)
Hmm must be a NS bug, I'm running FF 55.03 since it was released
I stopped FF automatic updates for the reason that I don't want to loose legacy add-on's like NoScript and AddBlock Plus, since they might not work from FF 57 ....
But the automatic add-on update killed NS as other describe here .... :-(
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:55.0) Gecko/20100101 Firefox/55.0

Ed

Re: [Fix] Fx 56 - NoScript icon disappeared on 5.1.2 update

Post by Ed » Sat Oct 14, 2017 12:39 pm

After you restart in safe mode, you then need to close the browser and reopen it again.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0

FredFlyntstein

Re: [Fix] Fx 56 - NoScript icon disappeared on 5.1.2 update

Post by FredFlyntstein » Sat Oct 14, 2017 12:46 pm

Safemode restart works.

Noticed that [continue in safe mode] dialog box was cut off at bottom

Running:
CookieCuller
HTTPS Everywhere
NoScript

Thank-you for this software.
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:56.0) Gecko/20100101 Firefox/56.0

brockford

Re: [Fix] Fx 56 - NoScript icon disappeared on 5.1.2 update

Post by brockford » Sat Oct 14, 2017 12:56 pm

Safemode / Normal restart restored NoScript icons

Using Firefox 56.0 (Linux 4.13.5)

Extensions:

Name: Brief
Version: 2.3.0
Enabled: true
ID: brief@mozdev.org

Name: bug892485_PreventScrollOnHistory
Version: 1.1.1-signed.1-signed
Enabled: true
ID: bug892485@alice

Name: Classic Theme Restorer
Version: 1.7.1
Enabled: true
ID: ClassicThemeRestorer@ArisT2Noia4dev

Name: Cleanest Addon Manager
Version: 7.1
Enabled: true
ID: cam@sdrocking.com

Name: FindBar Tweak
Version: 2.1.12
Enabled: true
ID: fbt@quicksaver

Name: Floff
Version: 0.4.1-signed.1-signed
Enabled: true
ID: floff@.fx

Name: IdentFavIcon
Version: 0.3.4.7.1-signed.1-signed
Enabled: true
ID: identfavicon@david.hanak.hu

Name: NoScript
Version: 5.1.2
Enabled: true
ID: {73a6fe31-595d-460b-a920-fcc0f8843232}

Name: Open Bookmarks in New Tab
Version: 2.0.2016021001
Enabled: true
ID: openbookmarkintab@piro.sakura.ne.jp

Name: Private Tab
Version: 0.2.2
Enabled: true
ID: privateTab@infocatcher

Name: SavedSearchButton
Version: 1.4b1
Enabled: true
ID: savedsearchbutton@alice0775

Name: Status-4-Evar
Version: 2017.08.20.15
Enabled: true
ID: status4evar@caligonstudios.com

Name: Tree Style Tab
Version: 0.19.2017090601
Enabled: true
ID: treestyletab@piro.sakura.ne.jp

Name: Unified Sidebar
Version: 0.1.2011111101.1-signed.1-signed
Enabled: true
ID: unifiedsidebar@piro.sakura.ne.jp

Name: xclear
Version: 1.8.2
Enabled: true
ID: xclear@as-computer.de

Name: Print/Print Preview
Version: 1.0.1-signed
Enabled: false
ID: {19EB90DC-A456-458b-8AAC-616D91AAFCE1}
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:50.0) Gecko/20100101 Firefox/50.0

netzteil

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

Post by netzteil » Sat Oct 14, 2017 1:07 pm

Firefox menu > Help (?) > Restart with Add-ons disabled
Click the [Continue in Safe Mode] button
Restart the browser again normally: NoScript UI should be back now :)
Wfm
Mozilla/5.0 (Windows NT 6.1; rv:56.0) Gecko/20100101 Firefox/56.0

Martyzy

Re: Fx 56 - NoScript icon disappeared on 5.1.2 update

Post by Martyzy » Sat Oct 14, 2017 1:09 pm

Giorgio Maone wrote:All you, also those who fixed it by restarting in safe mode, could you please post the list of your extensions (from about:support)?
Even if we've got a few report, I'm still unable to reproduce this issue and I'd really like to pinpoint it, no matter if a work-around seems to exist. Thanks!

I removed and re-installed NoScript add-on and that restored the primary button but I still am missing other ones like the Revoke Temporary Permissions button that I used to be able to add to the menu bar on the bottom

I am using FF 55.0.3 because every update seems to mess up another add-in or other function so I'm waiting a while.

Here are my add-ins as requested:

Name Version Enabled
Adblock Plus 2.9.1 true
BetterPrivacy 1.77 true
Blur 7.7.2395 true
Element Hiding Helper for Adblock Plus 1.4 true
Flash Control 2.1.4 true
Ghostery 7.3.3.7 true
GoogleSharing 0.22.1-signed.1-signed true
HTTPS Everywhere 2017.10.4 true
IsraBlock 0.0.30 true
NoScript 5.1.2 true
RefControl 0.8.17.1-signed.1-signed true
Saved Password Editor 2.10.3 true
Show my Password 2.0.1-signed.1-signed true
Status-4-Evar 2017.03.19.12b true
Yahoo Mail Hide Ad Panel 3.0 true
ADB Helper 0.11.2 false
Avast Online Security 12.0.296 false
Facebook™ Disconnect 0.1.5 false
The Addon Bar (restored) 3.2.9-compat-fixed-4 false
uBlock Origin 1.14.14 false
Valence 0.3.8 false
Webmail Ad Blocker 5.0.5.2 false
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:55.0) Gecko/20100101 Firefox/55.0

hax85
Posts: 1
Joined: Sat Oct 14, 2017 1:22 pm

Re: FX 55 - no script icon disappeared on 5.1.2 update

Post by hax85 » Sat Oct 14, 2017 1:30 pm

My NoScript Icon disappeared too and I don't have this new Safe Browsing addon from Mozilla. Disabling, restart re-eanabling, restart doesn't work for me :(
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0

marsh mexico

Re: Fx 56 - NoScript icon disappeared on 5.1.2 update

Post by marsh mexico » Sat Oct 14, 2017 1:32 pm

albany road wrote:
Giorgio Maone wrote:All you, also those who fixed it by restarting in safe mode, could you please post the list of your extensions (from about:support)?
Even if we've got a few report, I'm still unable to reproduce this issue and I'd really like to pinpoint it, no matter if a work-around seems to exist. Thanks!
Safe mode restart ==> OK

56.0.1 64 bit, Windows 7 64 bit

EXTENSIONS
  • BetterPrivacy 1.77 true
    Dark Background and Light Text 0.5.11 true
    Decentraleyes 2.0.0 true
    Firefox Notes 1.8.0 true
    FireShot 0.98.93 true
    Gestionnaire de session 0.8.1.13 true
    Grammalecte [fr] 0.5.18 true
    HTTPS Everywhere 2017.10.4 true
    NoScript 5.1.2 true
    Privacy Badger 2017.9.12.1 true
    Safe Browsing Version 4 (temporary add-on) 1.0.0 true
    Test Pilot 2.0.4-dev-18ce799 true
    uBlock Origin 1.14.15b1 true
    uMatrix 1.0.1rc4 true
    Video DownloadHelper 6.3.1 true
    Skype 8.3.0.9150 false
Other machine : 56.0 64 bit, LinuxMint 17.3 (rosa)

Nothing to fix, no problem this time !

EXTENSIONS
  • Dark Background and Light Text 0.5.11 true
    Decentraleyes 2.0.0 true
    FireShot 0.98.93 true
    Gestionnaire de session 0.8.1.13 true
    Grammalecte [fr] 0.5.18 true
    HTTPS Everywhere 2017.10.4 true
    NoScript 5.1.2 true
    uBlock Origin 1.14.15b1 true
    uMatrix 1.0.1rc4 true
    Video DownloadHelper 6.3.1 true
    anonymoX 3.3.1 false
    Fasterfox 3.9.85.1-signed.1-signed false
    Magic Actions for YouTube™ 6.9.1.2 false
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0

Post Reply