[FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

Ask for help about NoScript, no registration needed to post
barbaz
Senior Member
Posts: 9268
Joined: Sat Aug 03, 2013 5:45 pm

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

Post by barbaz » Tue Oct 24, 2017 2:41 pm

Meotialora wrote:AT THE MOMENT THE ADDON PAGE SHOW ME A "LEGACY" YELLOW LABEL AND THE EXPLANATION IS https://support.mozilla.org/en-US/kb/fi ... =inproduct .

HAVE FUN.
First off, typing in all caps does not mean what you think it means. See this link.

Second, what makes you think the "Legacy" label has anything to do with the icon disappearance?
*Always* check the changelogs BEFORE updating that important software!
-

User avatar
boteman
Posts: 2
Joined: Tue Oct 24, 2017 7:43 pm
Location: soFLA
Contact:

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

Post by boteman » Tue Oct 24, 2017 8:20 pm

barbaz wrote: Second, what makes you think the "Legacy" label has anything to do with the icon disappearance?
As a user it seems like more than a coincidence that the LEGACY flag appeared in Firefox add-ons at approximately the same time as the NoScript icon disappeared. But only the developers have sufficient information to make an informed decision about that. In any case they have their work cut out for them to conform to the new add-on schema imposed by Mozilla; maybe that will solve this problem at the same time?

I too recently noticed that the NoScript icon disappeared. It does not appear in my Bookmarks toolbar nor anywhere else that I can find nor can I access it via Ctrl-Shift-\ or any other key combination. The only way to access it is by typing in about:addons and clicking the NoScript Options button there.

I am running
Firefox 55.0.3 (64-bit)
Win7-64 Windows 7 64-bit with all current MicroSoft updates applied
NoScript was 5.1.2 when I first noticed the disappearing icon last week, it just automatically updated to 5.1.3 but has the same behavior

other addons/plugins/extensions/whatever Mozilla calls them this week:
uBlock Origin 1.14.16
END OF LIST

Hope this helps.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0

CodeMonkeyJ
Posts: 1
Joined: Wed Oct 25, 2017 6:54 am

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

Post by CodeMonkeyJ » Wed Oct 25, 2017 7:02 am

Might be a coincidence, but this brought it back for me:

+ Uninstalled NoScript
+ Restarted FF
+ Installed NoScript
+ Restarted FF

This brought it back temporarily. Without restarting FF, while the icon is still there:

+ Used the Customize menu to remove it from the menu
+ Uninstalled, restarted, reinstalled, restarted

The NoScript pictograms now appear in the Customize menu permanently (at least survived a couple full PC restarts), and can be added back to the menu.

Edit: I think that's what I did. I may not have uninstalled/reinstalled after removing it from the menu. YMMV, it could still just be a coincidence.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0

Meotialora

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

Post by Meotialora » Wed Oct 25, 2017 9:44 am

barbaz wrote:
Meotialora wrote:AT THE MOMENT THE ADDON PAGE SHOW ME A "LEGACY" YELLOW LABEL AND THE EXPLANATION IS https://support.mozilla.org/en-US/kb/fi ... =inproduct .

HAVE FUN.
First off, typing in all caps does not mean what you think it means. See this link.

Second, what makes you think the "Legacy" label has anything to do with the icon disappearance?

Sorry for my Uppercase , was an error and the mean was only the thing I wrote .
I noticed the LEGACY after a FF update (when the Noscript icon disappear).

BTW solved now uninstalling and reinstalling and re-configuring FF and Noscript.

Thanks
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0

x1097
Posts: 4
Joined: Fri Oct 20, 2017 8:41 am

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

Post by x1097 » Wed Oct 25, 2017 1:27 pm

x1097 wrote:I am trying to do it one profile at a time, but the workaround won't work unless *no other* firefox-profile is concurrently opened at the time of the restart-with-addons disabled. Also it appears that even when the workaround succeeds (when no other profile is opened), then as soon as I close that firefox-instance and reopen the same profile then the NoScript icons are gone again. Installing NoScript from https://noscript.net seems to be effective temporarily. Maybe the behaviour that "Restart with addons disabled" opens the wrong firefox profile if other firefox-profiles are already opened while the restart is happening - is a Firefox issue and not a NoScript issue.
In my case, shutting down ubuntu 16.04.03 cleanly and restarting seemed to cure the issue with the fix "not sticking". Additionally since the arrival of NoScript 5.1.3 , I have had no issues. Thanks for the suggestions and support.
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0

Lehamego

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

Post by Lehamego » Thu Oct 26, 2017 1:45 am

Not aware of a fix, I just uninstalled NoScript and re installed it. Problem solved.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0

Guest

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

Post by Guest » Thu Oct 26, 2017 4:33 am

Buongiorno,
da quello che ho capito, il problema di noscript è che Firefox ha cambiato la "tecnologia" (tecnologia non dice nulla; saranno i servizi? le firme dei metodi????) su cui si devono basare gli addin

https://support.mozilla.org/it/kb/novit ... =inproduct

Questo fa in modo che non sia visibile l'icona anche se no-Script sta funzionando. I'unico modo che ho trovato di vedere l'icona è reinstallare ogni volta ma se riapro Firefox l'icona non c'è.
E0 previsto un upgrade di No-Script per usare la nuova "tecnologia"?
Grazie
Mario
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:56.0) Gecko/20100101 Firefox/56.0

Guest

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

Post by Guest » Thu Oct 26, 2017 4:36 am

in english too

Good morning,
from what I understand, the noscript problem is that Firefox has changed the "technology" (technology does not say anything, the services will be the methods signatures ????) on which addins should be based

https://support.mozilla.org/it/kb/novit ... =inproduct

This ensures that the icon is not visible even if no-Script is running. The only way I've found to see the icon is to reinstall every time but if I re-open the Firefox icon there is not.
Is a No-Script upgrade to use the new "technology" planned?
Thank you
Mario
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:56.0) Gecko/20100101 Firefox/56.0

barbaz
Senior Member
Posts: 9268
Joined: Sat Aug 03, 2013 5:45 pm

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

Post by barbaz » Thu Oct 26, 2017 4:57 am

*Always* check the changelogs BEFORE updating that important software!
-

RnDDude

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

Post by RnDDude » Thu Oct 26, 2017 9:06 am

Good news? Icon is OK, did not disappear, in Ffx 48.0.2 running on 64-bit Mac OS X 10.7.5 and a 64-bit Core i5. And, the Temporarily allow... and the Revoke Temporar... icons are both shown in the Customize... dialog, too.

Yes, I know, I have to upgrade; but for now, thank you, Giorgio, for keeping NoScript compatible with this old Firefox and OS! Love it!
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:48.0) Gecko/20100101 Firefox/48.0

maurix
Posts: 19
Joined: Tue Jun 23, 2015 1:35 pm

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

Post by maurix » Thu Oct 26, 2017 1:13 pm

I have had to uninstall 5.1.4 as it happened with 5.1.2.
This time noscript is preventing the login from quite a number of sites (i.e. mediaworld).
I guess I will keep 5.1.3 for a while. Never happened before.
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:45.0) Gecko/20100101 Firefox/45.0

FunkyBoss

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

Post by FunkyBoss » Fri Oct 27, 2017 3:13 pm

All I had to do was install the plug-in again and restart my browser.
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:56.0) Gecko/20100101 Firefox/56.0

Yehya

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

Post by Yehya » Sat Oct 28, 2017 3:04 am

This problem maybe began with new 5.1.2 or with newest Firefox upgrade last fortnight . NoScript was present and busy blocking but not reachable through icon or low bar ( which i use every minute ) . Through the menu of Firefox i could read that my noscript settings were normal thus lying that reachable ¨show menu¨ , and i didn´t find much tool , maybe deleting and reinstalling .
So , I go to site noscript.net and reinstall . Every time i close down Firefox and restart Firefox and/or pc ( about every week , or 9 seconds ) , icon and bar are gone ( which the settings don´t admit ) . So i go to site noscript.net and reinstall again and again after closing ( throwing away every job on screen ) and starting Firefox . Even my usual settings survive. ( BTW Never choose setting to Forbid Every java , the icon and bar will disappear too , you need this trick to fix it ) .
Problem gone since 5.1.3 today . By the way , i saw that the numbers in noscript.net/?ver=5.1.3&prev=5.1.2 were the other way round , that is noscript.net/?ver=5.1.2&prev=5.1.3 or something alike , i´m not sure about ¨ver¨ ? !
This hour after finding 5.1.3 , every time i close down and restart Firefox ( or pc ) , i get a kind of homepage of noscript , wrong , it is the usual report after upgrade noscript.net/?ver=5.1.3&prev=5.1.2 , on my screen , again and again , plus icon and low bar . Very welcome , it seems that my trick has become standard . Anyhow , i don´t have to invite an update to get the icon back this hour .
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0

TechJD
Posts: 1
Joined: Sun Oct 29, 2017 1:57 pm

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

Post by TechJD » Sun Oct 29, 2017 2:09 pm

I applied fix and it worked on my Windows 10 Tablet till I restarted
then buttones and icons were gone agaain
trying 5.1.4 now
Mozilla/5.0 (Windows NT 10.0; rv:56.0) Gecko/20100101 Firefox/56.0

yuppiepuppie

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

Post by yuppiepuppie » Sun Oct 29, 2017 5:15 pm

This is also a problem for me on Ubuntu Linux x86_64 - the icon(and all alerts do not display not matter how NoScript is configured).

I read elsewhere that this issue is fixed in Firefox 56.0.1 but many distributions have not built past 56.0 because there are no security fixes in 56.0.1.
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0

Post Reply