[FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

Ask for help about NoScript, no registration needed to post
User avatar
Giorgio Maone
Site Admin
Posts: 8735
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

Post by Giorgio Maone » Fri Oct 20, 2017 12:14 pm

x1097 wrote: Seems that "Restart with addons disabled" uses the profile of the already-running "other" profile, instead of the profile that this instance of Firefox has been invoked.

Any suggestions?
Do it for each profile needed, possibly starting Firefox with the -safe-mode command line flag.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0

x1097
Posts: 4
Joined: Fri Oct 20, 2017 8:41 am

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

Post by x1097 » Fri Oct 20, 2017 12:56 pm

I am trying to do it one profile at a time, but the workaround won't work unless *no other* firefox-profile is concurrently opened at the time of the restart-with-addons disabled. Also it appears that even when the workaround succeeds (when no other profile is opened), then as soon as I close that firefox-instance and reopen the same profile then the NoScript icons are gone again. Installing NoScript from https://noscript.net seems to be effective temporarily. Maybe the behaviour that "Restart with addons disabled" opens the wrong firefox profile if other firefox-profiles are already opened while the restart is happening - is a Firefox issue and not a NoScript issue.
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0

Tim Fowler

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

Post by Tim Fowler » Fri Oct 20, 2017 2:09 pm

I had a similar problem in the past. I went to customize in Firefox. The NoScript Icon wasn't there. Reset to default. Then the NoScript icon was in customize, dragged it where I wanted it to be and redid my other customizations.

With 5.12 the noscript icon disappeared but that solution didn't work. Instead I removed NoScript. Closed Firefox, reopened Firefox, and installed NoScript again, and the problem was resolved.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0

Norm Mosher

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

Post by Norm Mosher » Fri Oct 20, 2017 5:56 pm

I've tried all of the above, and there's still no sign of the NoScript icon.

Fortunately, Ctl-Shift-\ does work.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0

rasn

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

Post by rasn » Sat Oct 21, 2017 2:36 am

I'm one of the odd cases who successfully updated to NS-5.1.2. Summary of my browsing system is below:

* Firefox-56.0: 64 bit: Pre-built binary from Mozilla; System Installed (i.e. NOT a *.deb or *.rpm package).
* OS: GNU+Linux: x86_64.
* Extensions: NoScript only, manually updated only.

At least once a day, if accessing my system, I check for updates available for the web browser & NoScript (amongst other things).

When Firefox told me an update was available to NS-5.1.1; I asked FF to download & install the update - which it did, and immediately opened a tab showing the new NS release notes. I then closed the browser session and launched a new session. The NS icon was available and has remained so after each browser session since.

I thought I'd send this through in case it is of any use, and apologise for taking so long to do so.
Mozilla/5.0 (X11; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0

mintuser

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

Post by mintuser » Sat Oct 21, 2017 1:35 pm

I was having the same problem with the NoScript icon disappearing. I am running a 32 bit Firefox in 32 bit Linux MX 16. The icon reappeared after I reinstalled NoScript but disappeared after the next reboot. On another machine on which I have Linux Mint 17.3 installed also a 32 bit machine the problem was not happening. The difference that I could see was that on the machine running MX 16 there was another add-on, a temporary security thing from Mozilla, that was not listed in the extensions list of the Linux Mint machine. I tried disabling it but that did not solve the problem so I removed it, the Mozilla temporary security add-on. That seems to have fixed the problem. I just did this 15 min. ago but I tested by rebooting and the icon stayed. Mozilla must have sent the add-on with the 56.0.1 version of Firefox but why to the machine running MX16 but not the machine running Linux Mint 17.3. They are both older IBM Intel 32 bit desktops?
Mozilla/5.0 (X11; Linux i686; rv:56.0) Gecko/20100101 Firefox/56.0

Friend of NS

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

Post by Friend of NS » Sat Oct 21, 2017 3:15 pm

Hi,
I'm running a fresh Ubuntu 16.04.3 64bit install - all default Fx so far except for NS installed via noscript.net. Only a single profile.
The Fx reported version is 56 64bit which I guess you can confirm in this post.

I've had no bugginess with the menu bar icon using the default NS install, except for changing the open permissions item away from mouse hover to
left clicking.

Any testing you want done in this clean install I'd be happy to do. Things like installing older NS versions and then upgrading spring to mind, but you're the boss.
It'll probably stay nice and clean for a couple of weeks while I get used to all the Fx stuff again after a long time hiding in SM.
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0

Guest

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

Post by Guest » Sat Oct 21, 2017 9:35 pm

I tried the recommended FIX namely restarting into Safe Mode, and then restarting normally, but the NoScript icon did not reappear. HOWEVER what did happen was that a few new icons appeared in the 'customize' menu for the Bookmarks Toolbar, and the NoScript icon was among them. So I dragged the appropriate icon into the Bookmarks Toolbar and now everything is working as expected.

Cheers Stephen
W7, 4Gb, AMD Raid-1
Mozilla/5.0 (Windows NT 6.1; rv:56.0) Gecko/20100101 Firefox/56.0

muspench

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

Post by muspench » Sun Oct 22, 2017 7:27 pm

Yes, NoScript icon disappeared after 10/21/2017 update to 5.1.2. Fixed it by reinstalling, used green INSTALL button on this page: https://noscript.net/. No restart required. Firefox 55.0.3 (32-bit).
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:55.0) Gecko/20100101 Firefox/55.0

redhawk

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

Post by redhawk » Mon Oct 23, 2017 1:35 pm

I have tried this fix several times. It doesn't work for me.
Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:56.0) Gecko/20100101 Firefox/56.0

redhawk

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

Post by redhawk » Mon Oct 23, 2017 1:43 pm

redhawk wrote:I have tried this fix several times. It doesn't work for me.
Then I noticed the post about the bookmarks menu, so I tried that and I was able to add the icon manually
Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:56.0) Gecko/20100101 Firefox/56.0

starshrink

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

Post by starshrink » Mon Oct 23, 2017 5:47 pm

On Mac-OS 10.11.6 and Firefox 56.0 (64 bit) the update lead to NoScript disappearing. I've uninstalled and re-installed NoScript, then it worked again (didn't get the notifcation message about blocked scripts, and icon on menu bar was gone). I haven't tried out the fix, because I only saw it now when restarting FF and seeing that NoScript had updated to 5.1.3.
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:56.0) Gecko/20100101 Firefox/56.0

stumped

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

Post by stumped » Mon Oct 23, 2017 6:17 pm

The no script status bar is missing. I am using Firefox. I am unable to view pages. How do I fix this?
Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0

barbaz
Senior Member
Posts: 9268
Joined: Sat Aug 03, 2013 5:45 pm

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

Post by barbaz » Mon Oct 23, 2017 6:30 pm

stumped wrote:The no script status bar is missing. I am using Firefox. I am unable to view pages. How do I fix this?
Read the first post in this thread
*Always* check the changelogs BEFORE updating that important software!
-

Meotialora

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

Post by Meotialora » Tue Oct 24, 2017 1:51 pm

REGARDING THE ICON WHO DISAPPEAR i NOTE THAT THIS HAPPENS AFTER THE FF VERSION 56 64b WAS INSTALLED . AT THE MOMENT THE ADDON PAGE SHOW ME A "LEGACY" YELLOW LABEL AND THE EXPLANATION IS https://support.mozilla.org/en-US/kb/fi ... =inproduct .

HAVE FUN.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0

Post Reply