[FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

Ask for help about NoScript, no registration needed to post
somenoscripter

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

Post by somenoscripter » Wed Oct 18, 2017 1:53 pm

Do my previously posted screenshots help in any way?
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0

maurix
Posts: 19
Joined: Tue Jun 23, 2015 1:35 pm

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

Post by maurix » Wed Oct 18, 2017 2:19 pm

Giorgio Maone wrote: You just need to drag and drop the file onto a browser window.
Thanks
After 24 h everything seems ok. Guess the problem was in the 5.1.2
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:45.0) Gecko/20100101 Firefox/45.0

volfied

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

Post by volfied » Wed Oct 18, 2017 3:07 pm

SafeMode fix worked for me. Here are my extensions.


Adblock Plus 2.9.1
Element Hiding Helper for Adblock Plus 1.4
Greasemonkey 3.17
NoScript 5.1.2
Privacy Badger 2017.9.12.1
Safe Browsing Version 4 (temporary add-on) 1.0.0
Session Manager 0.8.1.13
Open in IE 0.1.2
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0

vic

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

Post by vic » Wed Oct 18, 2017 3:42 pm

The fix did not work for me (neither any other solution posted on this page, like combinging with reinstalling noscript).

55.0.2 (32-bit), Mozilla firefox for ubuntu canonical 1.0
Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:55.0) Gecko/20100101 Firefox/55.0

JJBJR

Re: Fx 56 - NoScript icon disappeared on 5.1.2 update

Post by JJBJR » Wed Oct 18, 2017 6:13 pm

tamiya wrote:Restarted FF in Safe Mode, exited, opened FF normally. All is well.
It also worked for me. Thanks
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0

barbaz
Senior Member
Posts: 9263
Joined: Sat Aug 03, 2013 5:45 pm

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

Post by barbaz » Wed Oct 18, 2017 6:40 pm

@vic
Giorgio Maone wrote:does right click + Customize on the toolbar help you find the icon and drag it back there?
*Always* check the changelogs BEFORE updating that important software!
-

wolfgang

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

Post by wolfgang » Thu Oct 19, 2017 6:06 am

join2 wrote:Restart with Add-ons disabledm, Continue in Safe Mode, Restart the browser again normally: NoScript should be back now
Thanks, works fine
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0

Hansl
Junior Member
Posts: 28
Joined: Wed Apr 02, 2014 6:58 am

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

Post by Hansl » Thu Oct 19, 2017 8:52 am

Also got this problem on several similarly installed LMDE Linux Mint Debian Edition / Mate machines with FF 56.0 and NS 5.1.2.
For me, the quickest workaround —without restarting FF— is to reinstall NS: opening https://noscript.net/ and clicking on the Install button.
Did this problem maybe start with the addition of FF's new screenshot button?
Mozilla/5.0 (X11; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0

Guest

Re: Pictogram NoScript

Post by Guest » Thu Oct 19, 2017 10:45 am

Luke17 wrote:I confirm that, icon is missing after upgrade to 5.1.2.
Same problem here (under Win 7 Pro)
Mozilla/5.0 (Windows NT 6.1; rv:56.0) Gecko/20100101 Firefox/56.0

Guest

Re: Fx 56 - NoScript icon disappeared on 5.1.2 update

Post by Guest » Thu Oct 19, 2017 10:57 am

Giorgio Maone wrote: ....
Also, please check whether the problem persists after disabling all your extensions and reinstalling NoScript.
No, still doesn't work.
Mozilla/5.0 (Windows NT 6.1; rv:56.0) Gecko/20100101 Firefox/56.0

stocktonlan

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

Post by stocktonlan » Thu Oct 19, 2017 11:59 pm

Hi all,

I encountered the same issue (NoScript 5.1.2 and Firefox 56.0) where NoScript disappeared from my navigation bar and refused to appear in Customize. It reappeared on my navigation bar after I deleted my extensions.json as suggested here: I also reset my about:config > browser.uiCustomization.state as support.mozilla suggested, but that alone didn't work.

I tried to see what might have been relevant that would change in the file, but within NoScript's description I only saw changes on
  • syncGUID
  • installDate
  • updateDate
  • sourceURI
  • releaseNotesURI
I tried putting the old extensions.json, but NoScript stayed put. Was the cause something downstream from that?
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:56.0) Gecko/20100101 Firefox/56.0

Guest

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

Post by Guest » Fri Oct 20, 2017 1:26 am

I ran into this issue on two different PC's. What fixed it for me was removing (or installing) a different plugin and restarting FF. I don't remember the extensions I removed but they were different on each computer (I suspect we just need to get firefox to reload it's addon config or whatever - I don't know how it actually works inside).

I didn't remove noscript or disable it in either case though.

I didn't discover this thread until after I'd already "fixed" the thing myself by fiddling with removing unrelated addons. I'm just posting here in case it helps folks figure out what's going on.
Mozilla/5.0 (X11; Linux i686) AppleWebKit/601.1 (KHTML, like Gecko) Version/8.0 Safari/601.1 Ubuntu/15.10 (3.16.3-1ubuntu1) Epiphany/3.16.3

pauljohn32

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

Post by pauljohn32 » Fri Oct 20, 2017 1:49 am

Fixed this by the safe-mode, close, and restart procedure

ImageHost Grabber 1.6.5.5.1-signed.1-signed true {E4091D66-127C-11DB-903A-DE80D2EFDFE8}
NoScript 5.1.2 true {73a6fe31-595d-460b-a920-fcc0f8843232}
Safe Browsing Version 4 (temporary add-on) 1.0.0 true sbv4-gradual-rollout@mozilla.com
uBlock Origin 1.14.14 true uBlock0@raymondhill.net
Ubuntu Modifications 3.4 true ubufox@ubuntu.com
Zoom Scheduler 1.05 true jid1-zoomscheduler@zoom.us
Zotero 4.0.29.23 true zotero@chnm.gmu.edu
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0

dzirg44

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

Post by dzirg44 » Fri Oct 20, 2017 7:24 am

After updating to firefox 56.0 icons for noscript and translator extensions is disappeared.
I disabled the extensions and worked the remaining day without them.
The next day I tried to turn them on and they worked.
I did not start the browser in safe mode.

Perhaps this information will help to solve the problem.
Mozilla/5.0 (X11; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0

x1097
Posts: 4
Joined: Fri Oct 20, 2017 8:41 am

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

Post by x1097 » Fri Oct 20, 2017 8:47 am

The workaround seems to not work correctly on Linux Ubuntu 16.04.03 x64 if you have multiple firefox profiles and at least one of those profiles is already in use while you "restart with addons disabled".

I always use multiple firefox profiles and always have at least three different profiles opened concurrently.

My test case with 64bit firefox 56.0 for ubuntu canonical 1.0 , and NoScript 5.1.2:


open firefox -P profile-A
(use the workaround to make noscript icons visible)

now open firefox -P profile-B
(the NoScript icons are not visibile)
in profile-B window, use "Restart with addons disabled" , accept the confirmation
a new firefox window opens
in that new firefox window, use "about:profiles"
Result: the active profile is Profile-A instead of the expected Profile-B.

Seems that "Restart with addons disabled" uses the profile of the already-running "other" profile, instead of the profile that this instance of Firefox has been invoked.

Any suggestions?
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0

Post Reply