[FIXED] NoScript 5.1.0. Disables ProtonMail Login

Ask for help about NoScript, no registration needed to post
User avatar
Giorgio Maone
Site Admin
Posts: 8697
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: NoScript breaks Protonmail using Firefox

Post by Giorgio Maone » Sat Sep 30, 2017 7:30 pm

wrekow wrote:Since the recent No Script upgrade I am unable to log in to Protonmail using Firefox 55.0.3 on a Mac with OSX 10.10.5. I cannot retrieve my email.
The following message was posted by Protonmail:
"Due to a critical bug in the NoScript plugin on Firefox, NoScript must be disabled to login to ProtonMail. Please report this bug to NoScript."
Did you try latest development build 5.1.1rc1 as advised 2 message earlier in this thread?
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0

ThrowAway

Re: NoScript 5.1.0. Disables ProtonMail Login

Post by ThrowAway » Sat Sep 30, 2017 7:42 pm

Thank you very much for fixing this bug Giorgio. Protonmail now works using Firefox 55.0.2 ( 64 bit ) on Linux.
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:55.0) Gecko/20100101 Firefox/55.0

chimpscript
Posts: 6
Joined: Sun Mar 16, 2014 5:20 pm

Re: NoScript 5.1.0. Disables ProtonMail Login

Post by chimpscript » Sat Sep 30, 2017 9:12 pm

Thanks Giorgio for a quick fix.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0

tranquility1
Posts: 2
Joined: Sat Sep 30, 2017 3:31 pm

Re: NoScript 5.1.0. Disables ProtonMail Login

Post by tranquility1 » Sat Sep 30, 2017 9:46 pm

Confirmed that 5.1.1rc1 fixes the problem for me. Thanks.
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:56.0) Gecko/20100101 Firefox/56.0

visitor

Re: [FIXED] NoScript 5.1.0. Disables ProtonMail Login

Post by visitor » Sun Oct 01, 2017 11:36 am

Thank you Giorgio for the lightning quick fix!
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:54.0) Gecko/20100101 Firefox/54.0.1 Waterfox/54.0.1

Guest

Re: [FIXED] NoScript 5.1.0. Disables ProtonMail Login

Post by Guest » Sun Oct 01, 2017 12:29 pm

Working like a charm again :-)
Thanks for fixing the bug so soon, now I didn't need to downgrade No script to an older version.
Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:54.0) Gecko/20100101 Firefox/54.0

Guest

NoScript 5.1.2rc1 Disables ProtonMail Login with 2FA

Post by Guest » Sun Oct 01, 2017 10:56 pm

I still can't access my email with ProtonMail. I'm running Firefox 55.0.2 (64-bit) and NoScript 5.1.2rc1. The stable release 5.1.1 wouldn't work either. I've rebooted my laptop after upgrading NoScript. I'm using Two Factor Authentication (token) to access ProtonMail. I currently have to disable NoScript to access my ProtonMail email account.
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:55.0) Gecko/20100101 Firefox/55.0

umair

Re: [FIXED] NoScript 5.1.0. Disables ProtonMail Login

Post by umair » Sun Oct 01, 2017 11:26 pm

It worked once after upgrade but it no longer works now. On version 5.1.1.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0

User avatar
Giorgio Maone
Site Admin
Posts: 8697
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: [FIXED] NoScript 5.1.0. Disables ProtonMail Login

Post by Giorgio Maone » Sun Oct 01, 2017 11:36 pm

Latest posters: does the problem persist also if you use "Allow scripts globally"?
@umair: are you using 2FA too?
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0

Guest

NoScript 5.1.2rc1 Disables ProtonMail Login with 2FA

Post by Guest » Mon Oct 02, 2017 12:09 am

Giorgio Maone wrote:Latest posters: does the problem persist also if you use "Allow scripts globally"?
@umair: are you using 2FA too?
Yes, I still have the problem when I "Allow Scripts Globally". The login and password screen works fine and the 2FA screen works fine. After entering the 2FA token, ProtonMail shows the "Decrypting..." dialog box and the moving atom graphic and then justs hangs there.

I tried NoScript 5.1.1 with "Allow Scripts Globally" and had the same problem. Thanks for the quick response!
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:55.0) Gecko/20100101 Firefox/55.0

LG25

Re: [FIXED] NoScript 5.1.0. Disables ProtonMail Login

Post by LG25 » Mon Oct 02, 2017 5:52 am

This is "Fixed"? Maybe I missed something, but I can not log in to Proton Mail without disabling NoScript. It's funny that it used to work, then a Firefox update, No Script update, or maybe after I set it up on my phone (if that could possibly affect it), made it stop working. I took Proton Mail's advice about a No Script bug where you must disable it to log in to Proton Mail. It didn't work. I had to disable it entirely. I'm pretty good at figuring these things out, and am now quite familiar with No Script. The Protonmail site is whitelisted to begin with, and I was once able to use it on my PC.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0

LG25

Re: [FIXED] NoScript 5.1.0. Disables ProtonMail Login

Post by LG25 » Mon Oct 02, 2017 5:56 am

LG25 wrote:This is "Fixed"? Maybe I missed something, but I can not log in to Proton Mail without disabling NoScript. It's funny that it used to work, then a Firefox update, No Script update, or maybe after I set it up on my phone (if that could possibly affect it), made it stop working. I took Proton Mail's advice about a No Script bug where you must disable it to log in to Proton Mail. It didn't work. I had to disable it entirely. I'm pretty good at figuring these things out, and am now quite familiar with No Script. The Protonmail site is whitelisted to begin with, and I was once able to use it on my PC.
I don't see a way to delete this comment. I looked further back in the thread and found a suggestion of a dev build. It works. I'm whole again. Thx
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0

umair

Re: [FIXED] NoScript 5.1.0. Disables ProtonMail Login

Post by umair » Mon Oct 02, 2017 7:36 am

Giorgio Maone wrote:Latest posters: does the problem persist also if you use "Allow scripts globally"?
@umair: are you using 2FA too?
No, I am not.

The error is the same in console as was with 5.1.0;

Error: Unhandled error in openpgp worker: NetworkError: Failed to load worker script at openpgp.min.js?rel=51671db22f (nsresult = 0x805e0006) (https://mail.protonmail.com/openpgp.wor ... 2635bcaa:1) openpgp.min.js:10:29944
NetworkError: Failed to load worker script at openpgp.min.js?rel=51671db22f (nsresult = 0x805e0006)
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0

User avatar
Giorgio Maone
Site Admin
Posts: 8697
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: [FIXED] NoScript 5.1.0. Disables ProtonMail Login

Post by Giorgio Maone » Mon Oct 02, 2017 8:14 am

@LG25, thanks for the update, glad it works for you.

@umair & "2FA guest", could you please use NoScript Options>Export and send me the exported files by email? After that, also worth trying, use NoScript Options>Reset and check whether it works; you can restore your settings from the file after the test. Thank you!
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0

User avatar
Giorgio Maone
Site Admin
Posts: 8697
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: [FIXED] NoScript 5.1.0. Disables ProtonMail Login

Post by Giorgio Maone » Mon Oct 02, 2017 10:11 pm

Giorgio Maone wrote:@umair & "2FA guest", could you please use NoScript Options>Export and send me the exported files by email? After that, also worth trying, use NoScript Options>Reset and check whether it works; you can restore your settings from the file after the test. Thank you!
Thank you both for sending your files. They were useful to determine that it's not something related to a specific NoScript setting, but rather to your profile configuration, e.g. other extensions or special Firefox settings.
"2FA guest" already tried, and I suspect umair will also find that installing NoScript on a clean profile will make Protonmail work as soon as protonmail.com is whitelisted. On the other hand, resetting NoScript options doesn't suffice, therefore it must be the interation of NoScript with something else and non-standard.
Therefore, please try Standard Diagnostic and/or examine how your Firefox settings diverge from the defaults in order to find the conflicting factor.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0

Locked