[RESOLVED] Possible NoScript loop

Ask for help about NoScript, no registration needed to post
User avatar
ronks
Posts: 10
Joined: Tue Jun 12, 2012 3:31 am

[RESOLVED] Possible NoScript loop

Post by ronks » Sun Jun 25, 2017 4:32 pm

Running NoScript 5.0.5 on 64-bit Firefox 54.0 and Windows 10, Firefox locks up and has to be killed whenever I visit
http://www.nytimes.com/column/bits
By disabling NoScript (and nothing else) as an add-on, the page displays properly and FF responds.
Not sure what the cause is, but it seems to be related to NoScript.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:54.0) Gecko/20100101 Firefox/54.0

barbaz
Senior Member
Posts: 9508
Joined: Sat Aug 03, 2013 5:45 pm

Re: Possible NoScript loop

Post by barbaz » Sun Jun 25, 2017 9:38 pm

If the site loads script from facebook.net, just Mark facebook.net as Untrusted. Problem solved.

If there are no facebook.net script, you're hitting a known bug in NoScript's XSS filter -
viewtopic.php?f=10&t=22828
viewtopic.php?f=7&t=22881
*Always* check the changelogs BEFORE updating that important software!
-

User avatar
ronks
Posts: 10
Joined: Tue Jun 12, 2012 3:31 am

Re: Possible NoScript loop

Post by ronks » Mon Jun 26, 2017 12:09 am

Thanks! I un-trusted facebook.net and so far the site works again.
But I suppose I should ask if allowing facebook.net scripts, which I must have whitelisted at some point, has any value?
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:54.0) Gecko/20100101 Firefox/54.0

barbaz
Senior Member
Posts: 9508
Joined: Sat Aug 03, 2013 5:45 pm

Re: Possible NoScript loop

Post by barbaz » Mon Jun 26, 2017 2:04 am

Not unless you like to have about as much privacy as the Kardashian family. That is, without any of the upsides they get. ;)
*Always* check the changelogs BEFORE updating that important software!
-

User avatar
ronks
Posts: 10
Joined: Tue Jun 12, 2012 3:31 am

Re: Possible NoScript loop

Post by ronks » Mon Jun 26, 2017 3:01 am

Got it. ;-)
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:54.0) Gecko/20100101 Firefox/54.0

User avatar
Giorgio Maone
Site Admin
Posts: 8830
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: [RESOLVED] Possible NoScript loop

Post by Giorgio Maone » Fri Jun 30, 2017 12:08 am

Please check latest development build 5.0.6rc5, thanks.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:54.0) Gecko/20100101 Firefox/54.0

User avatar
ronks
Posts: 10
Joined: Tue Jun 12, 2012 3:31 am

Re: [RESOLVED] Possible NoScript loop

Post by ronks » Fri Jun 30, 2017 2:59 am

So I take it that
> [XSS] Fixed performance regression in handling of big JSON
payloads causing the browser to freeze on loading pages
with Facebook tracking subframes
was the issue?
I think I'll wait till the fix gets into the stable release, but thanks for the information.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:54.0) Gecko/20100101 Firefox/54.0

Post Reply