[FIXED] file:\\\ links fail with NoScript 5.0.2 & FF 53.0

Ask for help about NoScript, no registration needed to post
BigB

[FIXED] file:\\\ links fail with NoScript 5.0.2 & FF 53.0

Post by BigB » Thu Apr 20, 2017 6:42 pm

Earlier today I upgraded FF to v53.0 and now my local .htm file links will only open when NoScript 5.0.2 is disabled. There is no error message or other indication of failure. The .htm file simply fails to open. Pasting the file:\\\ link into the FF address bar then hitting enter results in the address bar being cleared. Is this problem unique to me or is it a confirmed issue.

The file links open fine in IE and in FF when NoScript is disabled.
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0

zakgj01

Re: file:\\\ links fail with NoScript 5.0.2 & FF 53.0

Post by zakgj01 » Thu Apr 20, 2017 8:05 pm

Same Problem after update to FF 53.0
I hope it will be fixed in the next update of NoScript or some one can tell what to change in setting
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0

Stefan

Re: file:\\\ links fail with NoScript 5.0.2 & FF 53.0

Post by Stefan » Fri Apr 21, 2017 9:13 am

Options > Advanced > Trusted > Allow local links

Disable this option, and file-URLs will be loaded again.

Possible reason: https://blog.mozilla.org/addons/2017/02 ... firefox-53

General, point 2: Use a separate content process for file:// URLs. This slightly changes the behavior of _openURIInNewTab.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:53.0) Gecko/20100101 Firefox/53.0

BigB

Re: file:\\\ links fail with NoScript 5.0.2 & FF 53.0

Post by BigB » Fri Apr 21, 2017 12:20 pm

Thanks for the workaround Stefan.

Disabling "Allow local links" is counter-intuitive to allowing local files so I hope this gets fixed soon.
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0

barbaz
Senior Member
Posts: 9262
Joined: Sat Aug 03, 2013 5:45 pm

Re: file:\\\ links fail with NoScript 5.0.2 & FF 53.0

Post by barbaz » Fri Apr 21, 2017 8:36 pm

Another thread suggests this problem with Allow local links may be extension conflict - viewtopic.php?f=10&t=22562

Does disabling all extensions other than NoScript get it working? (Tools > Add-ons Manager)
*Always* check the changelogs BEFORE updating that important software!
-

Aybee
Posts: 8
Joined: Wed Mar 22, 2017 7:54 pm
Location: Germany Mönchengladbach

Re: file:\\\ links fail with NoScript 5.0.2 & FF 53.0

Post by Aybee » Fri Apr 21, 2017 10:06 pm

Same problem here. Deactivated all other addons will not help.

If I deactivate

Code: Select all

EN
"Options > Advanced > Trusted > Allow local links"
DE
"Einstellungen > Erweitert > Vertrauenswürdig > Links auf lokale Dateien erlauben"
this will do the trick as a workaround.

Only difference with all deactivated other addons is that I can see a URL in the adressbar now (e.g. file:///C:/index.html) but with no effect. Bug stays the same.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:53.0) Gecko/20100101 Firefox/53.0

undefined
Posts: 5
Joined: Fri Apr 21, 2017 3:16 pm

Re: file:\\\ links fail with NoScript 5.0.2 & FF 53.0

Post by undefined » Fri Apr 21, 2017 10:31 pm

it might be a red herring (and/or i total misunderstand the circumstances), but prompted by the reference to the "separate content process for file:// URLs" change in firefox 53...

the ubufox (ie "ubuntu modifications") add-on disables (either directly or incidentally) "multiprocess windows". about:support shows "Multiprocess Windows: 0/1 (Disabled by add-ons)" when ubufox is enabled and "1/1 (Enabled by default)" when disabled.

(i couldn't find a setting to enable/disable multiprocess windows in about:config to do it manually to test that it's specific to that and not to something else related to ubufox.)

now why ubufox works fine by itself and noscript works fine by itself, but if you have ubufox and noscript and "Allow local links", then it breaks file:// urls, that's left to be explained by someone more familiar with noscript's implementation.
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:53.0) Gecko/20100101 Firefox/53.0

barbaz
Senior Member
Posts: 9262
Joined: Sat Aug 03, 2013 5:45 pm

Re: file:\\\ links fail with NoScript 5.0.2 & FF 53.0

Post by barbaz » Fri Apr 21, 2017 11:23 pm

undefined wrote:(i couldn't find a setting to enable/disable multiprocess windows in about:config to do it manually to test that it's specific to that and not to something else related to ubufox.)
Try doing the opposite of this - https://superuser.com/a/1108314
*Always* check the changelogs BEFORE updating that important software!
-

undefined
Posts: 5
Joined: Fri Apr 21, 2017 3:16 pm

Re: file:\\\ links fail with NoScript 5.0.2 & FF 53.0

Post by undefined » Fri Apr 21, 2017 11:31 pm

tl;dr browser.tabs.remote.autostart.2 = false

i'm able to recreate the problem apart from any extension (in my case ubufox) by setting browser.tabs.remote.autostart.2 to "false" (from the default of "true", though it says in about:config that it's technically "user set", but if i reset the value then it comes back up automatically as "true", so i don't know what definition of "user set", versus "default", firefox is using :P).

so, if:
  • browser.tabs.remote.autostart.2 = false
  • "Allow local links" enabled
then:
  • file:// urls don't work
i presume that the problem is noscript, specifically its "Allow local links" functionality, behaving badly (or triggering a firefox bug) when multi-process firefox is disabled (either implicitly, eg ubufox extension, or explicitly, ie browser.tabs.remote.autostart.2).

maybe i'll look in noscript and see where all that option is used (to see what code it enables).
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:53.0) Gecko/20100101 Firefox/53.0

periboob
Posts: 8
Joined: Thu Jul 23, 2009 10:10 pm

Re: file:\\\ links fail with NoScript 5.0.2 & FF 53.0

Post by periboob » Sat Apr 22, 2017 6:06 pm

Problem just started for me, with latest FF. Win-10. Tried suggestions above. Disableing NoScript fixes, but I cant live that way!
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0

periboob
Posts: 8
Joined: Thu Jul 23, 2009 10:10 pm

Re: file:\\\ links fail with NoScript 5.0.2 & FF 53.0

Post by periboob » Sun Apr 23, 2017 11:03 pm

Partial Work around/perhaps a hint as to whats happening. I only need much access to one file, so as a trial, rather than a bookmark, I made a desktop shortcut to that file. It works. No idea what the difference between a bookmark to a file, and a file shortcut is, maybe someone smarter can use this hint to work on a real fix.
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0

User avatar
therube
Ambassador
Posts: 7455
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: file:\\\ links fail with NoScript 5.0.2 & FF 53.0

Post by therube » Mon Apr 24, 2017 12:58 pm

Suppose it would be helpful to know:

OS
32 or 64-bit FF
e10's enabled or not
& then testing in a new, clean Profile, with only NoScript installed - at its default settings
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0 SeaMonkey/2.46 Lightning/.4.46

Aybee
Posts: 8
Joined: Wed Mar 22, 2017 7:54 pm
Location: Germany Mönchengladbach

Re: file:\\\ links fail with NoScript 5.0.2 & FF 53.0

Post by Aybee » Mon Apr 24, 2017 2:11 pm

Seems to work if you create a new boolean param with about:config

Code: Select all

browser.tabs.remote.force-enable = true
You can test if multiprocess is enabled in about:support - "Multiprocess Windows"
see here https://superuser.com/questions/1029400 ... refox-beta
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:53.0) Gecko/20100101 Firefox/53.0

Aybee
Posts: 8
Joined: Wed Mar 22, 2017 7:54 pm
Location: Germany Mönchengladbach

Re: file:\\\ links fail with NoScript 5.0.2 & FF 53.0

Post by Aybee » Tue Apr 25, 2017 3:30 pm

Celebrated too soon. With

Code: Select all

browser.tabs.remote.force-enable = true
NoScript did not work anymore. There is nothing in the dropdown you can click on.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:53.0) Gecko/20100101 Firefox/53.0

mzs

Re: file:\\\ links fail with NoScript 5.0.2 & FF 53.0

Post by mzs » Tue Apr 25, 2017 5:18 pm

I get the same problem with FF 53.0 and NoScript 5.0.3....

Disabled NoScript and file open works...
Mozilla/5.0 (X11; Linux x86_64; rv:53.0) Gecko/20100101 Firefox/53.0

Post Reply