New Forbid Scripts Globally "!" character

Ask for help about NoScript, no registration needed to post
User avatar
ronks
Posts: 10
Joined: Tue Jun 12, 2012 3:31 am

New Forbid Scripts Globally "!" character

Post by ronks » Fri Mar 17, 2017 5:39 pm

I'm using the NoScript 2.9.5.3 extension to Firefox 51.0.1 on Windows 10. I haven't made any option changes, but just recently the little "S" icon shows a red exclamation point on every site I visit, with the message "Forbid Scripts Globally (advised)".
I'm wondering what is new, since I don't intentionally allow scripts globally, and where does this choice appear within the NoScript Options window tabs.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:51.0) Gecko/20100101 Firefox/51.0

barbaz
Senior Member
Posts: 9508
Joined: Sat Aug 03, 2013 5:45 pm

Re: New Forbid Scripts Globally "!" character

Post by barbaz » Fri Mar 17, 2017 5:42 pm

NoScript Options > Whitelist, un-check "Scripts Globally Allowed (dangerous)"

Does that change stick?

BTW NoScript is at version 5.0.2 now. I would recommend updating NoScript.
*Always* check the changelogs BEFORE updating that important software!
-

User avatar
ronks
Posts: 10
Joined: Tue Jun 12, 2012 3:31 am

Re: New Forbid Scripts Globally "!" character

Post by ronks » Fri Mar 17, 2017 6:02 pm

Thanks! That did it. I wonder how that option could have gotten changed, hmm. Will look at updating to latest version of NoScript.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0

barbaz
Senior Member
Posts: 9508
Joined: Sat Aug 03, 2013 5:45 pm

Re: New Forbid Scripts Globally "!" character

Post by barbaz » Fri Mar 17, 2017 6:07 pm

You're welcome! Image
*Always* check the changelogs BEFORE updating that important software!
-

Post Reply