NoScript 2.9.5.3

Ask for help about NoScript, no registration needed to post
Jojo999
Senior Member
Posts: 143
Joined: Mon Jun 01, 2009 3:54 am

NoScript 2.9.5.3

Post by Jojo999 » Mon Mar 06, 2017 8:18 pm

I have Pale Moon 27.1.2 (32bit) running. I just noticed that NS seems to be stuck back on v2.9.0.14, last updated 10 Aug 2016.

It appears that v2.9.5.3 is current version per another post here that I saw.

WHY is my PM not updating NS? And where can I find the v2.9.5.3 release, if that is the one I actually need?

Thanks.
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:45.9) Gecko/20100101 Goanna/3.0 Firefox/45.9 PaleMoon/27.1.2

User avatar
therube
Ambassador
Posts: 7669
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: NoScript 2.9.5.3

Post by therube » Mon Mar 06, 2017 9:13 pm

AFAIK, NoScript 5.0 should be working in your PM.
(At least that's what install.rdf says.)
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 5.1; rv:49.0) Gecko/20100101 SeaMonkey/2.46

barbaz
Senior Member
Posts: 9666
Joined: Sat Aug 03, 2013 5:45 pm

Re: NoScript 2.9.5.3

Post by barbaz » Mon Mar 06, 2017 9:46 pm

therube wrote:AFAIK, NoScript 5.0 should be working in your PM.
NoScript 5.0 does work in Pale Moon. I've tested it.
Jojo999 wrote:WHY is my PM not updating NS?
That's a question for the Pale Moon people. NoScript isn't responsible for handling updates.
*Always* check the changelogs BEFORE updating that important software!
-

Jojo999
Senior Member
Posts: 143
Joined: Mon Jun 01, 2009 3:54 am

Re: NoScript 2.9.5.3

Post by Jojo999 » Tue Mar 07, 2017 9:20 am

Some here contend 5.0 NOT fully compatible in PM.

http://www.ghacks.net/2017/03/06/noscri ... -released/
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:45.9) Gecko/20100101 Goanna/3.0 Firefox/45.9 PaleMoon/27.1.2

User avatar
therube
Ambassador
Posts: 7669
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: NoScript 2.9.5.3

Post by therube » Tue Mar 07, 2017 11:16 am

Hardly a meaningful "report", http://www.ghacks.net/2017/03/06/noscri ... nt-4179552.

At least I'm glad that Mr. Anonymous has lots of followers, devotees ;-).
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0 SeaMonkey/2.46 Lightning/.4.46

barbaz
Senior Member
Posts: 9666
Joined: Sat Aug 03, 2013 5:45 pm

Re: NoScript 2.9.5.3

Post by barbaz » Tue Mar 07, 2017 7:55 pm

Jojo999 wrote:Some here contend 5.0 NOT fully compatible in PM.
Some there are trolling. The only Pale Moon specific issue is viewtopic.php?f=10&t=22539

Do people who write stuff like this ever bother with proper troubleshooting? -
Just tried it with Pale Moon, not fully compatible, I have to allow all scripts globally. Back to 2.9.5.3 until I remove it definitively, like it was the case for Firefox already.
@Andy: So why the author of NoScript is keeping Pale Moon as targetApplication in the install.rdf? This nonsense so evident for you could not be so evident for others, don't you think?
(emphasis mine)

Ignore them and go test it, like I have done. You won't regret it. :)
*Always* check the changelogs BEFORE updating that important software!
-

Jojo999
Senior Member
Posts: 143
Joined: Mon Jun 01, 2009 3:54 am

Re: NoScript 2.9.5.3

Post by Jojo999 » Wed Mar 08, 2017 9:56 am

OK but assuming it does not work for me, how do I find this 2.9.5.3 release?
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:45.9) Gecko/20100101 Goanna/3.0 Firefox/45.9 PaleMoon/27.1.2

User avatar
therube
Ambassador
Posts: 7669
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: NoScript 2.9.5.3

Post by therube » Wed Mar 08, 2017 11:33 am

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0 SeaMonkey/2.46 Lightning/.4.46

Jojo999
Senior Member
Posts: 143
Joined: Mon Jun 01, 2009 3:54 am

Re: NoScript 2.9.5.3

Post by Jojo999 » Wed Mar 08, 2017 8:13 pm

FF says "Firefox prevented this site from asking you to install software on your computer"
PM says "This add-on could not be downloaded because its origin could not be verified"
Chrome and IE 11 just show XML.

I tried copying the actual XPI link and putting that in the address bar and got that to work in IE11. Otherwise, the direct link did not work in FF or PM and gave the same msgs as above.
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:45.9) Gecko/20100101 Goanna/3.0 Firefox/45.9 PaleMoon/27.1.2

barbaz
Senior Member
Posts: 9666
Joined: Sat Aug 03, 2013 5:45 pm

Re: NoScript 2.9.5.3

Post by barbaz » Wed Mar 08, 2017 8:24 pm

*Always* check the changelogs BEFORE updating that important software!
-

Jojo999
Senior Member
Posts: 143
Joined: Mon Jun 01, 2009 3:54 am

Re: NoScript 2.9.5.3

Post by Jojo999 » Fri Mar 10, 2017 6:50 pm

I received this replay on the PM forums when I asked why NS was not getting auto updated:

"I would say because of compatibility. Pale Moon use Firefox 27.9 as useragent for AMO, so if a addon say the min-gecko is higher then 27.9 you doesnt get a update.'
https://forum.palemoon.org/viewtopic.php?f=3&t=15079

Is this correct? It would seem then that NS will no longer get auto updated in the future then. Can this be adjusted/repaired so that NS updates again become automatic?
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:45.9) Gecko/20100101 Goanna/3.0 Firefox/45.9 PaleMoon/27.1.2

barbaz
Senior Member
Posts: 9666
Joined: Sat Aug 03, 2013 5:45 pm

Re: NoScript 2.9.5.3

Post by barbaz » Fri Mar 10, 2017 7:26 pm

Jojo999 wrote:Is this correct?
Nope. Changing that UA override to Firefox 52 doesn't help.
Jojo999 wrote:It would seem then that NS will no longer get auto updated in the future then. Can this be adjusted/repaired so that NS updates again become automatic?
Really, we can't help with this. Even I don't use Pale Moon enough to know what next.

But "if it were me", I'd look at this -

Code: Select all

extensions.update.background.url;https://addons.palemoon.org/integration/addon-manager/internal/update?reqVersion=%REQ_VERSION%&id=%ITEM_ID%&version=%ITEM_VERSION%&maxAppVersion=%ITEM_MAXAPPVERSION%&status=%ITEM_STATUS%&appID=%APP_ID%&appVersion=%APP_VERSION%&appOS=%APP_OS%&appABI=%APP_ABI%&locale=%APP_LOCALE%&currentAppVersion=%CURRENT_APP_VERSION%&updateType=%UPDATE_TYPE%&compatMode=%COMPATIBILITY_MODE%

extensions.update.url;https://addons.palemoon.org/integration/addon-manager/internal/update?reqVersion=%REQ_VERSION%&id=%ITEM_ID%&version=%ITEM_VERSION%&maxAppVersion=%ITEM_MAXAPPVERSION%&status=%ITEM_STATUS%&appID=%APP_ID%&appVersion=%APP_VERSION%&appOS=%APP_OS%&appABI=%APP_ABI%&locale=%APP_LOCALE%&currentAppVersion=%CURRENT_APP_VERSION%&updateType=%UPDATE_TYPE%&compatMode=%COMPATIBILITY_MODE%
*Always* check the changelogs BEFORE updating that important software!
-

Jojo999
Senior Member
Posts: 143
Joined: Mon Jun 01, 2009 3:54 am

Re: NoScript 2.9.5.3

Post by Jojo999 » Sat Mar 11, 2017 5:51 am

Could you translate that into something that a non-programmer could understand?
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:45.9) Gecko/20100101 Goanna/3.0 Firefox/45.9 PaleMoon/27.1.2

barbaz
Senior Member
Posts: 9666
Joined: Sat Aug 03, 2013 5:45 pm

Re: NoScript 2.9.5.3

Post by barbaz » Sat Mar 11, 2017 6:12 am

Since I don't understand it all either, not completely, but I will try.

First off, I should have mentioned that I confirm the problem in Pale Moon 27.1.2.
barbaz wrote:
Jojo999 wrote:Is this correct?
Nope. Changing that UA override to Firefox 52 doesn't help.
By default, Pale Moon presents itself like this to AMO -

Code: Select all

Mozilla/5.0 (Linux; X11; rv:27.9) Gecko/20100101 Firefox/27.9 (Pale Moon)
That tells AMO 'Hi, I'm Firefox 27.9 on Linux.' Which, if true, would mean the browser doesn't support NoScript. But it's not true.

Changing it to present like this, which says 'Hi, I'm Firefox 52 on Windows 10', does not get NoScript to update for me.

Code: Select all

Mozilla/5.0 (Windows NT 10.0; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
You can check this yourself - just modify about:config > general.useragent.override.addons.mozilla.org
barbaz wrote:But "if it were me", I'd look at this -
That code box lists two about:config preferences. My uneducated guess is that those are the URL templates for addon update checking. Unfortunately I don't understand enough about those URLs to make any more sense of them than you did, sorry.

Again, the Pale Moon people will probably be more helpful than we can be.
*Always* check the changelogs BEFORE updating that important software!
-

Jojo999
Senior Member
Posts: 143
Joined: Mon Jun 01, 2009 3:54 am

Re: NoScript 2.9.5.3

Post by Jojo999 » Sun Mar 12, 2017 5:42 pm

barbaz wrote: Again, the Pale Moon people will probably be more helpful than we can be.
I received this reply on the PM forums:
Re: Noscript update
Postby Lootyhoof » Sun Mar 12, 2017 10:26 am
NoScript's minVersion on AMO is higher than 27.9. Thus, it will not auto update for us. Additionally, note that version 5.0 is not fully compatible with us anyway due to including WebExtension code.

If the developer wants to produce a version specific for Pale Moon, the following can be used with regards to where such a version can be hosted (so we can get updates properly):

http://developer.palemoon.org/Add-ons:Site
If NS doesn't auto update on PM, then there are a lot of people who are going to be running back-level with whatever problems that brings.
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:45.9) Gecko/20100101 Goanna/3.0 Firefox/45.9 PaleMoon/27.1.2

Post Reply