si.shimano.com not working

Ask for help about NoScript, no registration needed to post
sp00n

si.shimano.com not working

Post by sp00n » Sun Mar 05, 2017 4:40 pm

The search on http://si.shimano.com is not working, even when I allow all visible entries in the menu, and disable XSS protection. They've recently switched to AngularJS, and are including JS from their pages, so there's probably a connection. No notification or error in the console is shown though (is there some dedicated log for NoScript only somewhere?).

Try to search e.g. for "CS-M7000" in the input field, the indicator is just spinning forever. If I temporarily globally allow all scripts, it's working fine.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:50.0) Gecko/20100101 Firefox/50.0

User avatar
therube
Ambassador
Posts: 7459
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: si.shimano.com not working

Post by therube » Sun Mar 05, 2017 5:36 pm

Works with:

+angularjs.org
+amazonaws.com
+code.jquery.com
+angular-ui.github.io
+shimano.com
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0 SeaMonkey/2.46 Lightning/.4.46

barbaz
Senior Member
Posts: 9268
Joined: Sat Aug 03, 2013 5:45 pm

Re: si.shimano.com not working

Post by barbaz » Sun Mar 05, 2017 5:45 pm

Err, no, therube, not for everyone. I see the same behavior as the OP.

Setting about:config > noscript.forbidXHR to 0 gets it working. But that is NOT a solution.

So what does it all mean? It means some site(s) are missing from the NS menu.

I'll make sure Giorgio sees this.
*Always* check the changelogs BEFORE updating that important software!
-

User avatar
Giorgio Maone
Site Admin
Posts: 8735
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: si.shimano.com not working

Post by Giorgio Maone » Tue Mar 07, 2017 6:42 am

Looking into that, thanks.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:51.0) Gecko/20100101 Firefox/51.0

User avatar
Giorgio Maone
Site Admin
Posts: 8735
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: si.shimano.com not working

Post by Giorgio Maone » Tue Mar 07, 2017 2:36 pm

Please check latest development build 5.0.1rc1, thanks.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:51.0) Gecko/20100101 Firefox/51.0

barbaz
Senior Member
Posts: 9268
Joined: Sat Aug 03, 2013 5:45 pm

Re: si.shimano.com not working

Post by barbaz » Tue Mar 07, 2017 8:01 pm

Fixed here, thank you Giorgio! Image
*Always* check the changelogs BEFORE updating that important software!
-

Post Reply