Page 1 of 4

[FIXED] NoScript blocking Lastpass icon in login fields

Posted: Fri Nov 25, 2016 6:52 pm
by JoeMoo
The most recent update is preventing the Lastpass icon in username/password fields on websites from working. Normally, you click on the icon and it will pop up a Lastpass dialog window. Now when you click on it nothing pops up. I can't figure out how to re-enable it (yes Lastpass.com is whitelisted, but that shouldn't have anything to do with the icon anyway). I tried going through the options in NoScript but I couldn't find any way to get it working again. It's always worked fine but the most recent update appears to be blocking it from working (version 2.9.5.1).

Re: NoScript blocking Lastpass icon in login fields

Posted: Fri Nov 25, 2016 6:57 pm
by pegasus41
similar issue with dashlane; problem lies in ABE
see this thread:

viewtopic.php?f=7&t=22297&hilit=dashlane

if you disable ABE under "advanced" options, it may work...

Re: NoScript blocking Lastpass icon in login fields

Posted: Fri Nov 25, 2016 7:17 pm
by JoeMoo
Disabling ABE didn't fix it. Also didn't see anything related to ABE in the browser console.

Re: NoScript blocking Lastpass icon in login fields

Posted: Fri Nov 25, 2016 7:49 pm
by barbaz
What, if anything, do you get in the Browser Console (Ctrl-Shift-J) when you see this issue?

Does it make any difference if you use NoScript latest development build?

Re: NoScript blocking Lastpass icon in login fields

Posted: Fri Nov 25, 2016 8:17 pm
by JoeMoo
The latest development build didn't fix it. I tried to copy and paste my browser console but it kept triggering the anti spam filter for some reason and refused to let me post it so I had no choice but to save it as an image unfortunately.

Image

Re: NoScript blocking Lastpass icon in login fields

Posted: Sat Nov 26, 2016 1:13 pm
by coinperson
and here I thought I was crazy. Went through all the settings and could not get it to work. I went back to version 2.9.0.14 until it is fixed.

https://secure.informaction.com/download/releases/noscript-2.9.0.14.xpi

Re: NoScript blocking Lastpass icon in login fields

Posted: Sat Nov 26, 2016 4:30 pm
by JoeMoo
Thank you for the link, I downgraded for now as well. Glad to know it's not just me though, hopefully it will be sorted out.

Re: NoScript blocking Lastpass icon in login fields

Posted: Mon Nov 28, 2016 4:54 pm
by Giorgio Maone
Could you please check whether this issue persists latest development build rc4? thank you!

Re: NoScript blocking Lastpass icon in login fields

Posted: Mon Nov 28, 2016 4:59 pm
by JoeMoo
Unfortunately it's still not working.

Re: NoScript blocking Lastpass icon in login fields

Posted: Tue Nov 29, 2016 2:09 pm
by stroke
Hi, still not working on Version 2.9.5.2, FF 50.0.1 x64, W10 x64.

Re: NoScript blocking Lastpass icon in login fields

Posted: Tue Nov 29, 2016 4:14 pm
by JoeMoo
Same, still not working with the final release of 2.9.5.2. Also, I have the exact same specs as stroke if that helps. Perhaps a Win 10 issue? No idea.

Re: NoScript blocking Lastpass icon in login fields

Posted: Wed Nov 30, 2016 5:23 pm
by mikolajek
Confirmed, it fails to work with LastPass for me as well... :( Win10 x64 Pro + FF 50.0.1 + NS 2.9.5.2 + LP 4.1.32a.

I've restored the NS 2.9.5.1 build but it hasn't resolved the issue... But the mentioned 2.9.0.14 did the job.

Re: NoScript blocking Lastpass icon in login fields

Posted: Wed Dec 07, 2016 10:57 pm
by Aimhere
Also not working for me. Windows 10 x64, Firefox 50.0.2, Lastpass 4.1.3.2, NoScript 2.9.5.2 final.

Re: NoScript blocking Lastpass icon in login fields

Posted: Wed Dec 07, 2016 11:51 pm
by Thrawn
Well, for me, LastPass is failing at Github, but succeeding in various other places, and the Github failure complains of a violation of the site's Content Security Policy. Haven't tried it without NS enabled yet.

Re: NoScript blocking Lastpass icon in login fields

Posted: Thu Dec 08, 2016 4:08 am
by MasterK
The latest release 2.9.5.2 still does not fix this issue. Is there another place a bug like this should be reported that I have missed?