[FIXED] NoScript blocking Lastpass icon in login fields

Ask for help about NoScript, no registration needed to post
Aimhere
Posts: 10
Joined: Mon Feb 01, 2016 6:06 pm

Re: NoScript blocking Lastpass icon in login fields

Post by Aimhere » Wed Dec 28, 2016 11:49 pm

As a work-around to the non-functional embedded LastPass button in login fields, I will point out you can right-click on the field and get access to LastPass via the context menu. But it would be nice if the embedded button could be fixed!

Aimhere
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0

Aimhere
Posts: 10
Joined: Mon Feb 01, 2016 6:06 pm

Re: NoScript blocking Lastpass icon in login fields

Post by Aimhere » Thu Jan 12, 2017 11:17 pm

Has anyone looked into this yet? I'd like to see this conflict resolved, not just worked-around.
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0

User avatar
mikolajek
Posts: 18
Joined: Wed Mar 19, 2014 5:46 pm
Location: Warsaw, Poland
Contact:

Re: NoScript blocking Lastpass icon in login fields

Post by mikolajek » Fri Jan 13, 2017 8:44 am

Yesterday an updated version of LastPass was released, however it's still affected, which further corroborates it's NoScript that kills it... But no new NS builds have been released since this issue popped up, which is quite annoying... :(
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0

User avatar
Giorgio Maone
Site Admin
Posts: 8743
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: NoScript blocking Lastpass icon in login fields

Post by Giorgio Maone » Sat Jan 14, 2017 9:52 pm

Sorry, I've finally setup a Lastpass account to test this but I cannot reproduce.
Are you testing on a clean profile with just Lastpass & NoScript installed?
Could you please give me step-by-step instructions to reproduce?
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:50.0) Gecko/20100101 Firefox/50.0

Aimhere
Posts: 10
Joined: Mon Feb 01, 2016 6:06 pm

Re: NoScript blocking Lastpass icon in login fields

Post by Aimhere » Sun Jan 15, 2017 2:13 pm

Giorgio Maone wrote:Sorry, I've finally setup a Lastpass account to test this but I cannot reproduce.
Are you testing on a clean profile with just Lastpass & NoScript installed?
Could you please give me step-by-step instructions to reproduce?


Yes, tested with a clean profile (only NoScript 2.9.5.2 and LastPass 4.1.35a), same behavior seen as with my regular profile.

Steps to reproduce:

1) Go to any site/page with a login form.
2) The LastPass inline icon appears at the right end of the username/password fields, as expected.
3) Click on the inline LastPass icon.
4) The LastPass icon changes to an "X" (close) button, but otherwise, NOTHING else happens. There is no pop-up LastPass dialog.

aimhere
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0

User avatar
Giorgio Maone
Site Admin
Posts: 8743
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: NoScript blocking Lastpass icon in login fields

Post by Giorgio Maone » Sun Jan 15, 2017 9:38 pm

Aimhere wrote:Steps to reproduce:

1) Go to any site/page with a login form.
2) The LastPass inline icon appears at the right end of the username/password fields, as expected.
3) Click on the inline LastPass icon.
4) The LastPass icon changes to an "X" (close) button, but otherwise, NOTHING else happens. There is no pop-up LastPass dialog.

Thank you.

If I follow these steps at https://github.com/login, the problem you're reporting happens no matter if I've got NoScript installed or not (I suspect the CSP rules enforced by the site as the "culprit").
If I do it here ( ucp.php?mode=login ) or on Bugzilla ( https://bugzilla.mozilla.org/index.cgi?GoAheadAndLogIn=1 ), I get a Lastpass dialog as expected, even with NoScript installed and blocking those sites.

Can you see anything different?
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:50.0) Gecko/20100101 Firefox/50.0

libove
Junior Member
Posts: 21
Joined: Thu Oct 07, 2010 4:39 pm

Re: NoScript blocking Lastpass icon in login fields

Post by libove » Mon Jan 16, 2017 1:06 am

I confirm that simply having NoScript installed and active causes the reported symptom on the github login page, in Firefox 50.1.0 with NoScript 2.9.5.2 on Windows 10 64-bit. Disabling NoScript and restarting Firefox enables LastPass to work correctly again.
So it's not something about the github login page - it's the presence of NoScript.
Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.2883.87 Safari/537.36

jbanana

Re: NoScript blocking Lastpass icon in login fields

Post by jbanana » Mon Jan 16, 2017 1:48 pm

Hey!

I am also using Lastpass and Noscript and have experienced the described issue since some time ago. Today i got annoyed enough to try to find what is the cause and disabling Noscript restored lastpass inplace form fill functionality. Giorgio, thanks for NoScript. It helps with my paranoia :P But please look into this issue some more.

Thanks,
James
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0

User avatar
Giorgio Maone
Site Admin
Posts: 8743
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: NoScript blocking Lastpass icon in login fields

Post by Giorgio Maone » Mon Jan 16, 2017 5:21 pm

Sorry, unfortunately I've got serious troubles at reliably reproducing this issue yet.

Could you please follow the following steps exactly as shown and check whether we're observing the same things?

  1. Install (or use) Firefox 50.1.0
  2. Create a clean profile
  3. Install Lastpass 3.3.2 and restart the browser
  4. Optionally create a Lastpass profile, if none already there (it seems Lastpass "remembers" it across browser profiles, when I re-create a clean profile to double check my previously entered fake credentials for Github where "miracolously" remembered)
  5. Open https://github.com/login and check the fields. If you've got credentials for Github, they are automatically filled. However clicking on the [...] icon in the fields does not popup any menu, it's just turned into [x] even if NoScript is not installed yet
  6. Open https://bugzilla.mozilla.org/index.cgi?GoAheadAndLogIn=1. If you've got credentials for Bugzilla, they're automatically filled. Clicking on the [...] in the fields pops up a contextual menu (as expected, I suppose, since NoScript is not installed yet)
  7. Now install NoScript's latest development build 2.9.5.3rc4 and restart Firefox
  8. Repeat steps 4 and 5: the results (for me) are the same as before installing NoScript, i.e. Github partially works (the [...] icon is not functional), while Bugzilla seems to fully work.
Does anybody experience anything different following these steps exactly (same software versions, same order)?
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:50.0) Gecko/20100101 Firefox/50.0

libove
Junior Member
Posts: 21
Joined: Thu Oct 07, 2010 4:39 pm

Re: NoScript blocking Lastpass icon in login fields

Post by libove » Mon Jan 16, 2017 5:45 pm

Hello Giorgio,
That's ... interesting.

Yes, I can reproduce what you say, about the same LastPass in-field icon-click failure symptom on the github.com login field withOUT NoScript installed.

But it is also still true that installing NoScript makes that same failure occur on ALL webpages in FireFox. Try the wsj.com login for example.

That the github.com login fails for LastPass even withOUT NoScript installed may help understand what NoScript's presence in Firefox does to interfere with LastPass, but it does still seem that NoScript itself is also causing a problem.
Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.2883.87 Safari/537.36

User avatar
Giorgio Maone
Site Admin
Posts: 8743
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: NoScript blocking Lastpass icon in login fields

Post by Giorgio Maone » Mon Jan 16, 2017 6:09 pm

libove wrote:Yes, I can reproduce what you say, about the same LastPass in-field icon-click failure symptom on the github.com login field withOUT NoScript installed.

But it is also still true that installing NoScript makes that same failure occur on ALL webpages in FireFox.

I also observed that Bugzilla does appear to work correctly with NoScript installed, so not ALL the webpages seem to be affected.
Or is there anything I'm missing?
I'm gonna check the WSJ site with and without NoScript, of course, but so far my problem was not being able to identify any difference between having NoScript installed or not.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:50.0) Gecko/20100101 Firefox/50.0

libove
Junior Member
Posts: 21
Joined: Thu Oct 07, 2010 4:39 pm

Re: NoScript blocking Lastpass icon in login fields

Post by libove » Mon Jan 16, 2017 6:20 pm

Hi Giorgio,
For me, the Bugzilla login form does NOT work, if I have NoScript installed. With NoScript disabled, then the Bugzilla login form works fine.
-Jay
Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.2883.87 Safari/537.36

jbanana

Re: NoScript blocking Lastpass icon in login fields

Post by jbanana » Mon Jan 16, 2017 7:12 pm

Hi!

Giorgio Maone wrote:Sorry, unfortunately I've got serious troubles at reliably reproducing this issue yet.

  1. Install Lastpass 3.3.2 and restart the browser


Please try with Lastpass 4.1.35a form here: https://lastpass.com/lastpassffx/xpi.php.
I followed your steps with this (LP version) being the only difference. Lastpass worked correctly for both Github and Bugzilla.
Then installed the dev version of NoScript and none of the sites show the last-pass pop-up any more.

If you'd like i can provide Teamviewer access to the VM that shows the issue.
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0

User avatar
mikolajek
Posts: 18
Joined: Wed Mar 19, 2014 5:46 pm
Location: Warsaw, Poland
Contact:

Re: NoScript blocking Lastpass icon in login fields

Post by mikolajek » Mon Jan 16, 2017 7:34 pm

jbanana wrote:Please try with Lastpass 4.1.35a form here: https://lastpass.com/lastpassffx/xpi.php.
I followed your steps with this (LP version) being the only difference. Lastpass worked correctly for both Github and Bugzilla.
Then installed the dev version of NoScript and none of the sites show the last-pass pop-up any more.

Negative in my case :(. I've updated LastPass to 4.1.35a this morning as this release has become official. Now updated NoScript to the latest stable version (2.9.5.2) and the issue is still present. Reverting NS back to 2.9.0.14 fixes the issue, as it used to do previously. Checked on both working and clean profiles...
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0

User avatar
Giorgio Maone
Site Admin
Posts: 8743
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: NoScript blocking Lastpass icon in login fields

Post by Giorgio Maone » Mon Jan 16, 2017 10:20 pm

Now that we've cleared that the problem does not affect the Lastpass version available on AMO (3.3.2) but only the development builds (4.x) (hence my initial inability to reproduce), please check NoScript's latest development build 2.9.5.3rc5, which should fix this incompatibility.
Thanks!
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:50.0) Gecko/20100101 Firefox/50.0

Post Reply