NoScript brokes Firefox WebExtension background pages

Ask for help about NoScript, no registration needed to post

Re: NoScript brokes Firefox WebExtension background pages

Postby aloishammer » Tue Sep 05, 2017 5:24 pm

Giorgio Maone wrote:Please check latest development build 5.0.10rc3, thanks.

404
Mozilla/5.0 (Windows NT 6.1; rv:45.0) Gecko/20100101 Firefox/45.0
aloishammer
Senior Member
 
Posts: 65
Joined: Mon Apr 20, 2009 4:03 pm

Re: NoScript brokes Firefox WebExtension background pages

Postby therube » Tue Sep 05, 2017 7:43 pm

URL on the website is wrong.
Try, https:// secure.informaction.com/download/betas/noscript-5.0.10rc3.xpi.
[broke the link cause newer rc is now out]
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 5.1; rv:52.0) Gecko/20100101 SeaMonkey/2.49.1
User avatar
therube
Ambassador
 
Posts: 6698
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: NoScript brokes Firefox WebExtension background pages

Postby Giorgio Maone » Tue Sep 05, 2017 8:03 pm

therube wrote:URL on the website is wrong.

Fixed, thanks.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0
User avatar
Giorgio Maone
Site Admin
 
Posts: 8119
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy

Re: NoScript brokes Firefox WebExtension background pages

Postby aloishammer » Wed Sep 06, 2017 6:20 pm

Giorgio Maone wrote:
therube wrote:URL on the website is wrong.

Fixed, thanks.

I still have moz-extension: pages marked as untrusted with rc3 and rc4, still operating in E10S mode. I'll try to test at least one other browser installation in non-E10S later tonight. ETA: I'm using Free Download Manager. The "Download with FDM" menu entry has been broken since I switched to E10S, and is unchanged with rc3/rc4. The FDM browser extension is supposedly "legacy / hybrid", with a WX component.

Also, I'm just now noticing that my FlashGot context menu entries have disappeared. They're still listed under Menu Wizard, but the context menu entries for pages, links, etc. aren't drawing in actual use. I don't know if this is breakage from E10S, NoScript, or something else. I don't even remember if FlashGot was ever made E10S-compatible. Perhaps the FlashGot author can comment. ;)
Mozilla/5.0 (Windows NT 6.1; rv:45.0) Gecko/20100101 Firefox/45.0
aloishammer
Senior Member
 
Posts: 65
Joined: Mon Apr 20, 2009 4:03 pm

Re: NoScript brokes Firefox WebExtension background pages

Postby aloishammer » Sun Sep 17, 2017 11:01 pm

Any updates? I haven't seen any new NoScript releases. Since this isn't a problem with my configuration, the newer Firefox Developer Edition releases haven't fixed a single thing for me. From all the other posts, I think it's pretty clear the problem, whatever it is, isn't only a problem for me, either.

No one has asked me for additional information, and I haven't gotten any DMs or any other form of communication regarding this flaw, either.
Mozilla/5.0 (Windows NT 6.1; rv:45.0) Gecko/20100101 Firefox/45.0
aloishammer
Senior Member
 
Posts: 65
Joined: Mon Apr 20, 2009 4:03 pm

Re: NoScript brokes Firefox WebExtension background pages

Postby aloishammer » Tue Sep 19, 2017 8:53 pm

aloishammer wrote:Any updates? I haven't seen any new NoScript releases. Since this isn't a problem with my configuration, the newer Firefox Developer Edition releases haven't fixed a single thing for me. From all the other posts, I think it's pretty clear the problem, whatever it is, isn't only a problem for me, either.

No one has asked me for additional information, and I haven't gotten any DMs or any other form of communication regarding this flaw, either.

Note: Switching to E10S has "fixed" (papered over) the problem in most of my Firefox profiles. However, I have a couple of profiles with extra, 3rd-party developer tools installed, and E10S is still causing strange lag and other performance issues there. I need E10S disabled, at least for the moment. With E10S disabled, NoScript breaks every WX addon again.

Also, even with E10S enabled, NoScript still claims that it's blocking moz-extension:// pages... it's just failing to do so. I hope that's not a separate problem; I haven't tested to see whether E10S is causing NoScript to fail to block site / page scripts entirely. I'm really not sure that I want to know the answer.
Mozilla/5.0 (Windows NT 6.1; rv:45.0) Gecko/20100101 Firefox/45.0
aloishammer
Senior Member
 
Posts: 65
Joined: Mon Apr 20, 2009 4:03 pm

Re: NoScript brokes Firefox WebExtension background pages

Postby aloishammer » Wed Sep 20, 2017 6:13 pm

Well, I guess this is a moot point, now. As soon as my Firefox Developer Edition installs started upgrading to 57.0b1, NoScript was disabled, and it's not coming back.
Mozilla/5.0 (Windows NT 6.1; rv:45.0) Gecko/20100101 Firefox/45.0
aloishammer
Senior Member
 
Posts: 65
Joined: Mon Apr 20, 2009 4:03 pm

Re: NoScript brokes Firefox WebExtension background pages

Postby Giorgio Maone » Tue Sep 26, 2017 8:01 pm

aloishammer wrote:Well, I guess this is a moot point, now. As soon as my Firefox Developer Edition installs started upgrading to 57.0b1, NoScript was disabled, and it's not coming back.

I cannot speak for Beta because it's too much an hassle to install, since it brutally takes on the release version, but flipping the extensions.legacy.enabled about:config preference to true still works for me on Firefox Developer Edition (57.0b3) and even in Nightly (58.0a1).
Please let me know.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0
User avatar
Giorgio Maone
Site Admin
 
Posts: 8119
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy

Re: NoScript brokes Firefox WebExtension background pages

Postby barbaz » Tue Sep 26, 2017 9:47 pm

Giorgio Maone wrote:I cannot speak for Beta because it's too much an hassle to install, since it brutally takes on the release version, but flipping the extensions.legacy.enabled about:config preference to true still works for me on Firefox Developer Edition (57.0b3) and even in Nightly (58.0a1).
Please let me know.

I can confirm that pref does nothing in 57.0b3 Beta.
*Always* check the changelogs BEFORE updating that important software!
Board search is currently partially broken: https://forums.informaction.com/viewtopic.php?f=14&t=21752
Workaround: use your favorite search engine, add site:forums.informaction.com to your query
-
barbaz
Senior Member
 
Posts: 7094
Joined: Sat Aug 03, 2013 5:45 pm

Re: NoScript brokes Firefox WebExtension background pages

Postby Giorgio Maone » Tue Sep 26, 2017 11:52 pm

barbaz wrote:
Giorgio Maone wrote:I cannot speak for Beta because it's too much an hassle to install, since it brutally takes on the release version, but flipping the extensions.legacy.enabled about:config preference to true still works for me on Firefox Developer Edition (57.0b3) and even in Nightly (58.0a1).
Please let me know.

I can confirm that pref does nothing in 57.0b3 Beta.

So it seems to be a branded (Beta, Release) vs unbranded (Developer Edition, Nightly) issue.
Does prepending "{73a6fe31-595d-460b-a920-fcc0f8843232}," to the extensions.legacy.exceptions about:config pref work in Beta as well, instead?
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0
User avatar
Giorgio Maone
Site Admin
 
Posts: 8119
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy

Re: NoScript brokes Firefox WebExtension background pages

Postby barbaz » Wed Sep 27, 2017 1:40 am

Giorgio Maone wrote:Does prepending "{73a6fe31-595d-460b-a920-fcc0f8843232}," to the extensions.legacy.exceptions about:config pref work in Beta as well, instead?

Still can't install NoScript.

I also tried various tricks to force the installation of NoScript. But in all cases, NoScript was disabled with no way to enable it.
*Always* check the changelogs BEFORE updating that important software!
Board search is currently partially broken: https://forums.informaction.com/viewtopic.php?f=14&t=21752
Workaround: use your favorite search engine, add site:forums.informaction.com to your query
-
barbaz
Senior Member
 
Posts: 7094
Joined: Sat Aug 03, 2013 5:45 pm

Re: NoScript brokes Firefox WebExtension background pages

Postby freebirdwil » Sat Sep 30, 2017 1:22 am

September 29, 2017 updated from NoScript 5.0.1 to 5.1, unable to log into my Norton Identity Safe Vault, which is a moz-web-extension address, switched back to 5.0.1 logged in fine.
Barbaz locked out my previous thread to this one...this is a lot of info seemingly more related to interaction of other add-ons, my issue is that all my needs worked fine until went from NoScript 5.0.1 to NoScript 5.1, so switched back...what the heck gonna lose NoScript altogether on November 14th when Mozilla kills all add-ons with v.57.0
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:56.0) Gecko/20100101 Firefox/56.0
freebirdwil
 

Re: NoScript brokes Firefox WebExtension background pages

Postby barbaz » Sat Sep 30, 2017 2:23 am

freebirdwil wrote:gonna lose NoScript altogether on November 14th when Mozilla kills all add-ons with v.57.0

Nope.
*Always* check the changelogs BEFORE updating that important software!
Board search is currently partially broken: https://forums.informaction.com/viewtopic.php?f=14&t=21752
Workaround: use your favorite search engine, add site:forums.informaction.com to your query
-
barbaz
Senior Member
 
Posts: 7094
Joined: Sat Aug 03, 2013 5:45 pm

Re: NoScript brokes Firefox WebExtension background pages

Postby Giorgio Maone » Sat Sep 30, 2017 6:41 pm

BTW, not sure the Internet Vault thing is related to this.
Most likely it's a WebWorker-related, breakage, please check latest development build 5.1.1rc1, thanks.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0
User avatar
Giorgio Maone
Site Admin
 
Posts: 8119
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy

Re: NoScript brokes Firefox WebExtension background pages

Postby barbaz » Sat Sep 30, 2017 7:31 pm

Giorgio Maone wrote:BTW, not sure the Internet Vault thing is related to this.

Sorry about that, I saw the guy had e10s disabled and figured that meant it was the same issue. Should we unlock the other thread?
*Always* check the changelogs BEFORE updating that important software!
Board search is currently partially broken: https://forums.informaction.com/viewtopic.php?f=14&t=21752
Workaround: use your favorite search engine, add site:forums.informaction.com to your query
-
barbaz
Senior Member
 
Posts: 7094
Joined: Sat Aug 03, 2013 5:45 pm

PreviousNext

Return to NoScript Support

Who is online

Users browsing this forum: Yahoo [Bot] and 14 guests