[FIXED] keep.google.com gives blank page with NS 2.6.9.37rc2

Ask for help about NoScript, no registration needed to post
uegede
Posts: 1
Joined: Fri Oct 02, 2015 11:02 am

[FIXED] keep.google.com gives blank page with NS 2.6.9.37rc2

Post by uegede » Fri Oct 02, 2015 11:17 am

Hello,

In FF41 with NS 2.6.9.37rc2 the Google Keep page https://keep.google.com/ is blank apart from the initial banner. Allowing google-analytics makes no difference. The only way I have found to get the page to fully render is to disable the NS plugin and restart the browser. Browser errors below

Regards,
Ulrik

Syncing... noscriptOverlay.js:1476:6
TypeError: L is not a function rs=AMdsDvApsG11qX5L1gKf7gg53Wc6dsYbuQ:277:255
TypeError: L is not a function rs=AMdsDvApsG11qX5L1gKf7gg53Wc6dsYbuQ:277:255
TypeError: L is not a function rs=AMdsDvApsG11qX5L1gKf7gg53Wc6dsYbuQ:277:255
Syncing... noscriptOverlay.js:1476:6
Syncing... noscriptOverlay.js:1476:6
TypeError: N is not a function rs=AMdsDvApsG11qX5L1gKf7gg53Wc6dsYbuQ:1546:109
TypeError: c.U is undefined rs=AMdsDvApsG11qX5L1gKf7gg53Wc6dsYbuQ:3300:449
TypeError: L is not a function rs=AMdsDvApsG11qX5L1gKf7gg53Wc6dsYbuQ:277:255
about:blank : Unable to run script because scripts are blocked internally. <unknown>
Syncing... noscriptOverlay.js:1476:6
TypeError: L is not a function rs=AMdsDvApsG11qX5L1gKf7gg53Wc6dsYbuQ:775:156
Syncing... noscriptOverlay.js:1476:6
TypeError: L is not a function rs=AMdsDvApsG11qX5L1gKf7gg53Wc6dsYbuQ:277:255
Syncing... noscriptOverlay.js:1476:6
Syncing... noscriptOverlay.js:1476:6
TypeError: L is not a function rs=AMdsDvApsG11qX5L1gKf7gg53Wc6dsYbuQ:277:255
Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:41.0) Gecko/20100101 Firefox/41.0

hackerman
Posts: 3
Joined: Fri Oct 02, 2015 6:54 pm

Re: Google keep gives blank page in FF41 with NS 2.6.9.37rc2

Post by hackerman » Fri Oct 02, 2015 6:59 pm

Same Firefox 41.0 w/ NoScript 2.6.9.37, my Google Keep doesn't work even with "scripts allowed globally". (Notes can not be edited.) It only works as soon as I disable NoScript in Addons Manager. Why is this?
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0

barbaz
Senior Member
Posts: 9678
Joined: Sat Aug 03, 2013 5:45 pm

Re: Google keep gives blank page in FF41 with NS 2.6.9.37rc2

Post by barbaz » Fri Oct 02, 2015 7:06 pm

Since there is no indication in the console messages, can you please find what is the latest working rc version of NoScript?
Old NoScript @
https://addons.mozilla.org/addon/noscript/versions
*or*
https://noscript.net/feed?c=100&t=a

Thanks.
*Always* check the changelogs BEFORE updating that important software!
-

hackerman
Posts: 3
Joined: Fri Oct 02, 2015 6:54 pm

Re: Google keep gives blank page in FF41 with NS 2.6.9.37rc2

Post by hackerman » Fri Oct 02, 2015 9:53 pm

I now tested it on 2.6.9.35 and 2.6.9.36, and Keep doesn't work. It does however work fine on 2.6.9.30 though.
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0

arkaic
Posts: 1
Joined: Sat Oct 03, 2015 1:18 pm

Re: Google keep gives blank page in FF41 with NS 2.6.9.37rc2

Post by arkaic » Sat Oct 03, 2015 1:22 pm

I'm having the same problem.

Firefox 41
NoScript 2.6.9.37
Mozilla/5.0 (X11; Linux x86_64; rv:41.0) Gecko/20100101 Firefox/41.0

jdigital
Posts: 9
Joined: Wed Mar 19, 2014 6:55 pm

Re: Google keep gives blank page in FF41 with NS 2.6.9.37rc2

Post by jdigital » Sun Oct 04, 2015 2:12 am

I am also seeing this problem. Google Keep is displaying a blank page (apart from the top bar).
Using Firefox 41 and NoScript 2.6.9.37

The issue appears to be related to Google Analytics. I normally have GA marked as an untrusted site. If I allow it, then Keep works properly. (I have allowed all other sites needed by Google Keep.)

The Firefox Console window shows error messages similar to the ones posted above.

Thanks for looking into this issue!
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0

codebeard

Re: Google keep gives blank page in FF41 with NS 2.6.9.37rc2

Post by codebeard » Sun Oct 04, 2015 3:37 am

The last rc version I can find that works properly is 2.6.9.32rc2. Google Keep does not load properly with 2.6.9.32.rc3.

Changelog says:

Code: Select all

    NoScript addons.mozilla.org release 2.6.9.32rc3
   
    v 2.6.9.32rc3
    =============================================================
    + Added domains required for Netflix playback to the default
      whitelist
    x Fixed inline script blocking broken by latest Nightlies
    x Fixed NOSCRIPT elements not being shown in script-blocked
      pages on Firefox betas
    x [Surrogate] shimmed or replaced code causing deprecations
    x [Surrogate] updated googletag replacement (thanks barbaz)
Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:40.0) Gecko/20100101 Firefox/40.0

Guest

Re: Google keep gives blank page in FF41 with NS 2.6.9.37rc2

Post by Guest » Tue Oct 06, 2015 7:20 pm

jdigital wrote:The issue appears to be related to Google Analytics. I normally have GA marked as an untrusted site. If I allow it, then Keep works properly. (I have allowed all other sites needed by Google Keep.)


I don't think so. Even with all scripts allowed, Google Keep can not edit your notes even though you can see them.
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0

jdigital
Posts: 9
Joined: Wed Mar 19, 2014 6:55 pm

Re: Google keep gives blank page in FF41 with NS 2.6.9.37rc2

Post by jdigital » Wed Oct 07, 2015 3:03 am

Guest wrote:
jdigital wrote:The issue appears to be related to Google Analytics. I normally have GA marked as an untrusted site. If I allow it, then Keep works properly. (I have allowed all other sites needed by Google Keep.)


I don't think so. Even with all scripts allowed, Google Keep can not edit your notes even though you can see them.


That's odd, I'm seeing different behavior. I just tested editing a note with Google Analytics allowed and it seems to work (edit the note, left the page, reopened Keep, and I saw the edited note). In any case, NoScript needs to be fixed to handle this problem.
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0

yeaber

Re: keep.google.com gives blank page in FF41 with NS 2.6.9.3

Post by yeaber » Fri Oct 09, 2015 7:27 pm

How is this still an issue? Even disabling noscript and restarting the browser isn't working anymore. It's not like keep is some noname site, it's freaking google for pete's sake. Do we really need to completely uninstall noscript just to access keep? It may also be worth noting that over tha past week or so, different solutions have worked, but now non of them are working. This really needs to be fixed asap.
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0

User avatar
therube
Ambassador
Posts: 7680
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: keep.google.com gives blank page in FF41 with NS 2.6.9.3

Post by therube » Fri Oct 09, 2015 7:45 pm

Even disabling noscript and restarting the browser isn't working anymore.

Then it doesn't sound like a NoScript issue.

As a test, create a new, clean Profile, load keep.google.com & see if it works.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 5.1; rv:41.0) Gecko/20100101 SeaMonkey/2.38

User avatar
therube
Ambassador
Posts: 7680
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: keep.google.com gives blank page in FF41 with NS 2.6.9.3

Post by therube » Fri Oct 09, 2015 8:30 pm

I haven't a clue about this "keep"?

New Profile
Created a "message"
- it displayed
Changed its color
Archived it or something

Quit

Restart FF

Load "keep"
"Your archived notes appear here" - BUT, nothing shows

There is always a "Connecting..." indication (on the page itself).
The "reload" icon doesn't appear to do anything.
Constant "Can't connect right now..." messages.

Oh, damn, out of the blue it displays.

I have no clue what the "keep" is doing or how it works, but as far as I'm concerned, Google can keep it.

That said, NoScript seems to be interfering, in some fashion, but I haven't a clue as to how. And I only say that because when you create a message, it does display, initially, but only with NoScript disabled.

Otherwise, with no extensions at all, "keep" is a pitiful excuse for whatever it might be intended to be. (Perhaps Chrome works there, no idea?)


Oh, & older NoScript's, & disabling all kind of NoScript settings, & Allowing Globally ... made no difference either. And nothing in Error Console.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 5.1; rv:41.0) Gecko/20100101 SeaMonkey/2.38

bldewolf

Re: keep.google.com gives blank page in FF41 with NS 2.6.9.3

Post by bldewolf » Wed Oct 21, 2015 10:26 pm

Google keep has been broken for me for the past day as well. I checked out the diff between 2.6.9.32rc3 and 2.6.9.32rc2 (thanks to codebeard on finding the last known good version) and noticed the Google Analytics script surrogate was changed.

So, with this in mind, I added a key in about:config named "noscript.surrogate.ga.exceptions" with a value of "*" and suddenly google keep works. I tried to find a pattern that would just allow keep, but "keep.google.com", "*.google.com", and "keep.google.com/*" didn't work. I'm not sure what format it wants or what domain it wants (GA might be an include from an include?) and I don't know how to figure that out.

I'm over script surrogates at this point, so I've set "noscript.surrogate.enabled" to False and now it works.
Mozilla/5.0 (X11; Linux x86_64; rv:41.0) Gecko/20100101 Firefox/41.0

barbaz
Senior Member
Posts: 9678
Joined: Sat Aug 03, 2013 5:45 pm

Re: keep.google.com gives blank page in FF41 with NS 2.6.9.3

Post by barbaz » Wed Oct 21, 2015 10:59 pm

@bldewolf: Thank you for your investigations and sharing your findings. It seems that the GA surrogate needs an update to cope with the change avoiding deprecated JS stuff.

Can someone who sees the issue, please:
1) make sure surrogates are enabled & the GA surrogate is default
2) set about:config > noscript.surrogate.debug to true
3) reproduce the problem and check the Browser Console (Ctrl-Shift-J) when this issue happens and post here any JS errors & related messages?
(if you don't know, turn off CSS warnings and post everything else you see)

I would guess that there is an error happening inside the surrogate itself, which get suppressed by default.
*Always* check the changelogs BEFORE updating that important software!
-

hackerman
Posts: 3
Joined: Fri Oct 02, 2015 6:54 pm

Re: keep.google.com gives blank page in FF41 with NS 2.6.9.3

Post by hackerman » Fri Oct 23, 2015 9:00 pm

bldewolf wrote:So, with this in mind, I added a key in about:config named "noscript.surrogate.ga.exceptions" with a value of "*" and suddenly google keep works.


Wow! I add that and I can finally edit notes on Firefox 41.0 w/ NoScript 2.6.9.38. Thanks.
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0

Post Reply