[INVALID] 4chan is not working with No Script on my system.

Ask for help about NoScript, no registration needed to post
EmoHobo
Posts: 3
Joined: Mon May 05, 2014 11:04 pm

[INVALID] 4chan is not working with No Script on my system.

Post by EmoHobo » Mon May 05, 2014 11:07 pm

»boards.4chan.org/g/catalog

The catalog is always blank and custom site rules no longer work, it works fine on other browsers, but not on Firefox, wanted to see if anyone else has this issue.

Attempting to click settings will say "Your browser doesn't allow local storage" is that just cookies? Because I have those enabled.

The only workaround I've been able to find is to disable NoScript, restart the browser, enable NoScript and Restart the Browser, it then works for awhile until I navigate away from the site entirely and come back. I already tried clearing the Cache and Cookies and had no luck.

I am running Windows 7, Firefox 29 and NoScript 2.6.8.23
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0

EmoHobo
Posts: 3
Joined: Mon May 05, 2014 11:04 pm

Re: 4chan is not working with No Script on my system.

Post by EmoHobo » Tue May 06, 2014 4:36 am

Here is a copy of my error console stuff if it's any help.

GET http://boards.4chan.org/g/catalog [HTTP/1.1 200 OK 103ms]
Use of getUserData() or setUserData() is deprecated. Use WeakMap or element.dataset instead. requestNotifier.js:64
NS_ERROR_FILE_CORRUPTED: Component returned failure code: 0x8052000b (NS_ERROR_FILE_CORRUPTED) [nsIDOMStorage.getItem] catalog.847.js:19
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0

User avatar
therube
Ambassador
Posts: 7687
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: 4chan is not working with No Script on my system.

Post by therube » Tue May 06, 2014 10:19 am

Allow:

+4cdn.org
+4chan.org

And your other thread for reference, http://www.dslreports.com/forum/r292259 ... er-browser.

And if its still not working, then you've likely got something else blocking.

Disable all extensions except for NoScript & see what you get.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0 SeaMonkey/2.26

EmoHobo
Posts: 3
Joined: Mon May 05, 2014 11:04 pm

Re: 4chan is not working with No Script on my system.

Post by EmoHobo » Tue May 06, 2014 11:34 am

It was actually a corrupted file inside of Firefox, it has hopefully been resolved for now.
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0

redwolfe_98
Senior Member
Posts: 55
Joined: Wed Apr 22, 2009 6:27 am
Location: South Carolina, USA

Re: [INVALID] 4chan is not working with No Script on my syst

Post by redwolfe_98 » Wed May 07, 2014 1:13 pm

emohobo, i was thinking that the problem might be that you have flash player set to block websites from storing data.. that can cause problems with some websites.. so, you could check flash player's settings and set it to allow websites to store data and see if that resolves the problem..

i had not problems with the "4chan.org" webpage that you cited, use FF 24.5 ESR, with the "noscript" and "adblock plus" addons..
Mozilla/5.0 (Windows NT 5.1; rv:24.0) Gecko/20100101 Firefox/24.0

Post Reply