[RESOLVED] NoScript 2.6.6 issue with lloydstsb UK Bank

Ask for help about NoScript, no registration needed to post
NeilWhite
Posts: 7
Joined: Wed Apr 17, 2013 9:02 pm

[RESOLVED] NoScript 2.6.6 issue with lloydstsb UK Bank

Post by NeilWhite » Wed Apr 17, 2013 9:44 pm

I am just a non-tecki user of NoScript on Firefox for last few years and have always used the NoScript Add-0n for my own protection. However today I had one of the routine updates to NoScript which I automatically "allowed". However this latest version 2.6.6 immediately blocked access to my online banking site in the UK (https://online.lloydstsb.co.uk/personal ... =hpIBlogon) I could no longer log in - it appears that NoScript 2.6.6 is blocking all access and I am unable to fix it.

I contacted the UK Bank teckies but they are unfamiliar with NoScript on Firefox and told me that the Noscript seemed to block Cookies!! They are now worried that a lot of their Bank .customers might soon be having the same problem.

I can access my bank OK if I remove NoScript from my Firefox but I feel safer with NoScript in place even though I have no idea how it works.

I then had a bright idea and re-installed the previous version of NoScript 2.6.5.9 and it works just fine.

Any suggestions would be welcome but keep it simple please. Neil
Mozilla/5.0 (Windows NT 5.1; rv:10.0.2) Gecko/20100101 Firefox/10.0.2

User avatar
Giorgio Maone
Site Admin
Posts: 8732
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: NoScript 2.6.6 issue with lloydstsb UK Bank website

Post by Giorgio Maone » Thu Apr 18, 2013 8:04 am

Does your Error Console (Ctrl+Shift+J) show any possibly related message when you attempt to login?
Could you please install and try 2.6.6 RC versions (starting with rc1 and up to rc5) until you find the most recent version which still work?
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0

NeilWhite
Posts: 7
Joined: Wed Apr 17, 2013 9:02 pm

Re: NoScript 2.6.6 issue with lloydstsb UK Bank website

Post by NeilWhite » Thu Apr 18, 2013 10:38 pm

I have done as you asked and I found that Version 2.6.6 works for rc1, rc2, rc3 and rc4 but fails on rc5.
Using ctrl,shift,J gave an error message on rc5 stating

Error: gBrowser.addProgressListener was called with a second argument, which is not supported. See bug 608628.
Source File: chrome://browser/content/tabbrowser.xml
Line: 1880.

I trust that this means more to you than it does to me.
Previous versions gave lots of Warnings but not " X Error" messages.

Thanks for help so far
Mozilla/5.0 (Windows NT 5.1; rv:10.0.2) Gecko/20100101 Firefox/10.0.2

User avatar
Giorgio Maone
Site Admin
Posts: 8732
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: NoScript 2.6.6 issue with lloydstsb UK Bank website

Post by Giorgio Maone » Thu Apr 18, 2013 11:13 pm

Thank you for your help.

NeilWhite wrote:Using ctrl,shift,J gave an error message on rc5 stating

Error: gBrowser.addProgressListener was called with a second argument, which is not supported. See bug 608628.
Source File: chrome://browser/content/tabbrowser.xml
Line: 1880.

That message is not from NoScript, but may hint at a conflict of some kind.
Does the problem happen also if you disable all your extensions except NoScript?
Does that message actually disappear if you downgrade to RC4 (even though the problem goes away)?
Also, is there any way for me to reproduce/disprove this issue without having a proper account on this bank?
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0

User avatar
therube
Ambassador
Posts: 7455
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: NoScript 2.6.6 issue with lloydstsb UK Bank website

Post by therube » Thu Apr 18, 2013 11:57 pm

I could no longer log in

What does that mean?
You can enter your username & password?
And then hit Return or something?

And what happens next?
UN/PW blank out & nothing?
You're told invalid?
Your UN/PW is accepted but the following page does not load?
Or...?

Would you re-post the URL to the bank, login page or whatever it was in the first post.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 SeaMonkey/2.19a2

NeilWhite
Posts: 7
Joined: Wed Apr 17, 2013 9:02 pm

Re: NoScript 2.6.6 issue with lloydstsb UK Bank website

Post by NeilWhite » Fri Apr 19, 2013 10:54 am

In answer to Giorgio Maone:
When anyone wants to Log-on to the Online Lloyds Bank system you go to Web Page
https://online.lloydstsb.co.uk/personal/logon/login.jsp
(anybody can get this initial page, and you have to enter the usual User ID and password and hit return.
The bank system then checks the validity of the Userid/password combination (and I think there may be some sort of hidden cookie exchange/request, if this is successful a new page appears asking for additional personal information of
three characters chosen at random from a unique word (say character 1,5 and 7) - it varies each time.

Up to 2.6.6 rc4, the above second stage is successful and after entering the 3 characters successfully, I can enter my
online account with the bank.

with 2.6.6 rc5 onwards, it is possible to enter the initial User ID and password successfully it seems, at which point my screen states
"Waiting" at the bottom of the web-page until, eventually it times out and the system crashes. I do not get to the second stage which asks for the three unique characters.

When the system crashes I get an additional message that I tried to copy and add to this Forum message but I then found that whatever had happened to my browser, it was still affecting my system because when I tried to add the info, I found that it was preventing me from adding the data to this Forum page. I then got the following message
" Bad Request

Your browser sent a request that this server could not understand.
Apache/2.2.15 (CentOS) Server at ariel.informaction.com Port 80"

I had to revert back to 2.6.6 rc4 in order to add these extra comments.
Now I will log off, change to 2.6.6 rc5 and try to log back into the forum again
Mozilla/5.0 (Windows NT 5.1; rv:10.0.2) Gecko/20100101 Firefox/10.0.2

NeilWhite
Posts: 7
Joined: Wed Apr 17, 2013 9:02 pm

Re: NoScript 2.6.6 issue with lloydstsb UK Bank website

Post by NeilWhite » Fri Apr 19, 2013 11:56 am

I have now set to 2.6.6 rc5 and taken a copy of the Lloyds error message which I will now attempt to copy to this forum page with the browser still in2.6.6/rc5 condition:

XML Parsing Error: no element found
Location: https://online.lloydstsb.co.uk/personal/primarylogin
Line Number 1, Column 1:

That seems to copy OK this time, so I will now try to submit (last attempt failed).

It failed again (when I say it failed, I mean that when I click the "Submit" button on this browser, nothing happened, it would not submit) so it appears that I cannot communicate to this forum successfully if I have 2.6.6 rc5 or later so it is not a banking problem. I have now reverted back to rc4 and I will try to submit this again.

Success. I now get same problem with my browser working to this forum. I cannot submit responses correctly (the submit button appears to freeze with no response) if I set my browser to 2.6.6/rc5. so it appears I have an issue working this forum with rc5 or higher which should make it easier to resolve given help from you clever guys
Mozilla/5.0 (Windows NT 5.1; rv:10.0.2) Gecko/20100101 Firefox/10.0.2

NeilWhite
Posts: 7
Joined: Wed Apr 17, 2013 9:02 pm

Re: NoScript 2.6.6 issue with lloydstsb UK Bank website

Post by NeilWhite » Fri Apr 19, 2013 6:58 pm

Current position: Friday 19 April.
As a result of following support from Giorgio Maone & The Rube:Ambassador I have now discovered that if I use Versions 2.6.6/RC4 or earlier my Internet access to Bank Website AND THIS FORUM WEBSITE performs correctly.

However if I use Versions 2.6.6/RC5 or later, access to my Online Bank system fails BUT ALSO I CAN THEN NOLONGER ACCESS THIS FORUM WEBSITE. If I try to log on to this site, I enter my Username OK but when I enter my forum Password, I get the same error as with the Bank website - it fails to register my password and times out.

If I revert to 2.6.6 /RC4, I can then access this Forum with my Username and Password as normal.
Then, while on this forum, if I update from 2.6.6/RC4 to 2.6.6/RC5, I can still read this forum AND if I then try to submit some additional comments (like now), and add the comments it will not work [Submit fails to work, it just times out with an error message].
I will now update to 2.6.6/RC5 and check the error message (Ctrl+Shift+J)
-------------------------------------------------
This was done and I edited this message to state the fact but when I clicked Submit - it failed to work
The resultant error message was as follows:
---------------------------------------------------
Bad Request

Your browser sent a request that this server could not understand.
Apache/2.2.15 (CentOS) Server at ariel.informaction.com Port 80
--------------------------------------------------
I had to revert back to 2.6.6/RC4, take a copy of the above Ctrl+Shift+J data so I could copy it back for you to see.

If you can find out why I have this problem with this Forum Website, then it will probably resolve my Bank problem too.
Mozilla/5.0 (Windows NT 5.1; rv:10.0.2) Gecko/20100101 Firefox/10.0.2

User avatar
therube
Ambassador
Posts: 7455
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: NoScript 2.6.6 issue with lloydstsb UK Bank website

Post by therube » Fri Apr 19, 2013 8:55 pm

?

http://support.mozilla.org/en-US/questions/926754
Bad Request Your browser sent a request that this server could not understand
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 5.1; rv:22.0) Gecko/20100101 SeaMonkey/2.19a2

User avatar
Giorgio Maone
Site Admin
Posts: 8732
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: NoScript 2.6.6 issue with lloydstsb UK Bank website

Post by Giorgio Maone » Sat Apr 20, 2013 9:09 am

Login works for me on these forums, tested on Fx 3.6, Fx 17.5 (ESR), Fx 20 (current stable) and Nightly.

Firefox 10? Why? Did you try upgrading?
Also, did you try on a clean profile with just NoScript installed?
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0

NeilWhite
Posts: 7
Joined: Wed Apr 17, 2013 9:02 pm

Re: NoScript 2.6.6 issue with lloydstsb UK Bank website

Post by NeilWhite » Tue Apr 23, 2013 11:54 am

I think you have hit the prime source of my problem - I was using a very old version of Firefox (Version 10).

The background is that I abandoned my Windows PC just over a year ago and moved to Apple iMac. Unfortunately the iMac died with a Login Board/Power Supply failure and had to go back under extended Warrenty for repair. As a stop-gap, I dug out my old Windows PC which had an old copy of Firefox (Version 10) because at that time I could not get later versions of Firefox to support Norton's "Identity Safe & Safe Web" so I stopped automatic Firefox updates.

I have now Updated Firefox on the Windows PC to Version 20.0.1 and the Norton software now works fine.
I also have my iMac back again and am on it now. I will try the Noscript updates again and report back
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:20.0) Gecko/20100101 Firefox/20.0

NeilWhite
Posts: 7
Joined: Wed Apr 17, 2013 9:02 pm

Re: NoScript 2.6.6 issue with lloydstsb UK Bank website

Post by NeilWhite » Tue Apr 23, 2013 12:13 pm

I have now moved from my iMacPC, back to my old Windows PC which I have been using this last two weeks while the iMac was being repaired and I have updated NoScript to the lastest 2.6.6 version.

Now this PC works just fine on the Lloyds Bank Website using Firefox 20.0.1 and NoScript 2.6.6.

The problem seems to have been due to me using the old Firefox version 10.

I can also confirm that Firefox Version 20.0 on the Apple iMac with Noscript 2.6.6 also works fine.

Problem solved - many thanks.
Mozilla/5.0 (Windows NT 5.1; rv:20.0) Gecko/20100101 Firefox/20.0

barbaz
Senior Member
Posts: 9262
Joined: Sat Aug 03, 2013 5:45 pm

Re: [RESOLVED] NoScript 2.6.6 issue with lloydstsb UK Bank

Post by barbaz » Fri Aug 21, 2015 10:19 am

@Barry1: your posts are @ viewtopic.php?f=7&t=21178
*Always* check the changelogs BEFORE updating that important software!
-

Post Reply