keyboard shortcut not working?

Ask for help about NoScript, no registration needed to post
jalyst
Posts: 10
Joined: Tue Apr 14, 2009 4:18 pm

keyboard shortcut not working?

Post by jalyst » Sun May 17, 2009 1:10 pm

http://noscript.net/features#kbshort

ctrl + shift + \

As explained at the link above does not work with 3.5b4 + latest NS...
I followed all instructions and even tried a few other mods in about:config but still no go...

Can someone else confirm this is not working for them?

Cheers,
Jed
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-GB; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4

User avatar
Giorgio Maone
Site Admin
Posts: 8732
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: keyboard shortcut not working?

Post by Giorgio Maone » Sun May 17, 2009 1:42 pm

Works for me on Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.1b5pre) Gecko/20090516 Shiretoko/3.5b5pre.
Maybe a Mac OS X specific issue. Firing up a Leopard test host to check...
Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10 (.NET CLR 3.5.30729)

Alan Baxter
Ambassador
Posts: 1586
Joined: Fri Mar 20, 2009 4:47 am
Location: Colorado, USA

Re: keyboard shortcut not working?

Post by Alan Baxter » Sun May 17, 2009 1:47 pm

It works for me.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4
NS 1.9.2.93 with default settings
Default theme with no other extensions
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10

ma1/mac

Re: keyboard shortcut not working?

Post by ma1/mac » Sun May 17, 2009 1:53 pm

Working for me on Fx 3.0.10 on Leopard, downloading Shiretoko for final test.
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.10) Gecko/2009042315 Firefox/3.0.10

User avatar
Giorgio Maone
Site Admin
Posts: 8732
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: keyboard shortcut not working?

Post by Giorgio Maone » Sun May 17, 2009 2:09 pm

Weird, I can confirm it does not work on Shiretoko / Mac :(
However, I changed noscript.keys.toggle about:config preference to ctrl shift T (for Toggle) and it works as expected.
Must check if there's a conflict with some other major feature or extension, and if not change the default maybe...
Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10 (.NET CLR 3.5.30729)

jalyst
Posts: 10
Joined: Tue Apr 14, 2009 4:18 pm

Re: keyboard shortcut not working?

Post by jalyst » Sun May 17, 2009 2:31 pm

Giorgio Maone wrote:However, I changed noscript.keys.toggle about:config preference to ctrl shift T (for Toggle) and it works as expected.
Must check if there's a conflict with some other major feature or extension, and if not change the default maybe...


That's fixed it for me too, thanks!
I tried changing it to ctrl shift \ before posting but that did not work...
hmm I hope it doesn't cause problems with other addons that rely on that combo.
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-GB; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4

Cosmo

Re: keyboard shortcut not working?

Post by Cosmo » Sat Jun 06, 2009 6:03 pm

ctrl-shift-\ does not work here.
I think, the reason is the point, that on German keyboard layout \ is set on an AltGR-key-combination, that does not work in conjunction with ctrl-shift.

Furthermore: You cannot take ctrl-shift-T, as this is predefined in FF for restoring the last closed tab.

Another finding: If I press ctrl-shift-S the first time, the NS-menu popups correctly. If I close the menu and press the same combination another time, NS asks and warns me, if I want to globally allow scripts.
Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10

User avatar
therube
Ambassador
Posts: 7455
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: keyboard shortcut not working?

Post by therube » Sat Jun 06, 2009 6:55 pm

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1pre) Gecko/20090531 SeaMonkey/2.0b1pre

Cosmo

Re: keyboard shortcut not working?

Post by Cosmo » Sat Jun 06, 2009 7:13 pm

Maybe a de-problem?

Sorry, I forgot to mention my extensions:

- Deutsches Wörterbuch 1.0.1
- Java Console
- Java Quick Starter
- MR Tech Toolkit [de] 6.0.3.3
- NoScript 1.9.3.3
- United States English Dictionary 3.0.3 - English United States (en-US) spellchecking dictionary

So nothing, that is likely to interfere with the keyboard settings, regarding ctrl-shift-S and ctrl-shift-\.

P.S. Regarding ctrl-shift-T: MR Tech Toolkit (somewhere positively mentioned by Giorgio) makes the same mistake by using this (at least with German locale) by default. So, using this combination for NS would lead to (at least) 2 conflicts.
Suggestion: What about ctrl-shift-backspace? Doing a test with that shows it functional here.
Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10

Nan M
Ambassador
Posts: 102
Joined: Thu Mar 19, 2009 12:44 pm

Re: keyboard shortcut not working?

Post by Nan M » Sun Jun 07, 2009 7:28 am

Suggestion: What about ctrl-shift-backspace? Doing a test with that shows it functional here.


That's what I used for NS with zero conflicts in OS X 10.3.x for 3 years.
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.10) Gecko/2009042523 Ubuntu/9.04 (jaunty) Firefox/3.0.10

Post Reply