False Detect Previous Version Firefox

Ask for help about NoScript, no registration needed to post

False Detect Previous Version Firefox

Postby gill » Wed Nov 07, 2018 7:20 am

I cannot install NoScript 10 in FF Quantum 63.1 because I get a false detect FF version 48. I upgraded from 52.9 ESR. How can I clear up this detection error so I can install the latest NoScript? This is on Win10, but will this also happen on Win7? Yes I know I can wipe out all remnants of previous Mozilla folders but that kills all my customization. I was so pleased that the upgrade to 63 kept all the details of my layout except the expired extensions. Then this happened. I will not use a browser without script control. I had to roll back to restore point. There is some little "legacy" ini or reg file in there messing up the install. Maybe it is peculiar to ESR?
Mozilla/5.0 (Windows NT 6.1; WOW64; Trident/7.0; rv:11.0) like Gecko
gill
 
Posts: 4
Joined: Wed Nov 07, 2018 6:51 am

Re: False Detect Previous Version Firefox

Postby therube » Wed Nov 07, 2018 12:49 pm

Do you have the about:config Pref, general.useragent.override set?
If so, what is it set to?
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0 SeaMonkey/2.49.5
User avatar
therube
Ambassador
 
Posts: 7170
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: False Detect Previous Version Firefox

Postby gill » Wed Nov 07, 2018 6:23 pm

general.useragent.override;Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/601.7.7 (KHTML, like Gecko) Version/9.1.2 Safari/601.7.7

I had random user agent installed previous - now uninstalled since the attempted upgrade. I will install newer "Quantum" Random Agent again after this is set up.
Mozilla/5.0 (Windows NT 6.1; WOW64; Trident/7.0; rv:11.0) like Gecko
gill
 
Posts: 4
Joined: Wed Nov 07, 2018 6:51 am

Re: False Detect Previous Version Firefox

Postby fenix » Thu Nov 08, 2018 9:13 am

Hello gill.

Probably it's not related, but can You show the value of 'privacy.resistFingerprint' option? (You can use about:config?filter=privacy.resistFingerprint to access 'about:config' page; just copy this to Firefox address bar and press 'ENTER'). I'm asking about this, because if 'p.rF' value is set to 'true' then Firefox version is "faked" etc. (search for more informations, if You want).

That's the only one thing, that came to my mind. Sorry.

Thanks, best regards.
Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0
fenix
 

Re: False Detect Previous Version Firefox

Postby gill » Thu Nov 08, 2018 1:48 pm

This is too ridiculous. NS Product coders cannot tell me where NoScript obtains the FF version ID? FF API must have the real product version in a file in constant use somewhere. What is NoScript looking at when it thinks FFv 5.92ESR is ver 48? Its got to be some junk remnants of Random User Agent. I repeat reinstall v63.1 and it NEVER over-writes this junk file. I had to completely strip out ALL browser folders and configs in Win7 to get the new NoScript to work in an old W7 test box. I'll try to manually overwrite the general.useragent.override to Mozilla/6.0 - OR keep using FF v5xx. I'll post if it works
Mozilla/5.0 (Windows NT 6.1; WOW64; Trident/7.0; rv:11.0) like Gecko
gill
 
Posts: 4
Joined: Wed Nov 07, 2018 6:51 am

Re: False Detect Previous Version Firefox

Postby Giorgio Maone » Thu Nov 08, 2018 1:57 pm

gill wrote:What is NoScript looking at when it thinks FFv 5.92ESR is ver 48?

NoScript doesn't look anywhere. If something is preventing NoScript from being installed, that's Firefox's add-ons manager (i.e. Firefox itself).
I strongly suspect you've got a broken profile, probably due to all the junk accumulated across several major Firefox version updates.
One way to get rid of it is starting from scratch with a fresh profile and using Firefox sync to migrate the most important customizations of yours (of course you should enable Sync on the old profile before creating the new one).
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:64.0) Gecko/20100101 Firefox/64.0
User avatar
Giorgio Maone
Site Admin
 
Posts: 8634
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy


Return to NoScript Support

Who is online

Users browsing this forum: No registered users and 24 guests