Google Maps

Ask for help about NoScript, no registration needed to post
The_Tango

Google Maps

Post by The_Tango » Thu Jan 16, 2014 3:31 pm

Seems to have broken google maps - the only way to get google maps to work is to disable noscript

Any fix?
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0

spartanhooah

Re: Google Maps

Post by spartanhooah » Mon Aug 11, 2014 1:59 pm

Sorry for the necro, but I'm experiencing the same problem. I can zoom in and out sometimes, but searches never go (I see the loading animation endlessly), and the Street View box is grey. I've allowed google.com. Any ideas?
Mozilla/5.0 (Windows NT 6.1; rv:31.0) Gecko/20100101 Firefox/31.0

barbaz
Senior Member
Posts: 9313
Joined: Sat Aug 03, 2013 5:45 pm

Re: Google Maps

Post by barbaz » Mon Aug 11, 2014 4:39 pm

There is a change on their end, now seems to need a "panoramio.com" Allowed for it to work on OS X. So WFM, with (in all):

Code: Select all

+google.com
+gstatic.com
+ggpht.com
+panoramio.com

(if you don't see that last one in the menu, add it manually. I no longer see it in the menu but keyboard navigation was initially broken without it.)
Does that help?

Also, are you using a fake user-agent string on Google Maps? (if you don't know, the answer is no)
*Always* check the changelogs BEFORE updating that important software!
Mozilla/5.0 (X11; OpenBSD amd64; rv:26.0) Gecko/20100101 Firefox/26.0 SeaMonkey/2.23

spartanhooah

Re: Google Maps

Post by spartanhooah » Mon Aug 11, 2014 8:57 pm

That did not help. I don't know if it matters, but I'd seen ggpht.com mentioned a couple places when I searched for this problem, but that site wasn't showing up in my NoScript menu. I added that as well as panoramio.com. I have not change my user-agent string.
Mozilla/5.0 (Windows NT 6.1; rv:31.0) Gecko/20100101 Firefox/31.0

barbaz
Senior Member
Posts: 9313
Joined: Sat Aug 03, 2013 5:45 pm

Re: Google Maps

Post by barbaz » Mon Aug 11, 2014 9:54 pm

Weird, for some reason you're getting the old Flash-based Google Maps :?:
If I force Google to give me the Flash-based maps by using a Firefox 21 user-agent, it mostly works, but keyboard navigation does not work at all, and I see this in the Error Console:

Code: Select all

[NoScript] Force text/plain for missing content-type on https://maps.google.com/mapfiles/home3.html

Although I understand why NS would include a feature like that, I've no idea how to temporarily disable it or add exceptions, sorry :(

spartanhooah wrote:the Street View box is grey

This might be Firefox's built-in plugin click-to-play (check the left of the address bar for a plugin icon, and if you see one there, click on it).
*Always* check the changelogs BEFORE updating that important software!
Mozilla/5.0 (X11; OpenBSD amd64; rv:26.0) Gecko/20100101 Firefox/26.0 SeaMonkey/2.23

spartanhooah

Re: Google Maps

Post by spartanhooah » Tue Aug 12, 2014 12:17 pm

barbaz wrote:Weird, for some reason you're getting the old Flash-based Google Maps :?:


I don't believe I am. The url always gets "/preview" appended to it, and the interface looks the same as if I view it in e.g. Chrome. Unless they updated their Flash version to be visually similar?
Mozilla/5.0 (Windows NT 6.1; rv:31.0) Gecko/20100101 Firefox/31.0

s

Re: Google Maps

Post by s » Thu Aug 14, 2014 10:40 pm

Well, sorry about the bother, but it turned out that SmartVideo for YouTube was the culprit, not NoScript. I've contacted the dev for that add-on. Thanks for trying to help anyway!
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0

Post Reply