Menu's and details in noscript missing

Ask for help about NoScript, no registration needed to post
GenTooMan
Posts: 1
Joined: Wed Sep 11, 2019 3:00 pm

Menu's and details in noscript missing

Post by GenTooMan » Wed Sep 11, 2019 4:08 pm

I am using FF 60.9.0esr (64-bit) and noscript 11.0.3 under debian linux buster.
That said the same issue as the thread (viewtopic.php?f=7&t=25605) exists with a bit more too it (I think?)

So first of the right click context menu does not work (as expected), instead it opens the tool bar menu (if displayed).
If the tool bar is disabled this action means you can't bring up the noscript via right click menu. That might be an artifact of Mozilla.com design changes with quantum and likely it may be difficult to "fix".
A suggestion is instead of the method of using about:config dom.disable_window_open_feature.toolbar;true perhaps this can be handled in noscript until the noscript menu closes and it automatically opens up the menu correctly for the user so they can click away. Then noscript cleans up disappearing everything as before when the no script menu is excited (even if accidentally).

That said following the suggested fix which changes about:config and forbiding disabling the tool bar has a strange side effect.
When you work (yes work) to open the Noscript menu, web site addresses and status symbol (red green lock) are not displayed instead a blank section (polar bear in snow storm?) is shown. The menu is visible but it's a bit difficult to ascertain what to do based on not know what (nefarious?) website might be blocked in the list.

I hope this is helpful to whomever it may concern.
Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0

barbaz
Senior Member
Posts: 9180
Joined: Sat Aug 03, 2013 5:45 pm

Re: Menu's and details in noscript missing

Post by barbaz » Wed Sep 11, 2019 5:07 pm

GenTooMan wrote:
Wed Sep 11, 2019 4:08 pm
That said following the suggested fix which changes about:config and forbiding disabling the tool bar has a strange side effect.
When you work (yes work) to open the Noscript menu, web site addresses and status symbol (red green lock) are not displayed instead a blank section (polar bear in snow storm?) is shown. The menu is visible but it's a bit difficult to ascertain what to do based on not know what (nefarious?) website might be blocked in the list.
Could you please post a screenshot of this?
*Always* check the changelogs BEFORE updating that important software!
-

Post Reply